Installer Wifi, ndiswrapper not found

[Résolu/Fermé]
Signaler
Messages postés
16400
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2021
-
Messages postés
16400
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2021
-
Bonjour,

J'essaye de mettre le WiFi sur Lubuntu 12.04 (32 bits) fraîchement installé.
J'ai pour cela un dongle UR054g (Inventel), et je suis ce tutoriel : wifi_ur054g_r01_v1.1

Hier cela marchait très bien sur Linux Mint 12 LXDE, et voici ce que j'avais fait :
Après avoir téléchargé et décompressé le fichier zip sur porciello j'ai tapé :

sudo ndiswrapper -i PRISMA02.inf
sudo modprobe -r prism54
sudo modprobe -r prism54usb
sudo modprobe -r p54usb
sudo modprobe -r p54common 
sudo ndiswrapper -m
sudo modprobe ndiswrapper
echo "ndiswrapper"|sudo tee -a /etc/modules

Sur Lubuntu, je n'ai cependant pas autant de "chance" puisqu'il ne connait pas ndiswrapper, alors comme j'ai accès à la partition de Mint, j'ai fait un copier-coller depuis /usr/sbin de ndiswrapper et ndiswrapper-1.9, ça a donc fonctionné jusqu'à modprobe ndiswrapper qui me met :

FATAL: Module ndiswrapper not found.
J'avoue que je n'y connais pas grand chose en installation Linux, j'essaie de donner une nouvelle vie à un ordinateur sous XP mais sans internet ce n'est même pas la peine... Si vous savez donc comment faire l'installation de ce dongle WiFi sans internet (du moins pas sur le Lubuntu sur lequel je veux l'installer), je vous en remercie d'avance !

5 réponses


Bonjour,
Juste copier coller des fichiers ndiswrapper ne suffit pas.
Avec un PC ayant internet il faut récupérer le .deb de ndiswrapper:
https://packages.ubuntu.com/hardy/i386/ndiswrapper-utils-1.9/download
le mettre sur le PC isolé via une clef usb et ensuite lancer l'installation comme expliqué ici au paragrephe 3:
http://doc.ubuntu-fr.org/tutoriel/comment_installer_un_paquet
Si lors de l'installation il est question de dépendances non satisfaites il faut refaire la même chose pour chacune (et attention aux compatibilités de version!).
Ce peut être assez laborieux.
Si la méthode échoue, le plus simple serait de mettre le PC isolé sur le Net.
Perso j'utilise cet article sur un PC dont la carte réseau est HS:
http://www.google.fr/shopping/product/7535481848796559872?hl=fr
Bonne journée
Messages postés
16400
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2021
2 879
Merci de ta réponse, effectivement il y a de nombreuses dépendances qui ont elles même des dépendances... mais au niveau des versions est-ce qu'il faut aller sur hardy comme avec ton lien ou plutôt sur precise (pangolin) vu que c'est la version 12.04 que j'ai ?
Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 382
Salut,

Celui de Precise tant qu'à faire ;-))
https://packages.ubuntu.com/precise/i386/ndiswrapper-utils-1.9/download
Utilisateur anonyme
'jour,
Tout à fait, me suis un peu bien mélangé les pattes dans les versions.
Messages postés
16400
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2021
2 879
J'ai donc installé ndiswrapper et ses dépendances :

ndiswrapper-utils-1.9
  ndiswrapper-common
  libc6
    libc-bin
    libgcc1
      multiarch-support
      gcc-4.6-base
    tzdata
      debconf
        perlbase

Cependant j'ai toujours la même erreur : Module ndiswrapper not found.
Remarque : si je refais les opérations du tutoriel qui précédaient je me retrouve avec :
$ sudo ndiswrapper -i PRISMA02.inf
driver prisma02 is already installed

Est-ce que l'installation que j'ai faite hier avec le fichier copier de Mint est toujours valable, ou comment faire pour la supprimer sinon ?
Et donc, comment faire pour que le module ndiswrapper soit trouvé ?

J'avoue que là, j'ai des lignes de code à taper, et je tape, mais je ne comprends pas ce que je fais ^^

Merci de votre aide.
Messages postés
16400
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2021
2 879
Après quelques cheveux blancs précoces, j'ai réussi !
Il fallait également installer ndiswrapper-dkms (et ses dépendances)
Je vais donc pouvoir finir mon installation avec les mises à jours et autres réjouissances.

Merci à vous !
Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 382
Merci du retour.

Bonne continuation.
Messages postés
16400
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2021
2 879
J'ai encore une petite (?) erreur, lorsque j'ai installé les dépendances j'ai pris "perl" sur la version "hardy", et du coup maintenant il crie son désespoire ne pas trouver celui qu'il attend :

KX@KX:~$ sudo apt-get install -f
[sudo] password for KX: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés : 
  perl
Paquets suggérés :
  perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
Les paquets suivants seront mis à jour :
  perl
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/3 676 ko dans les archives.
Après cette opération, 91,1 ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? O
dpkg : des problèmes de dépendances empêchent la configuration de perl :
 perl dépend de libdb4.6 ; cependant :
  Le paquet libdb4.6 n'est pas installé.
 perl dépend de perl-base (= 5.8.8-12ubuntu0.5) ; cependant :
  La version de perl-base sur le système est 5.14.2-6ubuntu2.
dpkg : erreur de traitement de perl (--configure) :
 problèmes de dépendances - laissé non configuré
Aucun rapport « apport » écrit car MaxReports a déjà été atteint
Des erreurs ont été rencontrées pendant l'exécution :
 perl
E: Sub-process /usr/bin/dpkg returned an error code (1)
KX@KX:~$ 

Est-ce que vous avez des idées ? Moi j'en ai bien une c'est de réinstaller tout Lubuntu (maintenant que j'ai les bons .deb ça devrait aller tout seul) mais je trouve que c'est un peu bourrin comme méthode...
Utilisateur anonyme
Peut être installer la version de Perl correspondant au perl-base 5.14.2-6 (perl 5.14.2-6 donc). La dernière version est 5.14.2-9.
En sachant qu'il va toujours manquer le libdb (libdb5.1 pour la dernière) et ses dépendances (https://packages.ubuntu.com/fr/natty/libdb5.1-java-gcj
Messages postés
16400
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2021
2 879
Bon j'ai pas réussi, alors j'ai tout réinstallé Lubuntu proprement, j'ai refait toutes mes installations de dépendances (sauf perl du coup), et là ça marche bien... c'est donc définitivement résolu ^^