Problème Installation Skype sous Sabayon

[Résolu/Fermé]
Signaler
Messages postés
6
Date d'inscription
samedi 12 mai 2012
Statut
Membre
Dernière intervention
12 mai 2015
-
 xaw -
Bonjour,

Je viens d'installer Sabayon pour un ami.
C'est une distribution que je ne connais pas du tout.

Je rencontre une erreur lors de ma commande "emerge skype"

Voici l'erreur :

localhost skype-2.2.0.35 # emerge skype

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!
[ebuild N ] app-admin/eselect-qtgraphicssystem-1.1.1
[ebuild N ] dev-util/pkgconfig-0.26 USE="-hardened"
[ebuild N ] virtual/pkgconfig-0
[ebuild N ] x11-libs/qt-core-4.8.1-r2 USE="exceptions glib iconv qt3support ssl (-aqua) (-c++0x) -debug -optimized-qmake -pch (-qpa)"
[ebuild N ] x11-libs/qt-dbus-4.8.1 USE="exceptions (-aqua) (-c++0x) -debug -pch (-qpa)"
[ebuild N ] x11-libs/qt-script-4.8.1 USE="exceptions iconv jit (-aqua) (-c++0x) -debug -pch (-qpa)"
[ebuild N ] x11-libs/qt-gui-4.8.1-r1 USE="accessibility cups dbus exceptions gif glib mng qt3support tiff xinerama xv (-aqua) (-c++0x) -debug -egl -gtkstyle -nas -nis -pch (-qpa) -trace"
[ebuild N ] x11-libs/qt-sql-4.8.1 USE="exceptions mysql qt3support sqlite (-aqua) (-c++0x) -debug -firebird -freetds -odbc -pch -postgres (-qpa)"
[ebuild N ] x11-libs/qt-qt3support-4.8.1 USE="accessibility exceptions (-aqua) (-c++0x) -debug -pch (-qpa)"
[ebuild N ] net-im/skype-2.2.0.35-r1 USE="-pax_kernel -qt-static"

The following license changes are necessary to proceed:
#required by skype (argument)
>=net-im/skype-2.2.0.35-r1 skype-eula

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

!!! The following installed packages are masked:
- net-wireless/broadcom-sta-5.100.82.112-r2::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

- www-plugins/adobe-flash-11.2.202.228::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.



En cherchant sur Internet, je n'ai pas trouvé de solutions corrigeant mon soucis.

J'ai essayé d'ajouter des lignes dans mes package.mask .use .unmask sans succès.



Auriez vous une piste afin de ne plus avoir ces messages d'erreurs ?


En attente d'une réponse de votre part.

Cdt.

Nawae

6 réponses

Messages postés
30226
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 octobre 2021
7 198
À première vue, ta distribution ressemble fortement une gentoo. Vu le message il faut effectivement "unmask" le paquet net-wireless/broadcom-sta et www-plugins/adobe-flash. Apparemment tu peux passer l'option --autounmask-write pour corriger ça automatiquement, ce qui donnerait un truc du genre :

emerge -auD --autounmask-write skype


Bonne chance
Messages postés
6
Date d'inscription
samedi 12 mai 2012
Statut
Membre
Dernière intervention
12 mai 2015

Bonjour Mamiemando,

Je te remercie de ta réponse. On avance, voilà le résultat de la commande que tu m'as demandé de passer (désolé c'est un peu long :S ) :


* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


* IMPORTANT: 4 config files in '/etc/portage' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-kernel/linux-headers-3.3 [3.1]
[ebuild N ] virtual/os-headers-0
[ebuild U ] sys-libs/glibc-2.14.1-r3 [2.13-r4] USE="(-hardened*)"
[ebuild U ] dev-libs/expat-2.1.0-r1 [2.0.1-r6]
[ebuild U ] dev-libs/icu-49.1.1-r1 [4.8.1.1-r1]
[ebuild U ] sys-devel/gcc-config-1.7 [1.5-r2]
[ebuild U ] sys-devel/binutils-config-3-r3 [3-r1]
[ebuild N ] sys-apps/hwids-20120507
[ebuild U ] sys-devel/autoconf-wrapper-12 [10-r1]
[ebuild U ] sys-devel/automake-wrapper-7 [6]
[ebuild U ] app-portage/portage-utils-0.10 [0.9]
[ebuild U ] dev-libs/gmp-5.0.5 [5.0.2_p1]
[ebuild U ] app-misc/pax-utils-0.4 [0.3.0]
[ebuild U ] dev-libs/gobject-introspection-common-1.32.1 [1.32.0]
[ebuild U ] sys-libs/readline-6.2_p1-r1 [6.2_p1] USE="-static-libs%"
[ebuild U ] virtual/acl-0-r1 [0] USE="-static-libs%"
[ebuild U ] dev-libs/ppl-0.12.1 [0.12]
[ebuild U ] dev-libs/mpfr-3.1.0_p7 [3.1.0]
[ebuild N ] virtual/yacc-0
[ebuild U ] app-shells/bash-4.2_p28 [4.2_p24]
[ebuild U ] dev-libs/mpc-0.9-r1 [0.9] USE="-static-libs%"
[ebuild U ] sys-devel/libperl-5.10.1-r1 [5.10.1]
[ebuild U ] sys-apps/baselayout-2.1 [2.0.3-r1]
[ebuild U ] dev-libs/libtasn1-2.12 [2.9-r1] USE="-static-libs%"
[ebuild U ] sys-devel/autoconf-2.69 [2.68]
[ebuild U ] dev-perl/DBI-1.620.0 [1.618.0]
[ebuild N ] dev-util/gtk-doc-am-1.18
[ebuild N ] virtual/pam-0
[ebuild U ] app-misc/ca-certificates-20120212 [20111025]
[ebuild U ] sys-auth/pambase-20120417 [20101024] USE="-pam_krb5% -pam_ssh%"
[ebuild U ] dev-db/mysql-init-scripts-2.0_pre1-r2 [1.2]
[ebuild U ] app-admin/python-updater-0.10-r2 [0.9-r1]
[ebuild U ] app-admin/eselect-xvmc-0.3 [0.2]
[ebuild N ] app-admin/eselect-qtgraphicssystem-1.1.1
[ebuild U ] dev-util/intltool-0.50.2 [0.50.1]
[ebuild N ] dev-util/pkgconfig-0.26 USE="-hardened"
[ebuild N ] virtual/pkgconfig-0
[ebuild U ] dev-libs/glib-2.32.2 [2.32.1] USE="(-fam*)"
[ebuild U ] dev-libs/gobject-introspection-1.32.1 [1.32.0]
[ebuild U ] dev-util/desktop-file-utils-0.20-r1 [0.20]
[ebuild U ] sys-libs/zlib-1.2.7 [1.2.6]
[ebuild U ] media-libs/libpng-1.5.10 [1.5.9]
[ebuild U ] sys-libs/cracklib-2.8.18-r1 [2.8.18] USE="-static-libs%"
[ebuild U ] media-libs/tiff-4.0.1-r1 [4.0.1]
[ebuild U ] sys-devel/libtool-2.4.2 [2.4-r1] USE="-static-libs% -test%"
[ebuild U ] dev-libs/libxml2-2.7.8-r5 [2.7.8-r2]
[ebuild U ] sys-devel/gettext-0.18.1.1-r3 [0.18.1.1-r1] USE="cxx%* -java% -static-libs%"
[ebuild U ] sys-apps/coreutils-8.17 [8.16] USE="acl*"
[ebuild NS ] sys-devel/gcc-4.5.3-r2 [4.6.2] USE="cxx fortran gcj graphite mudflap nls nptl objc objc++ objc-gc openmp (-altivec) -bootstrap -build -doc (-fixed-point) -gtk (-hardened) (-libssp) -lto (-multilib) -multislot -nocxx -nopie -nossp -test -vanilla"
[ebuild U ] dev-libs/atk-2.4.0 [2.2.0]
[ebuild N ] dev-perl/Locale-gettext-1.50.0
[ebuild U ] dev-libs/libgpg-error-1.10-r1 [1.10]
[ebuild U ] app-admin/eselect-1.3.1 [1.2.18]
[ebuild U ] app-admin/perl-cleaner-2.12 [2.10]
[ebuild N ] sys-apps/help2man-1.40.9 USE="nls"
[ebuild U ] sys-devel/automake-1.11.5 [1.11.1]
[ebuild U ] x11-proto/xproto-7.0.23 [7.0.22]
[ebuild U ] x11-proto/xextproto-7.2.1 [7.2.0]
[ebuild U ] media-libs/freetype-2.4.9-r1 [2.4.8]
[ebuild U ] x11-libs/xtrans-1.2.7 [1.2.6]
[ebuild U ] x11-proto/kbproto-1.0.6 [1.0.5]
[ebuild U ] dev-libs/libpthread-stubs-0.3 [0.1] USE="-static-libs%"
[ebuild N ] dev-libs/libev-4.11 USE="-static-libs"
[ebuild U ] dev-libs/libgcrypt-1.5.0-r2 [1.5.0]
[ebuild U ] x11-proto/scrnsaverproto-1.2.2 [1.2.1]
[ebuild U ] dev-libs/libusb-0.1.12-r7 [0.1.12-r5] USE="cxx%* -static-libs%"
[ebuild U ] media-libs/fontconfig-2.9.0 [2.8.0-r2]
[ebuild U ] x11-libs/libICE-1.0.8 [1.0.7]
[ebuild N ] dev-libs/libverto-0.2.4 USE="libev threads -glib -libevent -static-libs -tevent"
[ebuild U ] dev-libs/libxslt-1.1.26-r3 [1.1.26-r2]
[ebuild U ] x11-libs/libSM-1.2.1 [1.2.0]
[ebuild U ] app-crypt/mit-krb5-1.10.1-r3 [1.9.2-r1]
[ebuild U ] dev-libs/openssl-1.0.0j [1.0.0e] USE="-static-libs%"
[ebuild NS ] dev-lang/python-3.2.3-r1 [2.7.2-r3] USE="gdbm ipv6 ncurses readline sqlite ssl threads (wide-unicode) xml -build -doc -examples -tk -wininst"
[ebuild U ] net-libs/openslp-1.2.1-r2 [1.2.1-r1]
[ebuild U ] dev-libs/nettle-2.4 [2.1]
[ebuild U ] net-misc/curl-7.25.0-r1 [7.24.0] CURL_SSL="openssl%* -axtls% -cyassl% -gnutls% -nss% -polarssl%"
[ebuild U ] net-libs/gnutls-2.12.19 [2.12.18]
[ebuild U ] x11-proto/xcb-proto-1.7.1 [1.7]
[ebuild U *] sys-apps/portage-2.2.0_alpha103 [2.2.0_alpha84] USE="(-pypy1_8)"
[ebuild U ] dev-python/dbus-python-1.0.0 [0.84.0]
[ebuild U ] x11-libs/libxcb-1.8.1 [1.8]
[ebuild N ] x11-libs/xcb-util-keysyms-0.3.8 USE="-doc -static-libs -test"
[ebuild N ] x11-libs/xcb-util-image-0.3.8 USE="-doc -static-libs -test"
[ebuild N ] x11-libs/xcb-util-wm-0.3.8 USE="-doc -static-libs -test"
[ebuild N ] x11-libs/xcb-util-renderutil-0.3.8 USE="-doc -static-libs -test"
[ebuild N ] x11-libs/qt-core-4.8.1-r2 USE="exceptions glib iconv qt3support ssl (-aqua) (-c++0x) -debug -optimized-qmake -pch (-qpa)"
[ebuild N ] x11-libs/qt-dbus-4.8.1 USE="exceptions (-aqua) (-c++0x) -debug -pch (-qpa)"
[ebuild N ] x11-libs/qt-script-4.8.1 USE="exceptions iconv jit (-aqua) (-c++0x) -debug -pch (-qpa)"
[ebuild N ] x11-libs/qt-gui-4.8.1-r1 USE="accessibility cups dbus exceptions gif glib mng qt3support tiff xinerama xv (-aqua) (-c++0x) -debug -egl -gtkstyle -nas -nis -pch (-qpa) -trace"
[ebuild N ] x11-libs/qt-sql-4.8.1 USE="exceptions mysql qt3support sqlite (-aqua) (-c++0x) -debug -firebird -freetds -odbc -pch -postgres (-qpa)"
[ebuild N ] x11-libs/qt-qt3support-4.8.1 USE="accessibility exceptions (-aqua) (-c++0x) -debug -pch (-qpa)"
[ebuild N ] dev-util/cmake-2.8.8-r2 USE="ncurses qt4 -emacs -test -vim-syntax"
[ebuild N ] net-im/skype-2.2.0.35-r1 USE="-pax_kernel -qt-static"
[ebuild N ] app-text/poppler-0.18.4-r1 USE="cairo cjk cxx introspection jpeg lcms png qt4 tiff utils xpdf-headers -curl -debug -doc -jpeg2k"
[ebuild U ] dev-db/mysql-5.1.62-r1 [5.1.61]
[ebuild N ] sys-apps/kmod-8 USE="tools zlib -debug -doc -lzma -static-libs"
[uninstall ] sys-apps/module-init-tools-3.16-r1
[blocks b ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r1)
[blocks b ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-8)
[ebuild N ] sys-fs/udev-init-scripts-10
[ebuild U ] sys-fs/udev-182-r3 [171-r5] USE="openrc%* -doc% -static-libs%"
[blocks b ] <sys-fs/udev-182 ("<sys-fs/udev-182" is blocking sys-auth/consolekit-0.4.5-r3, sys-fs/udev-init-scripts-10)
[ebuild U ] sys-auth/consolekit-0.4.5-r3 [0.4.5-r2] USE="acl%*"
[ebuild U ] x11-libs/gtk+-3.4.2 [3.4.1]
[ebuild N ] net-dns/avahi-0.6.30-r3 USE="autoipd dbus gdbm gtk3 howl-compat introspection ipv6 mdnsresponder-compat python -bookmarks -doc -gtk -mono -qt4 -test -utils"
[ebuild U ] net-print/cups-1.5.2-r21 [1.5.2-r1] USE="avahi%* -systemd%"
[ebuild U ] app-text/ghostscript-gpl-9.05-r2 [9.05]
[ebuild U ] net-print/foomatic-filters-4.0.15 [4.0.7] USE="dbus%*"
[blocks B ] <sys-apps/pciutils-3.1.9-r2 ("<sys-apps/pciutils-3.1.9-r2" is blocking sys-apps/hwids-20120507)
[blocks B ] <sys-apps/shadow-4.1.5-r1 ("<sys-apps/shadow-4.1.5-r1" is blocking sys-auth/pambase-20120417)
[blocks B ] <sys-apps/usbutils-005-r1 ("<sys-apps/usbutils-005-r1" is blocking sys-apps/hwids-20120507)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-apps/pciutils-3.1.9-r1::gentoo, installed) pulled in by
>=sys-apps/pciutils-2.1.9 required by (sys-apps/hotplug-20040923-r2::gentoo, installed)
sys-apps/pciutils required by (app-misc/sabayonlive-tools-2.3-r16::sabayon-distro, installed)
sys-apps/pciutils required by (media-sound/alsa-utils-1.0.25-r2::gentoo, installed)
sys-apps/pciutils required by (sys-apps/vbetool-1.1::gentoo, installed)

(sys-auth/pambase-20120417::gentoo, ebuild scheduled for merge) pulled in by
sys-auth/pambase[consolekit] required by (sys-auth/polkit-0.104-r1::gentoo, installed)
sys-auth/pambase required by (sys-libs/pam-1.1.5::gentoo, installed)
>=sys-auth/pambase-20081028 required by (net-misc/openssh-5.9_p1-r4::gentoo, installed)
sys-auth/pambase required by (sys-apps/openrc-0.9.9.3::sabayon-distro, installed)
>=sys-auth/pambase-20080219.1 required by (sys-apps/shadow-4.1.5::gentoo, installed)

(sys-apps/shadow-4.1.5::gentoo, installed) pulled in by
>=sys-apps/shadow-4.1 required by (virtual/shadow-0::gentoo, installed)

(sys-apps/hwids-20120507::gentoo, ebuild scheduled for merge) pulled in by
sys-apps/hwids required by (sys-fs/udev-182-r3::gentoo, ebuild scheduled for merge)

(sys-apps/usbutils-005::gentoo, installed) pulled in by
>=sys-apps/usbutils-0.9 required by (sys-apps/hotplug-20040923-r2::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86?full=1#blocked


The following USE changes are necessary to proceed:
#required by sys-auth/consolekit-0.4.5-r3[acl], required by sys-auth/pambase-20120417[consolekit], required by sys-libs/pam-1.1.5, required by virtual/pam-0, required by net-print/cups-1.5.2-r21[pam], required by x11-libs/qt-gui-4.8.1-r1[cups], required by x11-libs/qt-core-4.8.1-r2[qt3support], required by net-im/skype-2.2.0.35-r1[-qt-static], required by skype (argument)
>=sys-apps/coreutils-8.17 acl

The following license changes are necessary to proceed:
#required by skype (argument)
>=net-im/skype-2.2.0.35-r1 skype-eula

Would you like to add these changes to your config files? [Yes/No] Yes

Autounmask changes successfully written. Remember to run etc-update.

!!! The following installed packages are masked:
- net-wireless/broadcom-sta-5.100.82.112-r2::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

- www-plugins/adobe-flash-11.2.202.228::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Messages postés
30226
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 octobre 2021
7 198
Pfff eh bien moi je dis debian c'est quand même plus simple :-) Manifestement tu as de useflags à activer on dirait acl, consolekit, etc... Je pense qu'il s'agit de useflags que tu peux activer avec uflag si ma mémoire est bonne (ça fait bientôt 10 ans que je n'ai pas touché une gentoo...).

Personnellement je commencerais par faire une mise à jour et installer esync uflag (si nécessaire), puis voir si ma théorie sur les useflags est bonne :

emerge -uD world
emerge -auD esync uflag
esync -v
ldconfig
etc-update
uflag


Ensuite j'essayerais d'installer les deux dépendances flashet broadcom-sta en les démasquant :
https://wiki.gentoo.org/wiki/Handbook:X86?part=3&chap=3#doc_chap3
http://en.gentoo-wiki.com/wiki/Flash_player

J'espère que ça te débloquera car malheureusement, mes souvenirs de gentoo sont très très lointains.
Messages postés
6
Date d'inscription
samedi 12 mai 2012
Statut
Membre
Dernière intervention
12 mai 2015

Reuh, désolé j'ai été occupé.


Merci de ton aide :)

Tout d'abord, même message d'erreur pour "merge -uD world"



WARNING: One or more updates have been skipped due to a dependency conflict:

x11-base/xorg-server:0

(x11-base/xorg-server-1.12.1::gentoo, ebuild scheduled for merge) conflicts with
<=x11-base/xorg-server-1.11.49[-minimal] required by (x11-drivers/ati-userspace-12.3::sabayon-distro, installed)


The following USE changes are necessary to proceed:
#required by sys-auth/consolekit-0.4.5-r3[acl], required by gnome-base/gdm-3.2.1.1-r2[consolekit], required by @selected, required by @world (argument)
>=sys-apps/coreutils-8.17 acl

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
net-p2p/transmission-gtk+:0

!!! The following installed packages are masked:
- net-wireless/broadcom-sta-5.100.82.112-r2::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

- www-plugins/adobe-flash-11.2.202.228::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



Pour le "emerge -auD esync uflag" , aucuns résultats

Exemple avec uflag :

emerge: there are no ebuilds to satisfy "uflag".

emerge: searching for similar names...
emerge: Maybe you meant any of these: dev-cpp/gflags, games-action/bzflag, dev-util/shflags?


Je n'ai donc pas lancé les autres commandes puisqu'elles ne se sont pas installée;)

J'ai cru comprendre que je pouvais "unmask" certaines lignes d'erreurs en les plaçant dans package.use.

Malheureusement je n'ai pas trouvé mais packages maskés (remontés lors de l'installation Skype) dans mon fichier package.unmask.

Je suis à court d'idées.


C'est la dernière version de Sabayon (num 8), aimerais tu le contenu de mes fichiers packages ?

En espérant que vous trouviez une solution.

Cdt.
Messages postés
30226
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 octobre 2021
7 198
!!! Problems have been detected with your world file
!!! Please run emaint --check world


Pourquoi tu ne lances pas cette commande ?

emerge: there are no ebuilds to satisfy "uflag".
emerge: searching for similar names...
emerge: Maybe you meant any of these: dev-cpp/gflags, games-action/bzflag, dev-util/shflags?


Peut-être qu'uflag n'existe plus ou s'appelle autrement (ou n'existe que sous gentoo), essaye de le chercher avec esearch, sinon regarde dans la doc gentoo comment régler les useflags je ne me souviens plus.

En fait juste par curiosté, pourquoi tu as choisi sabayon et pas une distribution comme debian, ou à mon avis on s'embêterait beaucoup moins ?

Bonne chance
reponse partielle il faut mettre dans ton make.conf :

ACCEPT_LICENSE="AdobeFlash-10 AdobeFlash-10.1 PUEL skype-eula AdobeFlash-10.3"

+ les 2 ou 3 autres licences qu'il demande.