Ssh: connect to host : Connection refused

Résolu/Fermé
pandageek Messages postés 359 Date d'inscription samedi 6 août 2011 Statut Membre Dernière intervention 27 mai 2014 - 17 avril 2012 à 23:56
 raspoutine - 20 janv. 2016 à 19:46
Bonjour,
j'ai, branchés sur ma box, un serveur et un ordinateur, les deux sur ubuntu.

sur le serveur; ssh localhost fonctionne, pas sur le pc.
j'ai alors le message suivant :
ssh: connect to host X.X.X.X port 22: Connection refused

impossible d'utiliser ssh, il ne veut pas sortir de mon pc, les derniers logs ssh sur le serv datent de novembre, le port doit être fermé mais comment l'ouvrir?

A voir également:

2 réponses

zipe31 Messages postés 36317 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 569
18 avril 2012 à 08:12
Salut,

On peut voir ton fichier de conf (en root ou précédé de sudo) ?

egrep -v '^(#|$)' /etc/ssh/sshd_config

Affiche aussi le message d'erreur exact et si possible en lançant ta commande avec l'option "-v" (mode verbeux).

ssh -v X.X.X.X

1
pandageek Messages postés 359 Date d'inscription samedi 6 août 2011 Statut Membre Dernière intervention 27 mai 2014 4
18 avril 2012 à 11:32
$ ssh -v localhost
OpenSSH_5.8p1 Debian-7ubuntu1, OpenSSL 1.0.0e 6 Sep 2011
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: connect to address 127.0.0.1 port 22: Connection refused
ssh: connect to host localhost port 22: Connection refused


quand au fichier /etc/ssh/sshd_config, il ne le trouve pas.
0
zipe31 Messages postés 36317 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 569
18 avril 2012 à 11:45
Est-ce que la version serveur est installée au moins sur ce PC ?
Ou tu n'as que le client ?

Que renvoie la commande :

aptitude show openssh-{client,server} | grep -B1 "État"
0
pandageek Messages postés 359 Date d'inscription samedi 6 août 2011 Statut Membre Dernière intervention 27 mai 2014 4
18 avril 2012 à 13:08
Paquet : openssh-client
État: installé
0
zipe31 Messages postés 36317 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 569
18 avril 2012 à 13:08
Ben il manque le serveur, te reste plus qu'à l'installer ;-))
0
raspoutine > zipe31 Messages postés 36317 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021
Modifié par raspoutine le 20/01/2016 à 19:46
peux-tu donner la méthode pour l'installer s'il te plaît ?
0
pandageek Messages postés 359 Date d'inscription samedi 6 août 2011 Statut Membre Dernière intervention 27 mai 2014 4
18 avril 2012 à 13:09
je ne souhaite pas être contrôlé via ssh, il est nécessaire tout de même?
0