Recherche plusieurs mots clés dans colonne [Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 23 mars 2012
Statut
Membre
Dernière intervention
23 mars 2012
-
Messages postés
25547
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2020
-
Bonjour le forum,

J'ai parcouru un peu tout le forum, mais je n'ai pas réussi à trouver de solution à mon problème. Je vais essayer de m'expliquer clairement:
Dans une feuille 1, colonne A, j'ai une liste de mot clé
Dans une feuille 2, colonne A, j'ai une liste de compte client
Ce que je veux faire:
trouver une fonction qui me permette d'identifier dans la colonne A de la feuille 2 les mots clés listés dans la colonne A de la feuille 1, et si le mot clé est contenu dans la cellule, alors il me renvoie un autre terme;
Par exemple, si mon mot clé (en A1 de la feuille 1) est "Auchan" dans la feuille 1, je voudrais qu'il me renvoie "client" dans la feuille 2, si "Auchan" "Groupe Auchan" "AUCHAN" "AUchan"...est présent dans la colonne A de la feuille 2. Et ainsi de suite sur toute la colonne. Par exemple en A2 dans la feuille 1 j'ai "decathlon", je voudrais qu'il me renvoie "client" dans la feuille 2 si "décathlon"; "DEcathlon": "DECATHLON"; "groupe decathlon"...est présent dans la colonne A de la feuille 1.

j'ai un peu tout essayé, des recherchev, des"trouve"...mais rien n'y fait.

Merci par avance de votre aide.

Tigito

5 réponses

Messages postés
16297
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 novembre 2020
3 070
Bonjour
T'es sûr d'avoir bien cherché ou est ce de la "diplomatie pour chercher à la place" ?

=SI(ESTERREUR(CHERCHE(Feuil1!A1;A1));"";"client")
à tirer vers le bas
Michel
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
vendredi 23 mars 2012
Statut
Membre
Dernière intervention
23 mars 2012

Bonjour Michel,

Merci pour votre réponse, et il ne s'agit pas de diplomatie pour recherche à ma place: j'ai trouvé un autre topic qui traite presque du même sujet, mais en passant par VBA, que je ne connais pas du tout et donc préfère éviter pour le moment.
Votre solution ne me donne pas les résultats escomptés.
Je vais essayer de "modéliser" mes deux feuilles:
Feuille 1:
Auchan
Decathlon
...
Feuille 2:
Auchan France
Groupe Auchan
Groupe Auchan
Auchan France
Auchan France
Baxter S.A.S
BioMérieux
BioMérieux
BioMérieux
Décathlon
Decathlon SA
decathlon.com
...

Je voudrais qu'en deuxième colonne de la feuille 2 apparaisse le mot "client" en face de: Auchan France (à chaque fois qu'Auchan France apparaît), Groupe Auchan (à chaque fois que Groupe Auchan apparaît), Décathlon, Decathlon SA, decathlon.com.
rien pour Baxter S.A.S, rien pour BioMérieux

En gros, j'aimerais que pour chaque ligne de la feuille 2 la formule vérifie qu'il n'y a pas un des mots clés de toute la liste de la feuille 1.

Est ce que cela paraît plus clair?

Merci encore de votre aide.
Messages postés
25547
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2020
5 597
Bonjour

ce qui n'empêche pas que Michel a raison...mais ça demande un peu d'imagination:
!
essayez avec:
SI(OU(ESTNUM(CHERCHE("ucha";A1);ESTNUM(CHERCHE("thlon";A1));"Client";"")
essayez des tronçons de texte sans accent pour éliminer les risques
CHERCHE n'est pas sensible à,la casse mais au accents seulement.

crdlmnt

Messages postés
3
Date d'inscription
vendredi 23 mars 2012
Statut
Membre
Dernière intervention
23 mars 2012

Bonjour Vaucluse,

Merci pour les précisions.
Mais cela ne répond toujours pas à ma problématique.
J'ai une liste de 86 comptes client clés, et je voudrais savoir s'il y a une fonction qui permet de repasser pour chaque cellule de la feuille 2 s'il y a un des 86 comptes client clé. Et pour le moment je ne vois pas. J'avais pensé faire comme vous proposiez, mais pour 86 comptes différents, je me demandais si qqch de plus automatique existait? Tout en s'affranchissant des accents et de la casse?

Merci encore.
Messages postés
25547
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2020
5 597
Re
alors dans ce cas je ne peux que vous proposer un truc un peu bizarre qui se base sur les éléments de texte que vous pouvez tirer de votre liste.
A condition que la partie qui permet d'identifier le client soit toujours en fin ou en début de texte, on peut essayer de travailler sur 4 lettres significatives, mais cela ne traitera peut être pas tous les cas
exemple à adapter
à partir de A1 votre liste à traiter
de X1 à X100 la liste des clients, sans accent
en B1, la formule:
=SI(ESTVIDE(A1);"";SI(OU(NB.SI($X$1;$X$100;"*"&DROITE(GAUCHE(A1;6);4&"*");NB.SI($X$1;$X$100;"*"&DROITE(A1;4)&"*"));"client";""))

Qui vous renverra client si le texte contient une partie du nom de client de la 3° à la 6° lettre incluse ou sur les 4 lettres de la fin du texte

Mais c'est tout ce que je sais faire.

crdlmnt