[XL 2003] Pourcentages cumulés dans un TCD [Fermé]

Signaler
-
 Incal -
Bonjour à tous.

Si vous voulez une colle toute bête mais à s'arracher les cheveux, la voilà :


Ma colle : Je cherche à afficher dans mon tableau croisé dynamique un "résultat cumulé par" mais affiché en "pourcentage par ligne" (donc la dernière colonne ne devra afficher que des "100%")
Sachant que mes données sont en nombre de lignes de tel ou tel critère. Est-ce que c'est possible ?


J'ai cherché du côté des champs calculés sans succès (ou faut-il user d'une colonne dans les données sources comprenant une formule ressemblant à "=SOMME(SI(* critères en recherchev *;1;0))" et l'utiliser pour diviser dans le champ calculé ?


Je cale depuis quelques temps alors que j'ai l'impression que c'est tout bête.


Des idées ?

2 réponses

Messages postés
17132
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
14 juin 2021
10 430
Bonjour,

Tu peux nous donner un exemple de ton tableau ?
https://www.cjoint.com/

m@rina
Ce sera plus parlant oui.

Merci pour le site, voici le lien : http://cjoint.com/?BAsouN7W7ED
Il faut avouer que c'est pas forcément évident à expliquer. Désolé.
Le problème avec le tableau J4:P19, c'est que les pourcentages ne sont pas reportés sur la colonne de droite à chaque fois (exemple : on devrait avoir "100%" en N8 et O8). Le choix de mettre des maisons/vélos/voitures dans mon exemple, c'était pas futé. Ce sont des SLAs que je veux y mettre (moins de 2h, entre 2 et 4h, etc en entrée) donc le cumul sert à finir sur "de toutes façons, tout est traité en moins de 2 jours (dernière colonne).
Dans l'idéal, il aurait fallu que les données se présentent différemment en entrée, on est d'accord.
Messages postés
24105
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
13 juin 2021
6 802
Désolé, je ne vois pas ce que tu veux calculer.
Si tu veux 100% parce que pierre a vendu 1 vélo, s'il en vend 3 tu auras 300%.
Je ne vois pas la logique et je renonce....

eric
Arg, je n'ai pas su présenter mon problème. Désolé.
Je tente une dernière précision, sinon, tant pis, t'embête pas :
Dans le TCD, on peut mettre les données en "Résultat cumulé par" (ici, produit), c'est ce que je veux mais en pourcentage:
Affichage normal : 1 1 0 -> 2 au total de la ligne
Résultat cumulé: 12 2
Pourcentage : 50% 100% 100% -> on affiche le résultat cumulé divisé par 2 en pourcentage

Merci encore

Amaël
Messages postés
24105
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
13 juin 2021
6 802
Tout à l'heure c'était 100% 100% 100%, maintenant tu parles de 1 1 0
Tu donnes des chiffres, on ne sait même pas à quelles données, quelle ligne, de quel tableau tu fais référence.
c'était un exemple ...
100% 100% 100% ça aurait été le résultat espéré si j'avais eu une ligne avec 1 0 0 en affichage normal. Pas grave.