Mise en forme conditionnelle [Fermé]

Signaler
-
Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
-
Bonjour,

dans mon classeur excel, j'ai des pourcentages sur lesquels j'ai appliqué une mise en forme conditionnelle automatique (ex: vert quand la valeur tend vers 100% et rouge vers 0%). Pour que la mise en forme conditionnelle fonctionne, je n'ai mis que la valeur (enfin le calcul) dans la cellule, et le '%' dans la cellule d'à côté, pour la lisibilité. Seulement je voudrais que la mise en forme s'applique aussi sur le '%' tout seul. Existe-t-il une formule ou une macro qui permet de recopier la mise en forme de la cellule d'à côté même s'il s'agit d'une mise en forme conditionnelle ? Ou appliquer une mise en forme conditionnelle de ce type (dégradé selon la valeur) qui soit fonction de ma cellule qui contient le pourcentage mais qui s'applique également à la cellule '%' ?

Exemple : en O19 j'ai [0,00], la cellule est donc rouge, je souhaite que la cellule O20 [%] soit de la même couleur.

Merci pour votre aide.

1 réponse

Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
207
Bonjour,

Vous pouvez utiliser une formule dans une MFC (la formule est)
par exemple dans la cellule C1:

=SI(ET($B1>=0;$B1<=33);VRAI) ======>écrit en vert

=SI(ET($B1>=33,1;$B1<=66);VRAI) ======>écrit en orange

=SI(ET($B1>=66,1;$B1<=100);VRAI) ======>écrit en rouge

littéralement:
si B1 est supérieur ou égale à zéro et inférieur ou égal à 33 => écrit en vert
si B1 est supérieur ou égale à 33,1 et inférieur ou égal à 66 => écrit en orange
si B1 est supérieur ou égale à 66,1 et inférieur ou égal à 100 => écrit en rouge