Installation apache sous Centos [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
6 janvier 2012
-
Messages postés
29460
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2020
-
Bonjour,

J'ai installé apache et puis je l'ai désinstallé en utilisant la commande: yum erase httpd
et puis lorsque je veux le réinstaller il me dit qu'il est déjà installé or je suis sure qu'il n'est pas installé il ya plus de httpd sous /etc!
Pourriez-vous m'aider svp, je suis débutante , Merci d'avance.

5 réponses

Messages postés
29460
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2020
6 987
error reading information on service httpd: No such file or directory 


Comme tu le vois ici, le paquet se désinstalle mal. Essaye de faire ce qui est dit ici :
http://hacktux.com/yum/force/reinstall

Bonne chance
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
29460
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2020
6 987
Et tu es sûre que ton "yum remove" est arrivé jusqu'au bout ? Enfin la présence ou non de fichier dans /etc n'a aucun impact sur le statut du paquet pour yum.

Essaye de lancer en root :

yum update
yum remove httpd
yum install httpd


... et copie colle le résultat des deux dernières commandes.

Bonne chance
Messages postés
5
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
6 janvier 2012

merci, voilà les résultats ( tjr même prob :( )


[root@XXXX ~]# yum remove httpd
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package httpd.i386 0:2.2.3-53.el5.centos.3 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Removing:
httpd i386 2.2.3-53.el5.centos.3 installed 3.1 M

Transaction Summary
================================================================================
Remove 1 Package(s)
Reinstall 0 Package(s)
Downgrade 0 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
error reading information on service httpd: No such file or directory

Removed:
httpd.i386 0:2.2.3-53.el5.centos.3

Complete!
[root@XXXX ~]# yum install httpd
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.vieth-server.de
* extras: centos.psw.net
* updates: centosh2.centos.org
Setting up Install Process
Package httpd-2.2.3-53.el5.centos.3.i386 already installed and latest version
Nothing to do

Merci
Messages postés
5
Date d'inscription
jeudi 5 janvier 2012
Statut
Membre
Dernière intervention
6 janvier 2012

Grand Merci mamiemando :) ca fonctionnait enfin avec la commande:
rpm -e --justdb --nodeps PACKAGE

Merci encore
Messages postés
29460
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2020
6 987
Merci pour ces précisions, et bonne continuation ! Pense à basculer le sujet en résolu (lien au niveau de ton premier message).