Somme de mots en fonction d'une autre colonne

[Résolu/Fermé]
Signaler
Messages postés
13
Date d'inscription
samedi 22 septembre 2007
Statut
Membre
Dernière intervention
14 janvier 2014
-
Messages postés
13
Date d'inscription
samedi 22 septembre 2007
Statut
Membre
Dernière intervention
14 janvier 2014
-
Bonjour,

Je voudrais faire une somme de mots d'une colonne en fonction d'une autre colonne qui contient des cases vides et pleines.

ex:

1ère colonne :
N°1
case vide
N°2
N°3
case vide
case vide, etc.

2ème colonne :
case vide
N°1
case vide
case vide
N°2
N°3, etc.

3ème colonne :
vert
rouge
rouge
rouge
vert
vert, etc.

je voudrais faire la somme des "vert" par rapport à la colonne 1 et la somme des "vert" par rapport à la colonne 2.

J'ai beau chercher je ne trouve pas la formule. Pouvez vous m'aider ?

Merci beaucoup




5 réponses

Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 355
Bonjour,
En rajoutant deux colonnes avec les formules suivantes recopiées vers le bas :

1ère colonne :

=SI(ET(A2<>"";$C2="vert");1;0)

Dans la cellule on obtient 1 si la cellule de la colonne A n'est pas vide et si la cellule de la colonne C contient le mot "vert".

2ème colonne :

=SI(ET(B2<>"";$C2="vert");1;0)

il suffit ensuite de faire la somme des deux colonnes nouvelles pour avoir le résultat escompté (celles-ci peuvent être masquée ensuite).

A+

pépé
Messages postés
13
Date d'inscription
samedi 22 septembre 2007
Statut
Membre
Dernière intervention
14 janvier 2014

Super merci, mais je voudrais l'étendre à une plage de donnée : toute la colonne A et la colonne C et avoir le résultat.

Est ce que c'est possible ?

Merci d'avance
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 355
Bonjour,

Il suffit d'étendre le contenu de la première ligne vers le bas en utilisant la "poignée" située en bas à droite de la cellule (le pointeur se change alors en une petite croix). Faire un cliquer-glisser vers le bas jusqu'à la dernière ligne.

A+

pépé
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 229
Bonjour

en 1 seule formule

=SOMMEPROD((A1:A65500<>"")*(C1:C65500="vert"))

m^me punition avec la colonneB
Sommeprod n'admet pas une colonne entière mais tu as intérêt à évaluer le nombre de lignes maximum plutôt que toute la colonne
Messages postés
13
Date d'inscription
samedi 22 septembre 2007
Statut
Membre
Dernière intervention
14 janvier 2014

Enorme !

Merci beaucoup, ca marche super bien. J'ai opté pour la formule avec Sommeprod car elle prend moins de place.