Excel : tri avec plusieurs conditions [Résolu/Fermé]

Signaler
-
 dom14500 -
Bonjour,

Je me permets de vous solliciter parce que je n'ai pas réussi à trouver une réponse à ce problème.
Je tente de vous expliquer tout ça :
- La colonne A contient un numéro d'identification
- La colonne C : F pour féminin et M pour masculin
- La colonne D contient une date de naissance
- La colonne E fait apparaitre l'age calculé à partir de D (en mois avant 2 ans et en années après)
- la colonne J correspond au mois de janvier et c'est la que tout se complique.
J peut contenir : soit des abréviations se terminant par "X" ou "INCX" ou "TENX"
J peut contenir également "ABS" ou "DCD" ou "PDV"

Le problème est que je n'arrive pas à traduire en langage excel les critères suivants :
"Combien de femmes de plus 24ans ont un X en colonne du mois de janvier" ?

J'ai essayé avec SOMMEPROD avec SOMMESI... de longues heures mais je ne m'en sors pas
Pouvez-vous m'aider à traduire le critère ?

J'espère que cela me donnera la clé de départ car par la suite je dois utiliser une formule similaire avec les critères suivants "ABS" ou "DCD" ou "PDV"
Et enfin la même chose pour des critères d'age différents : nombre de jeunes femmes de 14 à 24 ans et les enfants "D" entre 0 et 14 ans.

Je vous remercie pour l'aide que vous m'apporterez.
Bonne journée à tous
Dominique



10 réponses

Messages postés
16366
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
18 janvier 2021
3 110
bonjour
il ya X dans la colonne J style "*X*)
=SOMMEPROD((C2:C13="F")*(E2:E13>24)*(ESTNUM(CHERCHE("X";J2:J13))))
mais si uniquement se terminant par X
=SOMMEPROD((C2:C13="F")*(E2:E13>24)*(DROITE(J2:J13;1)="X"))

je dois utiliser une formule similaire avec les critères suivants "ABS" ou "DCD" ou "PDV"
une formule par critère ou une formule pour indifféremment les 3 critères (cad on peut avoir ABS puis + bas DCD ==> 2 ?

je suis arrivé trop tard pour ta pièce jointe
Michel
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
16366
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
18 janvier 2021
3 110
ton lien envoie sur cjpoint sans téléchargement possible
Messages postés
23807
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
6 573
Bonjour,

Tu peux déposer un fichier exemple sur cjoint.com et coller ici le lien fourni.
As-tu regardé pour le faire via un TCD (Tableau Croisé Dynamique du menu 'Données')

eric
En fait je ne sais pas utiliser le TCD (Tableau Croisé Dynamique du menu 'Données')

http://cjoint.com/?3LfqOIds0ch
Les renseignements en F1 doivent remplir le tableau du feuillet données

Merci Eric
Bonjour Michel,

si je fais

=SOMMEPROD((C2:C13="F")*(E2:E13>24)*(DROITE(J2:J13;1)="X"))
je n'ai pas le bon résultat, j'ai bien toutes les femmes ayant X à droite (colonne J) mais le critère age (colonne E) n'est pas pris en compte
Ce critère est calculé à partir de la date de naissance (colonne D), il n'apparait pas comme un chiffre mais sous cette forme :
Exemple
- 22 mois
- 35 ans
C'est peut être ça qui ne fonctionne pas.

Pour les autres critères : DCD, PDV ou TSO ne sont pas groupés je pense que je saurais faire à partir du moment où mon pb F/H et sélection tranche d'age est résolu.

Le critère ABS c'est un peu plus compliqué car vient se rajouter à la sélection (DROITE(J2:J13)="X")

Je réessaye le lien cjpoint.

Merci du coup de main (de clavier :-))
Normalement le lien fonctionne

http://cjoint.com/?3LfsIs7iJbZ

Encore merci
J'ai tenté de faire un tableau croisé : fiasco !
Après une nuit bien raccourcie, je pense simplifier la colonne age, pour utiliser la formule de Michel.

Merci à tous de votre aide précieuse et très bonne journée.
Messages postés
16366
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
18 janvier 2021
3 110
Impressionnant !

Merci pour la correction des formules batardes;
Bon j'ai compris l'utilité (en partie certainement) du gestionnaire de noms, je vais donc pouvoir faire pareil avec les autres mois, c'est beaucoup plus clair.

Ce que je n'ai pas compris c'est la partie concernant l'age.
Je parle de cette partie (ESTNUM(CHERCHE(("ans");age))) Comment faire la sélection >24 ans ?
j'aimerai comprendre pour être capable ensuite de trier selon age<=14ans puis 14<age<=24

Cool de trouver ça à la pause, encore merci
Messages postés
16366
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
18 janvier 2021
3 110
Très juste, mettons ça sur "l'heure matinale" (l'après midi j'utilise "sieste")

il faut ajouter (age>24)
=SOMMEPROD((sexe="F")*(age>24)*(ESTNUM(CHERCHE(("ans");age)))*(DROITE(janv;1)="X"))

et pour la suite des tes aventures, tu incorpores
(age>=14)*(age<=24)

tu as aussi une proposition dans l'onglet "adultes" en petit supplément gratuit
Messages postés
16366
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
18 janvier 2021
3 110
décidemment!

=SOMMEPROD((sexe="F")*(age>"24 ans")*(ESTNUM(CHERCHE(("ans");age)))*(DROITE(janv;1)="X"))


(age>="14 ans")*(age<="24 ans")
Xtra !

Vous êtes top, même après la sieste :-))

Merci pour le bonus, c'est vrai que c'est plus rationnel ainsi.

Bonne soirée