[Knoppix] probleme installation logiciel

[Fermé]
Signaler
Messages postés
4751
Date d'inscription
lundi 30 mai 2005
Statut
Contributeur
Dernière intervention
9 septembre 2009
-
 Lion vert -
Salut

Je savais que je reviendrais tot ou tard ici.


j'essaie d'installer le logiciel amsn mais bien sure ca marche pas

j'ai reussi a decompresser le logiciel dans un dossier

je vais dans ce dossier je tape configure et voila ce que j'obtient


checking for prefix by checking for wish... /usr/bin/wish
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking tcl build dir... locate: warning: database `/var/cache/locate/locatedb' is more than 8 days old
configure: error: Unable to find Tcl directory or Tcl package is not tcl-dev


c grave docteur ?

17 réponses

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 882
Salut,

Apparemment il te manque les paquets de développements "tcl-dev" (apt-get install tcl-dev).

Sinon pour quoi ne pas prendre le paquet ".deb" directement pour Debian ?
https://sourceforge.net/projects/amsn/files/OldFiles/amsn_0.96rc1-1.i386.stable.deb/download?use_mirror=master

;-)
Messages postés
4751
Date d'inscription
lundi 30 mai 2005
Statut
Contributeur
Dernière intervention
9 septembre 2009
1 163
ok je vais voir

c koi la différence entre ce que j'ai pris et le package debian

sinon j'ai une autre question

en mode console je tape su - pour passer en super utilisateur et la on me demande mon mot de passe et le probleme c que je ne peux rien saisir c comme si je n'avais plus de clavier
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Parfaitement d'accord avec jicipy.

1) Installation standard : En root tape tout simplement :
apt-get install amsn

... et c'est tout.

2) Installation manuelle : Si tu veux vraiment mettre le tar.gz que tu as téléchargé, je pense que tu auras besoin d'autres paquets TCL notamment tcltls et tclmagick mais ca le ./configure te le dira.

Je te recommande très fortement la première solution nettement plus simple.

Bonne chance
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 882
Re-

La différence (en gros) c'est que les paquets ".deb" normalement contiennent toutes les bibliothèques nécessaires à l'installation du programme, alors que les "tar.gz" ont besoin qu'on leur fournissent ces bibliothèques.

Pour le mot de passe c'est normal, il n'y a pas d'echo en retour de frappe, mais toutes les frappes au clavier sont prises en compte.
Donc entre ton mot de passe "à l'aveugle" et appuie sur "Entrée".

;-))
Messages postés
4751
Date d'inscription
lundi 30 mai 2005
Statut
Contributeur
Dernière intervention
9 septembre 2009
1 163
je souhaite passez au plus simple mais après avoir taper la commande apt-get install amsn

voila le message retourner


root@monpc:~# apt-get install amsn
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
E: Impossible de trouver le paquet amsn
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Ca c'est bizarre. Peux-tu faire :
apt-get update

... et nous donner le résultat de :
apt-cache search amsn
cat /etc/apt/sources.list

Bonne chance
Messages postés
4751
Date d'inscription
lundi 30 mai 2005
Statut
Contributeur
Dernière intervention
9 septembre 2009
1 163
donc voila le resultat des 2 commandes

root@monpc:~# apt-cache search amsn

amsn - An MSN messenger written in tcl

root@monpc:~# cat /etc/apt/sources.list

# /etc/apt/sources.list for Knoppix
# If you want to do a "full upgrade", you should first
# upgrade the Packages from Debian/unstable (KDE & Co.)
# before doing a (dist-)upgrade for Debian/testing.
#
# See sources.list(5) for more information, especialy
# Remember that you can only use http, ftp or file URIs
# CDROMs are managed through the apt-cdrom tool.

# Security updates for "stable"
deb https://www.debian.org/security/ stable/updates main contrib non-free
deb https://www.debian.org/security/ testing/updates main contrib non-free

# Stable
deb http://ftp.de.debian.org/pub/debian/ stable main contrib non-free

# The non-US branch doesn't exist anymore since sarge. -KK
# deb http://ftp.de.debian.org/pub/debian-non-US stable/non-US main contrib non-free
# deb-src http://ftp.de.debian.org/pub/debian-non-US stable/non-US main contrib non-free
# deb-src http://ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free
# deb http://ftp.de.debian.org/debian-non-US unstable/non-US main contrib non-free
# deb-src http://ftp.de.debian.org/debian-non-US unstable/non-US main contrib non-free
# deb http://ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free

# Stable Sources
# deb-src http://ftp.de.debian.org/pub/debian/ stable main contrib non-free

# Testing
deb http://ftp.de.debian.org/pub/debian/ testing main contrib non-free

# Testing Sources
# deb-src http://ftp.de.debian.org/pub/debian/ testing main contrib non-free

# Unstable
deb http://ftp.de.debian.org/debian/ unstable main contrib non-free

# Unstable Sources
# deb-src http://ftp.de.debian.org/debian/ unstable main contrib non-free

# Experimental
deb http://ftp.de.debian.org/debian/ ../project/experimental main contrib non-free

# Experimental Sources
# deb-src http://ftp.de.debian.org/debian/ ../project/experimental main contrib non-free

# ndiswrapper source
deb http://ndiswrapper.sourceforge.net/debian ./

# KDE 3.4 (not in sarge)
# deb http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./
# deb-src http://pkg-kde.alioth.debian.org/kde-3.4.1/ ./

# Unichrome graphics driver
# deb http://www.physik.fu-berlin.de/~glaweh/debian/ unichrome/
# deb-src http://www.physik.fu-berlin.de/~glaweh/debian/ unichrome/

# NX stuff
# deb http://www.kalyxo.org/debian/ experimental main
# deb http://www.kalyxo.org/debian/ unstable main

# ndiswrapper
# deb   http://rigtorp.se/debian unstable/
# deb-src       http://rigtorp.se/debian unstable/

# Blades Repository (pppoeconf & co)
# deb http://people.debian.org/~blade/testing ./
# deb-src http://people.debian.org/~blade/testing ./

# deb cdrom:[Debian GNU/Linux 2.2 r3 _Potato_ - Official i386 Binary-1 (20010427)]/ unstable contrib main non-US/contrib non-US/main

# Knoppix special packages resource at LinuxTag HQ
# deb http://developer.linuxtag.net/knoppix ./
# deb-src http://developer.linuxtag.net/knoppix ./

# deb http://snapshot.debian.net/archive pool gcc
# deb-src http://snapshot.debian.net/archive pool gcc

# From the Kanotix archives
deb http://kanotix.com/files/debian/ ./
# deb-src http://kanotix.com/files/debian/ ./

# Packages from ubuntu. CAUTION, they don't mix well with Debian
# deb http://de.archive.ubuntu.com/ubuntu/ hoary main universe multiverse
# deb-src http://de.archive.ubuntu.com/ubuntu/ hoary main universe multiverse

Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
apt-cache search amsn t'as trouvé amsn donc peut être que le apt-cache update à suffit à ajouter amsn dans ton arbre de portage. En d'autres termes je pense que maintenant tu peux faire (en root) :
apt-get install amsn

Si ça ne marche pas copie colle le résultat de la commande.

Bonne chance
Messages postés
4751
Date d'inscription
lundi 30 mai 2005
Statut
Contributeur
Dernière intervention
9 septembre 2009
1 163
apparement tous roule

par rapport a apt-get tous les logiciels s'installe comme ca ?


je souhaiterais installer le logiciel no-ip
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Oui tout s'installe comme ça. Pour chercher un paquet en rapport avec plop :
apt-cache search plop

Pour un paquet en rapport avec plop tel que le nom la description contient tapir :
apt-cache search plop | grep tapir

Une fois le nom du paquet trouvé :
apt-get install lenomdupaquet

Pour mettre à jour ton linux et ton arbre de portage (en particulier si tu rajoutes un miroir) :
apt-get update
apt-get upgrade

Bonne chance
Messages postés
4751
Date d'inscription
lundi 30 mai 2005
Statut
Contributeur
Dernière intervention
9 septembre 2009
1 163
merci mais les 2 premieres commandes ne font rien
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Ben ouais c'est un exemple :-) Tu remplaces tapir et plop parce que tu veux. Par exemple : exemple tu veux trouver le nom du paquet installant firefox, et celui permettant de le traduire en français :
apt-cache search firefox
apt-cache search firefox | grep fr

Bonne chance
Messages postés
4751
Date d'inscription
lundi 30 mai 2005
Statut
Contributeur
Dernière intervention
9 septembre 2009
1 163
moi j'ai chercher a installer noip j'ai taper

apt-cache search noip mais j'ai rien

ca veut dire que j'ai pas saisie le bon nom
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Il suffisait de rajouter un '-' :
(root@silk) (~) # apt-cache search no-ip
arno-iptables-firewall - Single- and multi-homed firewall script with DSL/ADSL support
fish - a friendly interactive shell
inadyn - client to alleviate the requirements for an Internet name
no-ip - A second-generation Linux client for dynamic DNS service

La suite c'est donc :
apt-get install no-ip

Bonne chance
Messages postés
4751
Date d'inscription
lundi 30 mai 2005
Statut
Contributeur
Dernière intervention
9 septembre 2009
1 163
ok j'essaie ca en rentrant

merci a toi
Bonjour,
voila pour faire simple je voudrai utiliser amsn aussi sur un pc portable que je n'arrive a faire tourner que sur knoopix... mais cela est un autre probleme lol.
en gros j'ai suivi les directive donné, et je bloque sur l'installation par rapport au mot de passe
je suis passé par la console pour l'ajouter en mode su ( par le biais d'autre article d'içi ) et knoopix me refuse systematiquement le pass que je tape... pourriez vous m'aider ?
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Ton problème consiste simplement à passer root, pas à installer amsn si je résume bien. Pour passer root vérifie que tu tapes correctement ton mot de passe (clavier qwerty ou azerty ? verr num et cadenas enclenchés ou pas ?). A noter que pour passer root il ne faut pas chercher à se logguer en mode graphique en root, il faut taper dans une console :
su -

(pour les ubuntu sudo su -). Ensuite tapes ton mot de passe et appuies sur entrée (c'est normal qu'aucun caractère n'apparaisse quand tu tapes ton mot de passe). Une fois loggué en root :
aptitude update
aptitude upgrade
aptitude install amsn

Bonne chance
merci je test ca de suite.

Sympa d'avoir repondu aussi virte