Internet sur PC linux avec 2 cartes réseaux [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
mardi 4 octobre 2011
Statut
Membre
Dernière intervention
13 décembre 2011
-
Messages postés
29505
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 janvier 2021
-
Bonjour,

J'ai un réseau avec 2 PC Linux (PC1 et PC2), le PC1 a 2 cartes réseaux
réseau interne PC1 et PC2 ping ok
sur PC1 j'ai une carte réseau eth0 vers PC2 et une wifi pour Internet
Quand je connecte eth0 ET wifi, je n'ai pas d'internet
Si je déconnecte eth0, j'ai Internet

Je dois avoir un problème de configuration quelque part ?

Merci pour votre aide

4 réponses

Messages postés
29505
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 janvier 2021
7 013
C'est peut être un problème de routage, que donne :

/sbin/route -n


Si PC1 doit faire pont réseau, tu dois configurer ce pont (cf les nombreux tutoriels sur brctl).

Bonne chance
Messages postés
7
Date d'inscription
mardi 4 octobre 2011
Statut
Membre
Dernière intervention
13 décembre 2011

[root@localhost network-scripts]# route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 35 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 35 0 0 wlan0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.1 0.0.0.0 UG 35 0 0 wlan0

[root@localhost network-scripts]# route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 35 0 0 wlan0
192.169.99.0 0.0.0.0 255.255.255.0 U 10 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 10 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 35 0 0 wlan0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.169.99.1 0.0.0.0 UG 10 0 0 eth0
0.0.0.0 192.168.0.1 0.0.0.0 UG 35 0 0 wlan0


cas1 : wlan0 up
cas2 : eth0 et wlan0 up
Messages postés
7
Date d'inscription
mardi 4 octobre 2011
Statut
Membre
Dernière intervention
13 décembre 2011

Effectivement, il y a un pb de routage, il y a 2 chemins "default"

Merci pour la piste
Messages postés
29505
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 janvier 2021
7 013
Oui et tu peux également en profiter pour virer les routes qui commencent par 169 (requête DHCP échouée).

route del -net 169.254.0.0 netmask 255.255.0.0 dev eth0
route del -net 169.254.0.0 netmask 255.255.0.0 dev wlan0


D'après ton premier message tu as accès à Internet via wlan0 donc, il ne devrait pas y avoir de route par défaut pour eth0. Ainsi :

route del -net 0.0.0.0 netmask 0.0.0.0 dev eth0


Une fois la table de routage ainsi nettoyée, tout devrait rentrer dans l'ordre : ce PC devrait pouvoir accéder aussi bien aux machines du réseau sans fil que celles du réseau ethernet et avoir accès à Internet.

Bonne chance