Aide pour une longue formule pour excel [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
24 mai 2016
-
Messages postés
7
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
24 mai 2016
-
Bonjour,

bonjour,

j'ai un petit souci avec une formule que je suis sur allez arriver à trouver une solution.

=SI(NON(ESTERREUR(CHERCHE("Cercueil Crémation Bois Blanc 185"; Tarifs!$A$18))); 'Tailles Cercueils'!C16; SI(NON(ESTERREUR(CHERCHE("Cercueil Beaumont 185"; Tarifs!$A$18))); 'Tailles Cercueils'!C16; SI(NON(ESTERREUR(CHERCHE("Cercueil Pin 185"; Tarifs!$A$18))); 'Tailles Cercueils'!C16; SI(NON(ESTERREUR(CHERCHE("Cercueil Pin Supérieur 185 "; Tarifs!$A$18))); 'Tailles Cercueils'!C16; SI(NON(ESTERREUR(CHERCHE("Cercueil Chêne Blanc 1,85 Equipé"; Tarifs!$A$18))); 'Tailles Cercueils'!C16; "")))))

Mais lorsque je rajoute encore un cercueil ça bloque

=SI(NON(ESTERREUR(CHERCHE("Cercueil Crémation Bois Blanc 185"; Tarifs!$A$18))); 'Tailles Cercueils'!C16; SI(NON(ESTERREUR(CHERCHE("Cercueil Beaumont 185"; Tarifs!$A$18))); 'Tailles Cercueils'!C16; SI(NON(ESTERREUR(CHERCHE("Cercueil Pin 185"; Tarifs!$A$18))); 'Tailles Cercueils'!C16; SI(NON(ESTERREUR(CHERCHE("Cercueil Pin Supérieur 185 "; Tarifs!$A$18))); 'Tailles Cercueils'!C16; SI(NON(ESTERREUR(CHERCHE("Cercueil Chêne Blanc 1,85 Equipé"; Tarifs!$A$18))); 'Tailles Cercueils'!C16;SI(NON(ESTERREUR(CHERCHE("Chêne Noir 1,85 Equipé (Plaque et croix)"; Tarifs!$A$18))); 'Tailles Cercueils'!C16; "")))))

je peux vous envoyer le fichier si vous le voulez car je dois encore ajouter des dizaines d'autres cercueils à la suite...

Je pense qu'il y aura un problème d'imbrication....(Et je ne sais pas le résoudre)...
Jai lu sur le net qu'il fallait rajouter indirect qq part.


Merci beaucoup

6 réponses

Messages postés
614
Date d'inscription
lundi 7 juillet 2008
Statut
Membre
Dernière intervention
15 février 2013
17
en fait tu es limité à un certain nombre de SI imbriqué dans excel. Passe par du vba avec des if, ça devrait passer.
Mais sinon ça ne marche pas désolé

--
La vie c'est comme une boite de chocolat, on ne sait jamais sur quoi on va tomber.
bonjour,

merci de votre réponse rapide mais je suis sur excel au bureau et ne connais pas du tout vba...
ni avec les if.

Si vous pouviez me trafiquer cette formule afin que je puisse ajouter ensuite des dizaines de cercueils ce serait le top.

Merci

COrdialement
http://cjoint.com/?3KkotDUHMAd
Messages postés
8221
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
31 octobre 2020
1 500
1) la première formule ne fonctionne pas, elle ne renvoie que la valeur située en C16 de la feuille dimensions
2 ) C'est pas la peine d'essayer de continuer dans cette voie, la méthode est mauvaise.
3) il faut créer une véritable base de données dans laquelle on peut aller chercher toutes les informations nécessaires plutôt que de disperser les informations sur plusieurs feuilles sans aucun référencement commun.
4) Par exemple les différentes dimensions pourraient se trouver sur la feuille données (une par colonne) sur la même ligne que le tarif.
5) Dans la base de données il faut impérativement éviter les lignes vides
Messages postés
8221
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
31 octobre 2020
1 500
Comment as-tu résolu ?
slt

+

correction à faire :

Feuille "Fiche" cellule OPQ 12

Remplaces :

=ENT((D7-D12)/365,25)&" Ans"

Par :

=ENT((D7-D12)/365,25)&SI(ENT((D7-D12)/365,25)=1;" An";" Ans")

1 an est au singulier.

+

Feuille "Avion" cellule ABCDEFGH 00-00-00-00-00-00-00

Il manque des espaces (2 au moins) :

cercueil.Le cercueil ET l'épurationde ceux-ci

18MAI ou 18 MAI ?

+

Pour la formule, il faudrait une colonne ou plusieurs contenant les éléments à chercher = recherche multiple. INDEX RECHERCHEV ... je manque de savoir faire.

(Comment on affiche la liste des feuilles pour naviguer facilement quand il y a beaucoup de feuilles ? J'ai pas l'habitude ... de Office Excel Starter 2010.)

Lazarus (addon firefox) remplace les chaînes 51-52-53-54-55-56-57 par 00-00-...
Oui, je regarde encore le fichier ; les formules ont l'air simple mais éparpillées.
Les fonctions si() imbriquées, c'est mon truc aussi = c'est assez simple ;-)) !
Messages postés
7
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
24 mai 2016

merci beaucoup....
Messages postés
7
Date d'inscription
mardi 20 janvier 2009
Statut
Membre
Dernière intervention
24 mai 2016

je n'ai pas compris comment remplacer les chaines
en tout cas bravo tu as l'oeil...
Tu as vu pas mal de choses
Peux tu me contacter par mail? ou par tel pour te demander des explications?
Merci