Séléction d'OS au démarrage [Résolu/Fermé]

Signaler
Messages postés
146
Date d'inscription
mardi 1 juin 2010
Statut
Membre
Dernière intervention
15 juin 2012
-
Messages postés
29434
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
23 novembre 2020
-
Bonjour, j'ai installé Ubuntu en Dual Boot avec Windows 7. Le problème, c'est qu'Ubuntu prend le dessus sur Windows. J'aimerais savoir comment afficher la "fenêtre" au démarrage pour choisir quel OS démarrer. Tout ce que m'affiche l'ordi c'est "Signal d'entrée hors-limite, passer à 1280x1024 - 60Hz", puis Ubuntu se lance, merci.



2 réponses

Messages postés
29434
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
23 novembre 2020
6 980
Tu peux le configurer dans /etc/default/grub. Pour modifier ce fichier, lance dans un terminal la commande :

gksudo gedit /etc/default/grub &


Ce fichier ressemble à ceci :

# If you change this file, run 'update-grub' afterwards to update  
# /boot/grub/grub.cfg.  
# For full documentation of the options in this file, see:  
#   info -f grub -n 'Simple configuration'  

GRUB_DEFAULT=0  
GRUB_TIMEOUT=5  
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'  
GRUB_CMDLINE_LINUX_DEFAULT="quiet"  
GRUB_CMDLINE_LINUX=""  

# Uncomment to enable BadRAM filtering, modify to suit your needs  
# This works with Linux (no patch required) and with any kernel that obtains  
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)  
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"  

# Uncomment to disable graphical terminal (grub-pc only)  
#GRUB_TERMINAL=console  

# The resolution used on graphical terminal  
# note that you can use only modes which your graphic card supports via VBE  
# you can see them in real GRUB with the command 'vbeinfo'  
#GRUB_GFXMODE=640x480  

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux  
#GRUB_DISABLE_LINUX_UUID=true  

# Uncomment to disable generation of recovery mode menu entries  
#GRUB_DISABLE_RECOVERY="true"  

# Uncomment to get a beep at grub start  
#GRUB_INIT_TUNE="480 440 1"


La ligne en gras désigne la position par défaut du curseur en comptant à partir du 0. Cette valeur 0 désigne la première ligne, a priori Linux dans ton cas.

Ainsi si windows est en 3e position dans ce menu, il faut remplacer cette valeur par 2.

Ceci fait, comme mentionné en début de fichier il faut lancer update-grub. Concrètement il faut bien comprendre que ce menu (grub), appelé boot loader, est installé dans l'en-tête de ton disque dur (c'est-à-dire sur aucune partition). Là, tu ne fais que corriger un fichier de configuration (qui est sur une partition linux), mais pas grub lui-même.

C'est la commande update-grub qui va s'en charger pour nous. Bon en réalité elle fait d'autre chose (notamment elle met à jour /boot/grub/grub.cfg mais on va passer sur les détails...).

Mais comme celle-ci requiert des droits administrateurs (root), il faut la précéder d'un sudo :

sudo update-grub


Un petit reboot pour tester, et hop, l'affaire est dans le sac.b/grub
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Bonjour,
Je crois que le problème de Lagiol est plutôt du coté de la résolution d'écran utilisée par défaut par Grub.
D'après son message il voit affiché "Signal d'entrée hors-limite, passer à 1280x1024 - 60Hz" à la place de l'écran Grub et Ubuntu se lance au time out de la sélection.
Je n'ai jamais eu à la faire mais je suppose que si Lagiol décommente la ligne:
#GRUB_GFXMODE=640x480
pour mettre:
GRUB_GFXMODE=1280x1024 (sans oublier d'oter le #)
ça marchera peut être mieux.
Si quelqu'un peut confirmer ? (Mamiemando ?)
Ah, si c'est un dual boot, Windows sera en position 1 et en 2 ce sera MemTest.
Cordialement
Messages postés
29434
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
23 novembre 2020
6 980
Dans l'idée ce serait ça oui. Et memtest n'est pas sur toutes les distributions (notamment debian). J'avoue que la phrase "ubuntu prend le dessus sur windows" signifiait pour moi qu'il souhaitait avoir windows en choix par défaut.

Mais j'avoue ne pas avoir non plus compris la suite du message :-) Par défaut grub s'affiche en 640*480 et donc quel que soit l'écran.

Enfin, comme il veut tout réinstaller, ça n'a plus vraiment d'importance...
Messages postés
146
Date d'inscription
mardi 1 juin 2010
Statut
Membre
Dernière intervention
15 juin 2012
21
en réalité j'ai entre temps entrepris des actions que monn PC n'as pas aimé je me retrouve avec FreeBSD, Linux (Ubuntu) et Windows 7, bien évidement aucun des 3 ne veux se lancer, sinon ce serais trop simple. J'opte pour une solution plus... radicale. Je vais tenter de formater et tout réinstaller.