Afficher si jour ouvré ou férié

[Résolu/Fermé]
Signaler
Messages postés
9
Date d'inscription
jeudi 3 mars 2011
Statut
Membre
Dernière intervention
5 mai 2011
-
Messages postés
9
Date d'inscription
jeudi 3 mars 2011
Statut
Membre
Dernière intervention
5 mai 2011
-
Bonjour,

Je travaille sur excel 2010, et malgré mes recherches sur de nombreux forums, je n'ai pas trouvé de solution à mon problème.

Je voudrais afficher si le jour est ouvré ou férié.

Dans la colonne A, j'ai la date;
dans la colonne B j'ai le jour (lundi, mardi, etc.);
et j'ai ensuite tous les jours fériés calculés dans les colonnes F à Z nommé "ferie".

En C, j'ai écrit la formule
=SI(A2=ferie;"f";SI(OU(B2="samedi";B2="dimanche");"w";"o"))

Donc si le jour est férié, la formule affiche f, si c'est le weekend, elle affiche w, et si c'est un jour ouvré, elle affiche o.

la formule à partir du SI.OU marche, c'est avant que ça bugge, pour les jours fériés.
Quelqu'un a-t-il une solution ?

Mon classeur, ici :

http://www.cijoint.fr/cjlink.php?file=cj201104/cij7Lbg5C5.xlsx

Merci pour votre aide
A voir également:

1 réponse

Messages postés
9
Date d'inscription
jeudi 3 mars 2011
Statut
Membre
Dernière intervention
5 mai 2011
13
Il faut toujours que je poste pour trouver la solution par moi même directement après...
en C2
=SI(NB.SI(ferie;A2);"f";SI(OU(B2="samedi";B2="dimanche");"w";SI(B2="vendredi";"v";"o")))

J'ai trouvé un bout de solution ici
https://www.excel-downloads.com/threads/formule-si-jour-nest-pas-ferie.87759/