[AMSN] problème d'installation

[Résolu/Fermé]
Signaler
Messages postés
426
Date d'inscription
lundi 3 avril 2006
Statut
Membre
Dernière intervention
28 août 2017
-
Messages postés
426
Date d'inscription
lundi 3 avril 2006
Statut
Membre
Dernière intervention
28 août 2017
-
Bonjour tout le monde.

Voilà, j'essaye d'installer amsn depuis quelques jours sur ma vieille mandrake 9.1.
j'ai décompressé l'archive, j'ai lu le fichier INSTALL
j'ai donc suivit les instruction : configuration avec ./config
le résumé donne :
X11 : yes
Using Libng : yes
Tcl : 8.3
TK : 8.3
DEBUG : no

Ensuite, je vais pour compiler avec : make
et là, message d'erreur :
CXX utils/TkCximage/src/TkCximage.cpp.o
utils/TkCximage/src/TkCximage.cpp: In function `int PlaceHook(Tcl_Interp*)':
utils/TkCximage/src/TkCximage.cpp:138: invalid conversion from `const char*' to `char*'
utils/TkCximage/src/TkCximage.cpp:143: invalid conversion from `const char*' to `char*'
make: *** [utils/TkCximage/src/TkCximage.cpp.o] Erreur 1


Est-ce que quelqu'un pourrait m'aider à vaincre ce problème ?
Aufait, j'ai installé les paquetage gcc et make, ça ne vient donc pas de là.

Voilà, merci à vous !

4 réponses

Messages postés
805
Date d'inscription
lundi 11 octobre 2004
Statut
Membre
Dernière intervention
4 mars 2010
120
tu dois pouvoir trouver AMSN en RPM..; ca sera plus simple que de jongler comme tu l'essayes avec les dépendances
Messages postés
426
Date d'inscription
lundi 3 avril 2006
Statut
Membre
Dernière intervention
28 août 2017
23
merci du conseil, je vais chercher. je donnerais le lien si je trouve pour ce que ça intéresse.

Ciao !
Messages postés
426
Date d'inscription
lundi 3 avril 2006
Statut
Membre
Dernière intervention
28 août 2017
23
re !
Alors j'ai fais quelques recherches, et je n'ai pas trouver le .rpm de amsn.
dans le fichier README, il est dit que je dois avoir les paquets tcl-dev et tk-dev. Je ne les ai pas non plus trouvé tels quel sur internet, mais sur telecharger.com j'ai telechargé et compilé (sans problème cette fois-ci) le paquetage tcl/tk.
J'ai ensuite rééssayé de compiler amsn (j'ai tout recommencé depuis le début : décompression, ./configure, make) et j'ai exactement les même résultats.

Est-ce que toi ou une quelconque autre personne pourrait m'aider ?

D'avance merci pour toute votre aide !
Messages postés
21
Date d'inscription
lundi 15 janvier 2007
Statut
Membre
Dernière intervention
31 mars 2009
3
essayer par le commande
apt-get install tcl-dev
apt-get update
apt-get install amsn
Messages postés
426
Date d'inscription
lundi 3 avril 2006
Statut
Membre
Dernière intervention
28 août 2017
23
Salut imedo !

Tout d'abord, merci pour ton intervention. Malheureusement, ce problème n'est plus du tout d'actualité... ;-)

@ bientôt peut-être !