Lien Externe [Résolu/Fermé]

Signaler
-
Messages postés
9895
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 février 2021
-
Bonjour,

Je voudrai savoir s'il est possible d'utiliser une valeur d'un classeur dans une formule d'un autre classeur, sans utiliser de macro VBA???

Dans mon problème j'ai essayé la formule suivante:

=SIERREUR(INDEX([BaseDeDonnées.xls]Reference!C:C;EQUIV(INDEX(Conf!C:C;EQUIV(Livrable!B3;Conf!B:B;0))&C3;[BaseDeDonnées.xls]Reference!D:D;0))&"";"")


En gros je veux rechercher une valeur à partir d'autres dans un classeur externe(BaseDeDonnées dans la feuille Reference).

Je pense que si c'est possible de le faire comme ça, mon problème vient de la syntaxe de [BaseDeDonnées.xls]Reference!C:C

Sinon, j'ai entendu parler de lien externe mais je sais pas trop ce que c'est ni si c'est ce que je devrais utiliser?!

Merci de votre aide

9 réponses

Messages postés
9895
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 février 2021
1 129
Bonjour,
Oui sans macro c'est possible.
Difficile de déchiffrer votre formule sans un exemple de votre fichier et trouver se qui ne vas pas !
Mes fichiers sont confidentiels et un peu complexes à détailler.
En gros, j'ai un classeur "Liste" et un classeur "BaseDeDonnées".
Dans le premier, j'ai 2 feuilles: Livrable et Confidentiel; et dans le deuxième j'ai une seule feuille: Référence.
Ensuite j'ai la relation suivante pour chaque ligne des feuilles du classeur "Liste":
Confidentiel.B=Livrable.B
Et je voudrai une formule qui corresponde à l'algo suivant(pour chaque ligne de "Livrable"):

Si ((Confidentiel.C==Reference.A)ET(Livrable.C==Reference.B) Faire
Livrable.D=Reference.C
FinSi

Je voudrai seulement la "syntaxe" d'une formule pour pouvoir ensuite l'adapter.

Merci
Messages postés
9895
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 février 2021
1 129
Bonjour,
Se qui est important pour vous aidez c'est la structure de vos fichiers, les valeurs confidentiels peuvent être enlevées.
Je vais essayé de reconstituer le fichier selon vos explications !
http://cjoint.com/?1elkNkGIVAE

http://cjoint.com/?1elkND4YUqS

Ci dessus, j'ai essayé de recopier la structure de mes deux fichiers si ça peut aider.
Messages postés
9895
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 février 2021
1 129
Bonjour,
Voici la syntaxe correspondante de mandée :
=SI(ET(Confidentiel!C1='C:\Documents and Settings\jpp\Bureau\[ Data.xls]Reference'!$A$1:$A$14;C1='C:\Documents and Settings\jpp\Bureau\[ Data.xls]Reference'!$B$1:$B$14);'C:\Documents and Settings\jpp\Bureau\[ Data.xls]Reference'!$C$1:$C$14;"") 
Note : la formule dans le classeur 'Liste' et vous devez adapter les références aux cellules désirées.

Salutations.
Le Pingou
Merci beaucoup, je vais essayer et je vous tiens au courant.
Messages postés
9895
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 février 2021
1 129
Bonjour,
Attention, ma proposition ne tient pas compte de vos fichiers car je viens de les voir.
Salutations.
Le Pingou
d'accord...ça explique peut être le fait que je n'arrive pas à la faire marcher.
Mon erreur est "valeur non disponnible"

Sinon, j'ai essayé la formule suivante qui fonctionne sur les fichiers (structure) que j'ai publier en lien mais pas sur mes vrais fichiers:

=INDEX('C:\Bureau\[BdD.xlsx]Reference'!C:C;EQUIV(INDEX(Confidentiel!C:C;EQUIV(Livrable!B4;Confidentiel!B:B;0))&C4;'C:\Bureau\[BdD.xlsx]Reference'!D:D;0))&"";"")

Une explication???
d'accord...ça explique peut être le fait que je n'arrive pas à la faire marcher.
Mon erreur est "valeur non disponnible"

Sinon, j'ai essayé la formule suivante qui fonctionne sur les fichiers (structure) que j'ai publier en lien mais pas sur mes vrais fichiers:

=INDEX('C:\Bureau\[BdD.xlsx]Reference'!C:C;EQUIV(INDEX(Confidentiel!C:C;EQUIV(Livrable!B4;Confidentiel!B:B;0))&C4;'C:\Bureau\[BdD.xlsx]Reference'!D:D;0))&"";"")

Une explication????
C'est bon, j'ai fini par y arriver! Merci de ton aide
Messages postés
9895
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 février 2021
1 129
Bonjour,
Merci pour l'information.