[excel] extraire d'une valeure date

Résolu/Fermé
Signaler
Messages postés
113
Date d'inscription
mardi 14 septembre 2010
Statut
Membre
Dernière intervention
26 octobre 2014
-
 bibus -
Bonjour,
et salut pour tous
comment extraire une partie d'une cellule qui porte une valeur date
j'ai essayé avec la function gauche mais le resultat et nombre different de ce je recherhe. merci
sur le lien un fichier demo
http://www.cijoint.fr/cjlink.php?file=cj201011/cijyVjJau3.xlsx

1 réponse

Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 720
Bonsoir

Il ne faut pas confondre le contenu d'une cellule (résultat) avec le format d'affichage de ce contenu (apparence).
Lorsque le résultat est une date, la cellule contient une valeur numérique qui correspond au nombre de jours (et de fraction de jour) écoulés depuis la veille du 1er janvier 1900, dans ce cas 40493 (pour le 11 novembre 2010).
Le format d'affichage des nombres jj mmm aaaa donne alors 11 nov 2010

Pour obtenir un résultat sous forme de texte :
Question 1
=TEXTE(A1;"jj")
résultat textuel : 11

Question 2
=TEXTE(A1;"mmm")
résultat textuel : nov

Question 3
=TEXTE(A1;"aaaa")
résultat textuel : 2010

Pour obtenir un résultat sous forme numérique :
Question 1
=A1
au format personnalisé jj
résultat numérique : 40493 affiché 11

Question 2
=A1
au format personnalisé mmm
résultat numérique : 40493 affiché nov

Question 3
=A1
au format personnalisé aaaa
résultat numérique : 40493 affiché 2010

Pour extraire les éléments de la date :
Question 1
=JOUR(A1)
au format standard
résultat numérique : 11

Question 2
=TEXTE(A1;"mmm")
au format standard
résultat textuel : nov

Question 3
=ANNEE(A1)
au format standard
résultat numérique : 2010

Cordialement
Patrice
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
113
Date d'inscription
mardi 14 septembre 2010
Statut
Membre
Dernière intervention
26 octobre 2014

merci beaucoup mr patrice ca marche tres bien.
bonne nuit
merci tout le monde ....merci