EXCEL - Mise en avant doublons dans 2 colonne [Résolu/Fermé]

Signaler
-
Messages postés
4310
Date d'inscription
mercredi 29 mars 2006
Statut
Contributeur
Dernière intervention
6 janvier 2015
-
Bonjour à tous,

Voici ce que j'essaye de faire

J'ai 2 colonnes

C
43546354
64354354
65465465
68931854
97589785
97869756
16767917


Et F (+courte)

43546354
64354354
65465465
68931854

Dans la colonne C, il y a obligatoirement ceux de la colonne F et d'autres chiffres qui ne me servent pas.
J'aimerai que les chiffres qui sont dans la colonne C ET F (communs aux deux colonnes donc) soient mis en avant (soit en gras, soit avec un « 1 » dans la colonne à coté...)

Comment faire ?

Merci 1000 fois pour votre aide (il y a plus de 10000 lignes...)

Jere



3 réponses

Messages postés
4310
Date d'inscription
mercredi 29 mars 2006
Statut
Contributeur
Dernière intervention
6 janvier 2015
761
Si ça y est j'ai trouvé :-)

Tu as donc la colonne C plus longue que la F.
Admettons que la colonne D soit celle que tu remplis de 1 si jamais le chiffre est présent dans les deux.

Alors le code de la cellule Dx sera :

=SI(NB.SI($F$1:$F$10000 ; $Cx) ; "Doublon" ; "Pas doublon")

Ou F1 - F10000 représente l'ensemble de cellules remplie de la colonne F.
Et où Cx représente la cellule C voisine de Dx.

Ca va ?
6
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

wow tu gères!!

Ca marche!

Je viens de gagner des heures, merci bcp

Passe une excellente journée

Jere
Messages postés
4310
Date d'inscription
mercredi 29 mars 2006
Statut
Contributeur
Dernière intervention
6 janvier 2015
761
Content de t'avoir aidé ^^
Messages postés
4310
Date d'inscription
mercredi 29 mars 2006
Statut
Contributeur
Dernière intervention
6 janvier 2015
761
Salut,

Tu maitrises un peu le VBA ?
Il faudrait, mais c'est long, prendre chaque chiffre de la colonne F et le comparer à toute la colonne C !

Pour ça, une double boucle en while serait nickel.
Mince, j'ai eu des cours dans le passé mais je ne me rappelle plus de grand chose

Il n'y a pas un truc simple genre =SI F3 est dans colonne C alors G=1 .. c'est possible?

Merci!