FORMULE CONDITIONNELLE

Résolu/Fermé
aure0509 - 13 sept. 2010 à 17:47
Ricky38 Messages postés 4349 Date d'inscription samedi 15 mars 2008 Statut Contributeur Dernière intervention 2 novembre 2013 - 14 sept. 2010 à 14:58
Bonjour,



Bpnjour,

Je souhaite additionner les données de la colonne B uniquement si le statut de la vente est "ENCAISSEE" dans la colonne A...

Mon tableau :

A (statut de la vente) B (montant de la vente)
EN COURS 100 €
ENCAISSEE 150 €
ENCAISSEE 150 €
EN COURS 100 €
ANNULEE 222 €

Cela fait longtemps que je n'ai pas pratiqué EXCEL, et pas mal de choses se sont évaporées de ma mémoire!

HELP ! ! !

Une assistante dans la détresse...

3 réponses

Ricky38 Messages postés 4349 Date d'inscription samedi 15 mars 2008 Statut Contributeur Dernière intervention 2 novembre 2013 1 458
13 sept. 2010 à 18:02
Salut,

avec la fonction SOMME.SI

Donc en C1 tu pourrais mettre : =SOMME.SI(A1:A5;"ENCAISSEE";B1:B5)
Faire la somme de B1:B5 si A1:A5 contient ENCAISSEE
2
Merci! Cela m'a bien été utile... 1 journée.

Mon boss désire maintenant que je le fasse avec deux conditions. J'ai fait une formule matricielle dégotée dans un forum, mais... ça ne marche que pour une seule des sommes que j'ai à faire!


A (statut de la vente) -B (montant de la vente) - C(montant HT) - D (année)
EN COURS - 100 € - 83.61 € - 2010
ENCAISSEE - 150 € -125.42 € - 2010
ENCAISSEE - 150 € - 125.42 € - 2010
EN COURS - 100 € - 83.61 € - 2010
ANNULEE - 222 € - 185.62 € - 2010

Mon boss veut donc faire apparaître la somme des encaissés de 2010, la somme des encours, et la somme des annulés. Cela doit apparaître dans un tableau 'bilan' que j'ai mis sur un autre onglet.
Comme vous vous en doutez, il y a une formule dans toute la colonne C pour calculer le HT.
Et si la formule matricielle fonctionne sur la somme des TTC, cela ne fonctionne pas sur la somme de HT. Est-ce parce que le HT est généré par une formule?

Je sens que vous avez la réponse... ;-)

Merci en tout cas pour précédemment.

Aure0509
0
Ricky38 Messages postés 4349 Date d'inscription samedi 15 mars 2008 Statut Contributeur Dernière intervention 2 novembre 2013 1 458
14 sept. 2010 à 14:58
Salut,

voici un fichier exemple: http://www.cijoint.fr/cjlink.php?file=cj201009/cij3N9g098.xls

En fait tu te sert de la proposition de Mike-31

Bonne journée
0
Mike-31 Messages postés 18318 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 avril 2024 5 081
13 sept. 2010 à 18:25
Salut,

Une autre approche, intitulé en A1 à A30 somme en B1 à B30

=SOMMEPROD((A1:A30="ENCAISSEE")*(B1:B30))

Cette formule peut être perfectionnée avec une liste déroulante ex. en F1 dans laquelle on sélectionnerait EN COURS, ENCAISSEE, ANNULEE, ce qui permettrait d'avoir les différentes valeurs
La formule deviendrait
=SOMMEPROD((A1:A30=F1)*(B1:B30))

et si on nomme les plages pour une utilisation sur la feuille ou autre feuille du classeur, ex plage en A nommée Intitulé la B nommée Somme la formule devient

=SOMMEPROD((Intitulé=F1)*(Somme))
en abrégeant le nom des plages nommées ex. Int pour Intitulé et Som pour somme la formule se limite à

=SOMMEPROD((Int=F1)*(Som))
1
Merci pour votre réponse.

La formule de Ricky38, plus rapide, m'a été bien utile... 1 journée.

Mon boss désire maintenant que je le fasse avec deux conditions. J'ai fait une formule matricielle dégotée dans un forum, mais... ça ne marche que pour une seule des sommes que j'ai à faire!


A (statut de la vente) -B (montant de la vente) - C(montant HT) - D (année)
EN COURS - 100 € - 83.61 € - 2010
ENCAISSEE - 150 € -125.42 € - 2010
ENCAISSEE - 150 € - 125.42 € - 2010
EN COURS - 100 € - 83.61 € - 2010
ANNULEE - 222 € - 185.62 € - 2010

Mon boss veut donc faire apparaître la somme des encaissés de 2010, la somme des encours, et la somme des annulés. Cela doit apparaître dans un tableau 'bilan' que j'ai mis sur un autre onglet.
Comme vous vous en doutez, il y a une formule dans toute la colonne C pour calculer le HT.
Et si la formule matricielle fonctionne sur la somme des TTC, cela ne fonctionne pas sur la somme de HT. Est-ce parce que le HT est généré par une formule?

Je sens que vous avez la réponse... ;-)

Merci en tout cas pour précédemment.

Aure0509
0
tchernosplif Messages postés 600 Date d'inscription dimanche 8 novembre 2009 Statut Membre Dernière intervention 21 juin 2015 244
13 sept. 2010 à 18:04
dans une autre colonne:

=SI(GAUCHE(A:A;9)="ENCAISSEE";B:B;0)


puis faire la somme de la colonne (par exemple C)

=somme(C:C)
0