Recherche speciale dans une liste de nombre

Résolu/Fermé
hashad - 2 août 2010 à 14:15
TT02
Messages postés
12
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
5 octobre 2014
- 3 août 2010 à 16:27
Bonjour,

Quelqu'un pourrait m'aider?
Pour trouver la formule excel qui consiste à chercher le plus grand nombre négatif dans une liste de nombre quelconque.
Dans l'exemple le nombre -2.5
dans la liste: 22.5
20
17.5
15
12.5
10
7.5
5
2.5
0
-2.5
-5
-7.5
-10
-12.5
-15
-17.5
-20
-22.5
-25

4 réponses

Perso, j'utiliserais la fonction si :
=si(A1<0, max(A1);" ")

Pseudo001
0
Louwé
Messages postés
6
Date d'inscription
lundi 2 août 2010
Statut
Membre
Dernière intervention
26 octobre 2011

2 août 2010 à 15:22
il ya pas de resultat avec =SI(A1<0;MAX(A1);"")
rien
0
Bonjour,

Par cette formule matricielle :

=MAX(SI(A1:A20<0;A1:A20))

que tu valides en appuyant simultanément sur Ctrl + Maj + Entrée

Bonne journée
0
Louwé
Messages postés
6
Date d'inscription
lundi 2 août 2010
Statut
Membre
Dernière intervention
26 octobre 2011

2 août 2010 à 15:23
Quand je tape la formule =MAX(SI(A1:A20<0;A1:A20))
le resultat =0 alors ca doit être -2.5
0
TT02
Messages postés
12
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
5 octobre 2014
2
3 août 2010 à 16:27
Excellent
0
Re,

Comme précisé, il faut valider en appuyant "SIMULTANÉMENT" sur les trois touches :

Ctrl + Maj + Entrée

Soit :

Contrôle + Maj (Flèche du haut, sous la touche "Verrouillage Majuscule") + la touche Entrée

Ceci, lorsque tu as fini de taper la formule, et à la place de faire "Entrée" simplement
0
Louwé
Messages postés
6
Date d'inscription
lundi 2 août 2010
Statut
Membre
Dernière intervention
26 octobre 2011

2 août 2010 à 15:48
Ok, merci cousinhub
Mais comment ecrire derière la formule "Ctrl + Maj + Entrée" et je veux que le résultat se positionne en face de la cellule correspondante comme suit:

22.5
20
17.5
15
12.5
10
7.5
5
2.5
0
-2.5 -2.5
-5
-7.5
-10
-12.5
-15
-17.5
-20
-22.5
-25

est ce possible?
0
Re-,

Si c'est juste pour la repérer, tu peux utiliser la Mise En Forme Conditionnelle

Tu entres cette formule dans la cellule B1

Tu sélectionnes les cellules de A1 à a20

Tu fais "Format/Mise En Forme Conditionnelle"

Dans la liste déroulante, tu choisis "La formule est :"

Et dans la formule, tu entres cette autre formule :

=$A1=$B$1


Tu cliques sur "Format", onglet "Motifs", et tu choisis la couleur que tu veux...
0
Louwé
Messages postés
6
Date d'inscription
lundi 2 août 2010
Statut
Membre
Dernière intervention
26 octobre 2011

2 août 2010 à 16:16
J'ai essayé autrement:
=SI(A1<0;MIN(ABS($A$1:$A$20));"")
dans la colonne suivante
=SI(B1=MIN($D$1:$D$20);B1;"")
Ce qui me donne 2.5 en face de -2.5

Merci Louwé > cousinhub
0