Encodage site internet UTF-8 ISO-8859-1 [Résolu/Fermé]

Signaler
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
-
 vektor -
Bonjour,
Voilà je construit un site avec dreamweaver et MAMP et tout fonctionne correctement.
je met ensuite les même pages (php) sur mon serveur apache et j'ai un problème d'encodage avec des é au lieu de é
dans firefox quand je change l'encodage et le mets en UTF-8 c'est bon mais à chaque rafraichissement l'encodage se remet à ISO 8859-1.
Ayant regardé avant dans plusieurs forum
j'ai essayé un fichier .htaccess avec AddDefaultCharset UTF-8
j'ai changé dans mes fichiers :
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
j'ai regardé du côté de apache2.conf ?!!!
je ne vois pas ce qui cloche

quelqu'un pourrait m'aider à y voir un peu plus clair ?
merci




5 réponses

Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
merci les amis je crois que j'ai trouvé
sous dreamweaver j'ai modifier les propriétés de la page et dans le codage (qui était utf-8) j'ai mis western Mac OS Roman et ça fonctionne.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
18513
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 février 2021
4 266
Si certains textes proviennent de la base de données, vérifie bien que son l'interclassement soit en « utf8_general_ci » ou « utf8_bin ».
mais comment changer le type d'interclassement dans la base de donnée. j'ai beau sélectionné toute les tables et valider avec un autre interclassement apres opération les interclasses sont toujours pareils
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
Ce n'est pas ça j'ai vérifié en plus ça ne concerne pas des affichages de la base de donnée mais du texte de la page même.
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
Je croyais !!!
j'ai des soucis parce que maintenant tous les textes issus de javascript avec accent mettent des signes bizarres: en faite ce que j'ai fait en modifiant les propriétés de la page (voir ci-dessus) c'est mettre des è etc sur les textes HTML mais pour les textes dans le javascript il n'a rien fait donc ça ne doit pas être la solution...
il faudrait que ce p. de firefox mette encodage utf-8 automatiquement.

ce qui m'énerve c'est qu'avec MAMP j'avais aucun soucis donc je pense que cela doit venir d'Apache... quelqu'un peut m'aider à configurer comme il faut ?
merci


Sirius 911
« On n'est pas le meilleur quand on le croit, mais quand on le sait... »
Messages postés
266
Date d'inscription
mardi 12 février 2008
Statut
Membre
Dernière intervention
13 novembre 2020
48
Il est normal que le navigateur retombe sur l'encodage par défaut de la page à chaque rafraîchissement.

Si tu as un éditeur genre notepad++ (gratuit) ou editplus (payant), vérifie que tu as bien enregistré tes fichiers php en utf8 (de préférence sans BOM) et non en ANSI.

@ pluche.

Fab.