[Excel] - SOMMEPROD mixé à NB.SI? [Résolu/Fermé]

Signaler
Messages postés
79
Date d'inscription
mercredi 2 décembre 2009
Statut
Membre
Dernière intervention
6 septembre 2014
-
Messages postés
79
Date d'inscription
mercredi 2 décembre 2009
Statut
Membre
Dernière intervention
6 septembre 2014
-
Bonjour,

J'ai une base où 2 colonnes sont en jeux. Colonne A où on trouve les années, Colonne B où on trouve une moyenne (entre 0,00 et 10,00) de plusieurs notes.

Je veux faire une distribution (comptage) par classe (ceux qui ont eu 0, ceux qui ont eu 1 etc ...) , par année, des moyennes.

Prenons l'exemple de l'année 2008 et du nombre d'élèves qu'on considère avoir 6 de moyenne :

Pour le comptage des années : =SOMMEPROD((B2:B10000=2008)*1)

Pour le comptage de ceux qui ont 6 (ça garde ceux qui ont entre 5.5 et 6.5) : =NB.SI(B2:B10000;">5,49")-NB.SI(B2:B10000;">6,49")


Je pensais mixer les 2 dans une SOMMEPROD pour avoir le décompte par année et par classe de notes, mais je me casse les dents dessus. Ne faudrait-il remanier la NB.SI pour intégrer le tout à une seule SOMMEPROD à 2 matrices (ce que j'ai déjà essayé, mais surement mal)?

Merci d'avance.

3 réponses

Messages postés
79
Date d'inscription
mercredi 2 décembre 2009
Statut
Membre
Dernière intervention
6 septembre 2014
3
Personne n'est maître de la SOMMEPROD?
Messages postés
16431
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
9 avril 2021
3 162
bonjour,

essaies plutôt
=SOMMEPROD((A2:A1000=2008)*(ARRONDI(B2:B1000;0)=6)*1)
10000 ca risque d'^tre long.... estu sûr d'avoir 10000 notes a gérer ?

ta question est une question de bureautique, pas de prog
:-x
Messages postés
79
Date d'inscription
mercredi 2 décembre 2009
Statut
Membre
Dernière intervention
6 septembre 2014
3
C'était parfait (méchant retard, désolé) michel, merci.