[Excel] somme automatiques excel

Résolu/Fermé
dokaz
Messages postés
29
Date d'inscription
mercredi 18 mai 2005
Statut
Membre
Dernière intervention
19 décembre 2011
- 1 août 2005 à 11:38
dokaz
Messages postés
29
Date d'inscription
mercredi 18 mai 2005
Statut
Membre
Dernière intervention
19 décembre 2011
- 1 août 2005 à 17:55
Salut,

J'ai besoin de votre aide pour des calculs de somme qui me posent soucis.

Dans une consolidation très longue, je dois calculer des sous-totaux lorsque les libellés de données sont identiques.

J'ai trié mes données par ordre croissant et j'ai un tableau de ce genre, où les libellés sont nombreux (environ 300 différents) :

Libellés Montant Résultat
A 10 A=47
A 12
A 5
A 20
B 27 B=42
B 15
C 13 C=13
D 6 D=67
D 8
D 22
D 31

Pour l'instant je n'arrive qu'à indiquer à chaque nouveau libellé dans une autre colonne une info ou un chiffre.

Pouvez-vous m'aider, j'aimerai obtenir les sous totaux automatiques comme ci-dessus (colonne résultat, peu importe sa forme)

merci d'avance

3 réponses

'lut
DerniereCellule = Application.Workbooks("ton_fichier.xls").Worksheets("Nom_de_ta_feuille").Range("A65536").End(xlUp).Row
For i = 1 To DerniereCellule
If Range("A" & i & "").value = "A" then
a = Range("B" & i & "").value + a
else if
If Range("A" & i & "").value = "B" then
b = Range("B" & i & "").value + b
else if
If Range("A" & i & "").value = "C" then
c = Range("B" & i & "").value + c
end if
next i

à mettre dans un sub de bouton par exemple...
0
random
Messages postés
1612
Date d'inscription
vendredi 26 novembre 2004
Statut
Membre
Dernière intervention
30 mars 2006
155
1 août 2005 à 14:37
tu ajoutes deux colonnes l'une cumul et l'autre sous total
pour la colonne cumul tu mets en c2
SI(A2=A3;B2+C3;B2)

pour la colonne soustotal tu mets en d2
=SI(A2=A1;"";C2)

tu recopies les formules vers le bas
tu masques la colonne cumul
0
dokaz
Messages postés
29
Date d'inscription
mercredi 18 mai 2005
Statut
Membre
Dernière intervention
19 décembre 2011
78
1 août 2005 à 17:55
Trop fort !!!! et Trop belle la vie, merci. Je préfère la 2e solution, elle est plus simple et plus rapide.

Merci à vous 2

0