Ecran noir aprés selection KDE (10.04 lucid)

[Résolu/Fermé]
Signaler
Messages postés
140
Date d'inscription
vendredi 19 septembre 2003
Statut
Membre
Dernière intervention
10 mai 2013
-
 kaliweed -
Bonjour,

Aprés une mise à jour de la derniére béta Ubuntu 10.04 "The Lucid Lynx" elle même mise à jour par le web ce dimanche et qui marchait correctement en mode par défaut gdm ou gnome, j'ai choisi de tester l'interface graphique de KDE, au reboot j'ai un écran noir, pas de login mot de passe à saisir, juste le son du bureau qui se lance sur un écran noir.
juste avant cela, un écran de démarrage s'affiche avec en son centre 4 icônes, mais de manière brève, 3 à 4 secondes.
Ensuite, j'ai accès aux programmes grâce à la commande ALT F2 et j'ai pu ouvrir deux ou trois fenêtre, comme l'explorateur et des programmes, mais je ne sais pas comment revenir en mode non KDE ou lui permettre d'avoir un bon affichage.

Sur le net j'ai pu voir que je n'étais pas seul à rencontrer ce probléme mais je n'ai pas trouvé de solution ou du moins pas que je puisse mettre en oeuvre.
j'ai une config avec un amd ATHLON64 bi pro 3800+, deux carte en SLI de marque NVIDIA, assez anciennes, qui ont 3 ou 4 ans, un écran LCD en 1440 par 900, des disques SATA et je peux démarrer avec le cd d'installation en mode test.

j'ai déjà surfé sur le net depuis 3 jours et tenté diverses solutions trouvées dont la réinit sudo init.d/gdm stop et restart mais je n'ai pu ouvrir de terminal en mode alt F2, je dois dire que je suis loin de m'y connaitre sous linux.

je dois rajouter que je boot sur grub, et que j'ai du xp sur le même pc avec un autre boot type windows après grub.

Autre écart qui n'aide pas, alors que linux est le roi du net, je ne peux plus me connecter au net, a savoir que j'ai tenté une modif de mon ipv4 du réseau accessible en boot cd, sans résulats, au moins en http.

J'ai essayé d'être assez détaillé si quelqu'un de plus compétent peux me donner un petit coup de main.

merci d'avance

7 réponses

Quand l'écran est noir:
ALT+F2 => taper konsole

Dans la console, taper:
sudo apt-get -f install
sudo apt-get install kdebase

CTRL-ALT-DEL et choisir "Se deconnecter"

A la reconnexion cela devrait marcher
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

il suffit d'installer le paquet kdebase avec synaptic sous gnome ou sudo apt-get install kdebase dans une console.

j'avais le meme probleme depuis c'est resolu

bonne chance
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
juste avant cela, un écran de démarrage s'affiche avec en son centre 4 icônes, mais de manière brève, 3 à 4 secondes.

C'est probablement le ksplash (l'écran de chargement de KDE)

Ensuite, j'ai accès aux programmes grâce à la commande ALT F2 et j'ai pu ouvrir deux ou trois fenêtre, comme l'explorateur et des programmes, mais je ne sais pas comment revenir en mode non KDE ou lui permettre d'avoir un bon affichage.

Je ne sais pas trop ce que tu appelles le "bon affichage". Manifestement KDE s'est lancé non ? Si tu préfères lancer gnome, ça se choisis au moment où tu saisis ton login et ton mot de passe pour ouvrir une session graphique (ie au niveau de kdm ou de gdm).
http://doc.ubuntu-fr.org/gdm

j'ai déjà surfé sur le net depuis 3 jours et tenté diverses solutions trouvées dont la réinit sudo init.d/gdm stop et restart mais je n'ai pu ouvrir de terminal en mode alt F2, je dois dire que je suis loin de m'y connaitre sous linux.

Ce qui est possible c'est que tu aies activé des effets 3D et que ceux-ci fonctionnent mal. Dans un premier temps j'utiliserais le driver nv au lieu de nvidia pour être sûr que tout s'affiche correctement (quitte à remettre la 3D ensuite). Pour cela tape dans un terminal les commandes suivantes :

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo service gdm restart


Concrètement cela renomme xorg.conf en xorg.conf.bak. Dès lors xorg se lance sans configuration et charge le module nv au lieu de nvidia (pilote libre et fiable mais sans accélération 3D). Lorsque tu souhaiteras revenir dans ta situation actuelle il suffit de faire le chemin inverse :

sudo mv /etc/X11/xorg.conf.bak /etc/X11/xorg.conf
sudo service gdm restart


Pour être sur d'avoir un KDE à peu près complet :

sudo aptitude update
sudo aptitude safe-uprade
sudo aptitude install kubuntu-desktop


Si tu as l'intention d'utiliser KDE plutôt que gnome, privilégie kdm à gdm.

Choisis de lancer KDE ou gnome selon ton humeur. Pour quitter KDE, c'est via le menu K (en bas à gauche). Tu peux aller dans le centre de configuration KDE (alt f2 et lance "systemsettings"), dans la rubrique bureau tu peux activer ou désactiver les effets 3D (il faudra alors restaurer au préalable ton xorg.conf afin d'utiliser les drivers nvidia au lieu de nv).

Bonne chance
Messages postés
140
Date d'inscription
vendredi 19 septembre 2003
Statut
Membre
Dernière intervention
10 mai 2013
51
merci beaucoup de ta réponse détaillée, j'ai passé deux jours sur cette config, KDE s'est bien lancé, mais avec un écran noir, sans login, sans icône ni menu ni barres d'outils ou de taches juste ALT F2.
le bon affichage pour moi c'était celui qui me donnait le moyen de fonctionner tout simplement, revenir sous gnome en quelque sorte.

J'avais essayé des modifs du xorg.conf en lançant le live cd...
Je suis parti du cd live pour accéder au bureau, j'ai réussi à lancer une mise à jour en montant la partition lanceur et fait d'autres tentatives sans grand résultat, ce qui à débloqué la situation c'est l'édition sous KDE d'une option de configuration de l'affichage, je crois avoir là aussi tenté un sudo service gdm restart, sans certitude. sans reboot me semble t il l'écran de login KDE s'est enfin affiché avec en bas des choix que je n'avais jamais vu sur l'option visuelle, KDE, KDM et gnome je crois.
Si je manque de précision c'est que j'ai essayé tellement de trucs que tout se mélange, quoi qu'il en soit le redémarrage ensuite s'est bien passé. Tout est rentré dans l'ordre.

Je dois avouer que je n'ose plus tenter quoi que ce soit pour d'autres essais du même genre.

Merci encore de ton aide et du temps passé, ce post servira sans doute à d'autres, cette "panne" étant déjà arrivé à d'autres.

Cordialement
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Euh et tu as essayé ce que je t'ai indiqué, parce qu'avec ça, KDE devrait au moins se lancer sans effets 3D ? Peux-tu me reporter le résultat de :

sudo grep EE /var/log/Xorg.0.log


... si le problème persiste.

Bonne chance
Messages postés
140
Date d'inscription
vendredi 19 septembre 2003
Statut
Membre
Dernière intervention
10 mai 2013
51
Je vois que je ne t'ai pas répondu, j'en suis désolé

j'ai réussi à revenir sous gnome après de nombreux essais, pour résumer, j'ai pu y parvenir en démarrant la machine sous le live cd
puis montage de l'installation en suivant des prescriptions d'autres posts
mise à jour de cette installation
je crois modif de paramétrage d'affichages, je ne sais plus où
puis arrêt - redémarrage du gestionnaire vidéo
à un moment j'ai eu l'écran de login avec, en bas une option, un choix de environnement graphique
j'ai choisi Gnome et tout est reparti et fonctionne plutôt bien

en fait je pense avoir un soucis niveau drivers vidéo, en effet j'ai deux cartes nvidia en SLI et je pense que ça ne lui plait pas trop, au sortir de l'écran de veille par exemple, je ne peux plus me reconnecter, obligé de faire un reboot, pas très clean tout ça.

j'ai essayé d'installé les drivers, pour l'instant sans y parvenir...
lors d'une vieille install en bi-écran, j'y étais parvenu, j'ai les xconf d'époque, je vais réessayer après avoir mis de coté un max de fichiers pour revenir à mon point de départ en cas de plantage

merci de ta réponse
cordialement
Messages postés
30127
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
24 septembre 2021
7 175
Ça peut venir des drivers nvidia si ta carte est récente. En ce qui me concerne sur mon portable, seuls les derniers (version 195) fonctionnent correctement.

Donc là à ce stade, tu peux aller dans gnome en démarrant normalement (car attention, démarrer sur un live CD n'a rien à voir avec démarrer normalement, c'est le linux et le gnome du CD que tu lances, pas celui que tu as installé !) ? Sauf que ça plante en sortant des mises en veille ?

Une solution (mais qui te prive d'effets 3D) consiste à utiliser les drivers nv au lieu de nvidia, ce qui consiste simplement à ne pas avoir de fichier /etc/X11/xorg.conf (tu peux le mettre de côté au cas où). Tu perdras l'accélération 3D mais par contre tu n'auras pas de mauvaises surprises. Après c'est à toi de voir...
Merci vibi27

J'avais le même problème et ta solution a fonctionné...

thx