MODIFIER PLANNING VOITURE PRET [Résolu/Fermé]

Signaler
Messages postés
27
Date d'inscription
dimanche 25 janvier 2009
Statut
Membre
Dernière intervention
9 octobre 2017
-
 vincent -
Bonjour,
Bonjour,
J’AI CREE UN PLANNING DE GESTION POUR MES VEHICULES DE PRET DEBUT 2009 AVEC L’AIDE DE RAYMOND PENTIER, JE VOUDRAIS LE PERFECTIONNE POUR QUE CE SOIT UN PEU PLUS FACILE A GERER MAIS JE N’ARRIVE PAS.

DANS A4 JE VOUDRAIS QUE AB (pour absente) CE NOTE LORSQUE DANS LA CELLULE F4
IL Y A UN NOM DE CLIENT INSCRIT SI NON LA CELLULE A4 RESTE VIDE S’IL N'Y A RIEN DANS F4


DANS LA CELLULE C4 JE VOUDRAIS QUE P (pour présente) CE NOTE LORSQUE DANS LA CELLULE F4 EST VIDE


DANS LA CELLULE A7 JE VOUDRAIS METTRE UN CODE QUI RENVOI LES INFORMATIONS DANS LES CELLULES B7 C7 D7 ET E7 QUI SONT SUR LA FEUILLE "PLAN" J'AI CREE DES LISTES DE MON
MAIS SI JE NE METS AUCUN CODE DANS LA COLONNE A MA FORMULE QUI SE TROUVE EN COLONNE G à AK SE MET EN ERREUR N/A

SI VOUS POUVEZ M’AIDE
MERCI

12 réponses

Messages postés
445
Date d'inscription
lundi 4 janvier 2010
Statut
Membre
Dernière intervention
4 avril 2012
29
Salut tourille,

Je ne sais pas si tu sait mais les majuscules sur un forum sont comme si tu poussais un cri.
Tu dit bonjour sans crier alors continu ton message comme tel...
Messages postés
5387
Date d'inscription
lundi 1 octobre 2007
Statut
Membre
Dernière intervention
18 février 2021
132
tu peut pas poster ton planning, via cijoint.com, par ex, pour se rendre compte
Messages postés
53308
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2021
15 331
Bonjour.

Je n'ai plus le planning que je t'avais proposé. Alors remets le tien en ligne avec https://www.cjoint.com/ ou avec http://cijoint.fr/
(sans oublier de coller le lien dans un ton prochain message !).

En attendant, et au pif, je dirais que :
la formule en A4 serait =SI(F4="";"";"AB")
la formule en C4 serait =SI(F4="";"";"P")
Messages postés
27
Date d'inscription
dimanche 25 janvier 2009
Statut
Membre
Dernière intervention
9 octobre 2017

http://www.cijoint.fr/cjlink.php?file=cj201001/cijqcp3kgs.xlsx

Bonsoir Raymond,
j'ai essayé les formules que tu m'as proposé, mais pour la cellule C4, je voudrai que le P ne soit pas visible si
dans la colonne F4 il y a un texte inscrit.
j'ai mis en ligne le fichier se sera plus parlant, j'ai 2 feuilles une nommé "PLAN"dans la quelle le tableau me servant à gerer mes véhicules ,et la feuille planning 01-2010 celle ou se trouve le planning
Messages postés
53308
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2021
15 331
"j'ai essayé les formules que tu m'as proposé"

Oh, non !
En C4 tu as inventé une formule, qui n'est pas du tout celle que je t'ai proposée ...

https://www.cjoint.com/?bod4KHIMMx
https://www.cjoint.com/?bod6F7T1Zh
Messages postés
27
Date d'inscription
dimanche 25 janvier 2009
Statut
Membre
Dernière intervention
9 octobre 2017

feuille planning
effectivement avec la formule "sierreur( recherche) c'est ce qui me fallait , je ne l'a connaissais pas
il me reste une cellule dans planning la colonne F, la ou le nombre de jour s'inscrit
ma formule est simple c'est E7-d7+1 qui E7 est fin et D7 est début ,mais comme il y a des formules dans ces cellule lorsque qu'elles sont vide la cellule F7 ce met en #valeur!
feuille plan
DANS C4 JE VOUDRAI QUE P ( pour présente) CE NOTE LORSQUE DANS F4 LA CELLULE EST VIDE

=SI(F4="";"";"P")
mais le P ne s'affiche pas et la cellule est vide
Messages postés
53308
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2021
15 331
J'utilise TON fichier.
Dans la feuille PLAN je mets MA formule =SI(F4="";"";"P") en C4, que je recopie vers le bas.
Avec MOREAU en F4 je vois P s'afficher en C4.
Avec rien en F5 la cellule C5 reste vide.
En C8 le P s'affiche, mais c'est que F8 n'est pas vraiment vide : elle contient un espace !

Envoie ton nouveau fichier, où la colonne C ne fonctionne pas bien ; je vais vérifier.
http://www.cijoint.fr/cjlink.php?file=cj201001/cijpUA0jsR.xlsx

j'ai joint mon fichier,
dans plan pour la colonne C , je l'ai cachée je me suis dit que si ce n'est pas noté AB c'est que le vehicule est P présent car je n'arrive pas à trouver j'ai pourtant bien effacé le contenu

dans la feuille planning
c'est la colonne F dans le total de jour de prêt, si les au tres colonne sont vide il ya la #valeur! qui apparait
Messages postés
53308
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2021
15 331
Je te prie de bien vouloir m'excuser :
Depuis le post 3 ma deuxième formule était inversée, j'aurais dû écrire =SI(F4="";"P";"")
Tu peux donc réafficher ta colonne C dans la feuille PLAN.

Dans la feuille Planning..., cellule F10, remplace =E10-D10+1 par =SI(D10="";"";E10-D10+1)
https://www.cjoint.com/?bqkCXX3JP8

je pense que maintenant mon planning est au top de mes desirs, je ne crois pas avoir fait de betises
toutes mes cellules sont bien parametrée
quand penses-tu?
Messages postés
53308
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2021
15 331
C'est presque parfait ; je te félicite.

Feuille PLAN
Pour éviter d'avoir des "P" en colonne C pour les lignes vides, je te suggère de remplacer
=SI(F4="";"P";"") par =SI(E4="";"";SI(F4="";"P";""))
Pour une meilleure présentation, tu devrais mettre les cellules A2:D2 en orientation verticale (+90°) et aligner au centre (alignement vertical) la ligne 2.

Feuille Planning
Dans la colonne B tu as cumulé une fonction RECHERCHE et une liste déroulante ; c'est source de conflit : choisis l'une ou l'autre méthode.
N'oublie pas que lorsqu'on arrivera en février, il ne faudra ni supprimer les colonnes G à AK ni les laisser à l'affichage, ce qui t'obligerait à jouer souvent de l'ascenseur horizontal. La meilleure soution sera de les masquer.
https://www.cjoint.com/?bqvL33Z11q
merci Raymond,
J'ai suivi tes instructions et maintenant il me plait j'ai enlevé la liste deroulante dans planning colonne B
il va me facilté mon travail de gestion
si certaines personnes sont intéréssées par ce genre de planning je ne sais pas comment le mettre à disposition car sur le cite cjoint il ne reste pas longtemps !
Bonsoir
Serait-il de remettre votre fichier en partage. Je souhaiterai l'adapter à notre association dans la location de costume
Messages postés
53308
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2021
15 331
pouvez-vous m'indiquer la marche à suivre pour ouvrir ce fichier? Je n'arrive pas sous excel à ouvrir ce fichier de façon exploitable.
Merci