Clé ssh sans mot de pass

Résolu/Fermé
kipetrovitechy Messages postés 178 Date d'inscription samedi 25 février 2006 Statut Membre Dernière intervention 28 février 2013 - 29 déc. 2009 à 17:46
kipetrovitechy Messages postés 178 Date d'inscription samedi 25 février 2006 Statut Membre Dernière intervention 28 février 2013 - 30 déc. 2009 à 16:56
Bonjour,
j'ai un soucis pour m'authentifier sur un serveur gentoo a partir d'un autre serveur debian en ssh par clé sans mot de passe.
en gros je me suis placé sur le serveur debian identifier sous le compte de l'utilisateur qui sera connecté en ssh.
j'ai ensuite tapé
ssh-keygen -b 4096 -t rsa -f ~/.ssh/backup_key
qui me genere une clé backup_key et backup_key.pub
je lance cette commande pour rapatrier la clez sur la gentoo
scp backup_key.pub user@servergentoo:/home/usergentoo

jusque la tous va bien
je me logue sur l'user de la gentoo et tape
cat backup_key.pub >> ~/.ssh/authorized_keys
le contenue du .pub et bien copier dans le authorized_keys
les droits son ok j'ai créer un clé qui ne me servira pas sur la gentoo et que j'ai supprimer simplement dans le but d'avoir les bon droit sur les dossiers.

voila en gros je repart sur ma debian
je me logue avec l'utilisateur qui a le fichier .ssh/backup_key
et je tape ssh -i ~/.ssh/backup_key user@gentooserver
et la manque de bols il me demande d'accepter la cle je fais yes et il me demande un mot de passe.

j'ai créer le certificat sans mot de passe pourtant justement dans le but d'automatiser une connection ssh .

je ne comprend vraiment pas d'où cela peux provenir pouvez-vous me renseigner svp ?

sa viens de la gentoo sans aucun doute car j'ai fait les même manip sur une autre debian et il me demande le mot de passe comme si il ne prenait pas en compte la clé que j'ai créé ou qu'il ne charger pas le authorized_keys pourtant dans le sshd_config.

merci pour votre aide.

5 réponses

kipetrovitechy Messages postés 178 Date d'inscription samedi 25 février 2006 Statut Membre Dernière intervention 28 février 2013 11
29 déc. 2009 à 18:29
merci pour votre aide
screen
ssh -v backup
OpenSSH_5.1p1 Debian-5, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /home/rdiff/.ssh/config
debug1: Applying options for backup
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to xx.xx.xx.xx [xx.xx.xx.xx] port 22.
debug1: Connection established.
debug1: identity file /home/backup/.ssh/backup_key type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
debug1: match: OpenSSH_5.2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-5

debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-5
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
The authenticity of host 'xx.xx.xx.xx (xx.xx.xx.xx)' can't be established.
RSA key fingerprint is 0d:79:8z:4z:6s:39:da:8b:44:66:56:45:5b:34:df:75.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'xx.xx.xx.xx' (RSA) to the list of known hosts.
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /home/backup/.ssh/backup_key
debug1: Next authentication method: keyboard-interactive
Password:
2
Urielxx Messages postés 190 Date d'inscription mardi 26 août 2008 Statut Membre Dernière intervention 25 juin 2013 46
29 déc. 2009 à 18:00
Salut,
Vérifie si :
- ton serveur ssh accepte bien l'authentification par clef
- ton client utilise bien la clef
- tu n'as pas de problèmes de permissions trop "laxistes" ou trop "dures" sur ton authorized_keys ou ton fichier clef (ssh refuse d'utiliser certains fichiers si pas assez sécurisés)

Essaie de lancer le client avec l'option -v en plus si ça ne fonctionne pas, et le démon ssh avec l'option -ddd pour regarder ce que font tout ces petits processus... (poste le résultat ici, meme s'il est long)

a+
0
Urielxx Messages postés 190 Date d'inscription mardi 26 août 2008 Statut Membre Dernière intervention 25 juin 2013 46
29 déc. 2009 à 18:37
[message édité]

Mauvais diagnostic de ma part : j'ai re-testé et ssh envoie des messages différents selon les cas, donc il faudrait idéalement regarder aussi sur le serveur...
0
kipetrovitechy Messages postés 178 Date d'inscription samedi 25 février 2006 Statut Membre Dernière intervention 28 février 2013 11
30 déc. 2009 à 09:20
je sais mais je ne vois vraiment pas ou sa bloc sur le serveur.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
kipetrovitechy Messages postés 178 Date d'inscription samedi 25 février 2006 Statut Membre Dernière intervention 28 février 2013 11
30 déc. 2009 à 16:56
Merci pour votre aide cela fut très sympa.

j'ai régler le probleme en réalité un conseil pour tous ceux qui aime ce prendre la tête sur des truc comme sa !!
n'hésitez pas a vous remettre en question quand vous êtes sur que la config est bonne car cela paie de temps en temps.
mon problème est régler, une question de droit sur le fichier auhorized_keys.

en réalité pour régler le soucis j'ai créer le fichier a partir la machine debian en tapant:
ssh-copy-id -i ~/.ssh/backup_key.pub user_avec_lequelle_je_me_connecte@serveurgentoo
il integre le .pub au fichier authorized_keys de l'user avec les droits approprier.
ce qui regle tous c'est qu'il attrbuer le numero du user et groupe de cette façon
-rw------- 1 backup 35 225 Dec 30 16:32 authorized_keys
au lieux de sa que j'avais mis
-rw------- 1 backup backup 225 Dec 30 16:32 authorized_keys
d'ailleur c'est la seul différence que je vois mais peux-être que c'est autre chose.

le ssh -vvv user@servergentoo ma servit beaucoup plus que le -v simplement si sa peux aider.

merci encore
0