Service en démarrage automatique ne démarre p [Résolu/Fermé]

Signaler
Messages postés
374
Date d'inscription
jeudi 5 août 2004
Statut
Membre
Dernière intervention
18 mars 2021
-
Messages postés
374
Date d'inscription
jeudi 5 août 2004
Statut
Membre
Dernière intervention
18 mars 2021
-
Bonjour,

je viens d'installer diskeeper 2009,je me suis rendu compte au bout de quelques jours que la défragmentation automatique ne se faisait pas.
La raison est la suivante quand je lance diskeeper manuellement j'ai le message suivant "diskeeper ne peut pas se connecter au service,celui-ci est peut -être arrêté".
Effectivement en regardant dans la liste des services le service est arrêté bien qu'il soit positionné sur démarrage automatique. Il me faut le démarré manuellement et faire la manip à chaque démarrage du micro.
D'où cele peut-il venir?
Merci

6 réponses

Messages postés
81599
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 avril 2021
12 757
Bonjour,
Va dans démarrer, exécuter, tape: msconfig et OK. Onglet démarrage, coche: dkservice.exe , appliquer et OK. Redémarre et vois que ca donne.
Messages postés
374
Date d'inscription
jeudi 5 août 2004
Statut
Membre
Dernière intervention
18 mars 2021
8
Bonjour,

Merci pour la réponse mais le dk service n'est pas présent dans ms config et ne doit pas s'y trouver car sur un second micro tout fonctionne bien et le fichier dk service n'est pas présent.
En fait même en double cliquant sur dk service.exe le service ne se lance pas il faut aller dans outils d' administration et services puis le démarrer. De plus aucune erreur n'apparait dans le journal des événements.
le service dont il dépend est bien démarré,je me demande ce qui peut bien le bloquer.
Messages postés
81599
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 avril 2021
12 757
Vérifie si c'est le pare-feu qui le bloque.
Messages postés
374
Date d'inscription
jeudi 5 août 2004
Statut
Membre
Dernière intervention
18 mars 2021
8
Bonjour,
Le pare feu ne bloque pas le service qui est dans les exceptions. En regardant de plus près j'ai le message suivant dans le journal des événements.
"le service dkservice n'a pas démarré pour la raison suivante,le délai d'attente de connexion du service est trop long > 30000s".
Dans la base de connaissance microsoft j'ai trouvé la solution que je donne pour ceux qui auraient le même problème:

Pour contourner ce problème, modifiez le Registre de façon à augmenter la valeur par défaut du délai d'attente pour le gestionnaire de contrôle de services. Pour augmenter cette valeur à 60 secondes, procédez comme suit :
Cliquez sur Démarrer, puis sur Exécuter, tapez regedit, puis cliquez sur OK.
Recherchez la sous-clé de Registre suivante et cliquez dessus :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
Dans le volet droit, recherchez l'entrée ServicesPipeTimeout.

Remarque Si l'entrée ServicesPipeTimeout n'existe pas, vous devez la créer. Pour cela, procédez comme suit :
Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
Tapez ServicesPipeTimeout, puis appuyez sur ENTRÉE.
Cliquez avec le bouton droit sur ServicesPipeTimeout, puis cliquez sur Modifier.
Cliquez sur Décimale, tapez 60 000, puis cliquez sur OK.

Voilà problème résolu
Messages postés
374
Date d'inscription
jeudi 5 août 2004
Statut
Membre
Dernière intervention
18 mars 2021
8
Bonjour,

En fait le message d'erreur n'était pas à la ligne Diskeeper mais sur la ligne service control manager et donc je ne pensais pas trouver l'erreur ici.
Merci et à bientôt peut-être
Messages postés
81599
Date d'inscription
mercredi 27 mai 2009
Statut
Modérateur
Dernière intervention
12 avril 2021
12 757
Bizarre ! Plutôt, tu mentionnais qu'il n'y avait aucun message d'erreur dans l'observateur d'évènements et maintenant, il y en a un message pour cette erreur ? L'important, c'est que ca soit résolu.
Bonne journée.