Pb: SI et ET et comparaison Cellule/Colonne

Fermé
Bolinette
Messages postés
13
Date d'inscription
lundi 27 juillet 2009
Statut
Membre
Dernière intervention
11 septembre 2009
- 11 sept. 2009 à 11:02
michel_m
Messages postés
16570
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
26 mai 2022
- 11 sept. 2009 à 12:31
Bonjour,

Alors je vous explique mon petit problème. J'ai un tableau et je voudrais faire une formule disant :

=Si :Le résultat de la cellule est supérieur ou égale à l'un des résultats de la liste "listedate" compris entre B3 et B17 (sur une autre feuille) ET Si le résultat est supérieur ou égale à l'un des résultat de la liste compris entre C3 et C17 alors la formule reçoit "-"

=SI(ET(D5>='Listedate1!B3:B17;D5<='Listedate1!C3:C 17);"-";"")

Hélas la formule ne marche pas vraiment, j'ai un traditionnel #VALEUR! . Le but d'origine était avant de passer par l'option "mise en forme conditionnel" et ainsi ... Si ma cellule est égale un des résultats , alors le mettre en rouge. Hélas, ça n'a pas l'air de prendre plusieurs résultats d'une colonne.

Merci d'avance pour votre aide.

A bientôt

4 réponses

Bonjour,

tu ne peux pas le formuler comme ca mais :
=SI(ET(ou(D5>='Listedate1!B3;D5>='Listedate1!B4;D5>='Listedate1!B5;D5>='Listedate1!B6;D5>='Listedate1!B7;D5>='Listedate1!B8;D5>='Listedate1!B9;D5>='Listedate1!B9;D5>='Listedate1!B10;D5>='Listedate1!B11;D5>='Listedate1!B12;D5>='Listedate1!B13;D5>='Listedate1!B14;D5>='Listedate1!B15;D5>='Listedate1!B16;D5>='Listedate1!B17);ou(D5<='Listedate1!C3;D5<='Listedate1!C4;D5<='Listedate1!C5;D5<='Listedate1!C6;D5<='Listedate1!C7;D5<='Listedate1!C8;D5<='Listedate1!C9;D5<='Listedate1!C10;D5<='Listedate1!C11;D5<='Listedate1!C12;D5<='Listedate1!C13;D5<='Listedate1!C14;D5<='Listedate1!C15;D5<='Listedate1!C16;D5<='Listedate1!C17)=vrai;"-";"")
0
michel_m
Messages postés
16570
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
26 mai 2022
3 280
11 sept. 2009 à 11:08
bonjour
=SI(ET(D5>=MIN('Listedate1!B3:B17);D5<=MAX('Listedate1!C3:C 17));"-";"")

D5<=MAX('Listedate1!C3:C 17) ??? dans ton message tu as marqué:
Si le résultat est supérieur ou égale à l'un des résultat de la liste compris entre C3 et C17
dans ta formule
D5<='Listedate1!C3:C 17)
veut dire inférieur ou égal...
0
Bolinette
Messages postés
13
Date d'inscription
lundi 27 juillet 2009
Statut
Membre
Dernière intervention
11 septembre 2009

11 sept. 2009 à 11:15
pardon c'est bien inférieur ou égale j'ai fait une erreur de recopie !
Par contre je pense que la première solution est meilleur (même si plus longue) car en fait le traitement se fait par ligne. En effet il y avoir plusieur solution.
En fait je veux faire une planning, donc la case du calendrier se colore si la date est comprise entre deux date d'une ligne (allant de C3-D3 à C17-D17)

Vous voyez peut être une meilleur solution ?
0
michel_m
Messages postés
16570
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
26 mai 2022
3 280
11 sept. 2009 à 12:31
En effet il y avoir plusieur solution
Fallait peut-être le préciser AVANT.

Qui plus est la 1° solution est particulièrement lourde et ne te donne pas plusieurs résultats...

Vous voyez peut être une meilleur solution ?
La solution multi-résultats passe par une matricielle
mais je suis lassé de recommencer le boulot suite à des demandes mal exprimée
0