Problème de wifi sur linux kubuntu 9.04

Fermé
Tez_972 - 2 août 2009 à 23:07
 Tez_972 - 25 sept. 2009 à 06:45
Bonjour,

J'ai installé récemment le système d'exploitation linux kubuntu version 9.04.
Depuis quelques temps je n'arrive pas à me connecter sur internet avec le wifi.
Je possède une livebox orange sagem. J'ai une carte wifi intel corporation PRO/Wireless 4965 AG or AGN.
Mon PC est un DELL XPS M1530 avec un triple boot windows vista edition familiale premium service pack 1/ windows XP professionnel service pack 2/ linux kubuntu 9.04.
J'ai cherché toutes sortes de solutions pour faire fonctionner le wifi sur linux: aucun résultat positif.
Chaque fois que j'essaie de me connecter sur la livebox, il me redemande indéfiniement ma clé WEP.

Quelqu'un pourrait-il m'aider, s'il-vous-plaît?

13 réponses

Dernière idée...

On m'a dit que Kubuntu ne serait vraiment pleinement oérationnel qu'à partir de la version 9.10 (qui sortira fin octobre).

Essaie de remplacer Kubuntu par Ubuntu (qui lui est bien rodé).

En fait de refaire l'installation mais avec un CD d'Ubuntu :
http://old-releases.ubuntu.com/releases/9.04/ubuntu-9.04-desktop-amd64.iso

Comme c'est un "desktop-cd", tu peux tester en démarrant l'ordinateur avec le CD (Live-CD) puis installer en utilisant l'icone sur le bureau.

Avant de lancer, choisis la langue et le clavier (ça aide...).

Cordialement,

Pierre
1
Salut,

Il y a des soucis avec network-manager et Kubuntu 9.04.

Essaie d'installer wicd à la place :
sudo apt-get install wicd

Cordialement,

Pierre
0
Salut PGraber,

Merci pour ta réponse rapide.

J'ai essayé ton astuce en installant wicd en faisant "sudo apt-get install wicd" dans le terminal de linux, et tout ce qu'il me dit c'est "E: impossible de trouver le paquet wicd" ou quelque chose comme ça.

Dis-moi le lecteur E, c'est le lecteur de CD ou bien la partition où linux est installé, en temps normal?

Sinon... que faire?
0
Salut,

Évidemment, j'aurais dû imaginer la difficulté d'installer wicd si tu n'as pas de connexion internet.

Il faudrait d'abord brancher ton portable à un réseau avec un câble.

Après l'installation devrait être possible.

A+

Pierre
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
La connexion avec le câble ethernet fonctionne bien. Mais j'ai toujours le même message pour installer wicd: "E: Impossible de trouver le paquet wicd".
0
Va dans le menu K (en bas à gauche).
Choisis Applications / System / Gestion des logiciels (Kpackagekit).

Tu peux aussi le lancer en tapant
Alt+F2 ... puis kpackagekit

Puis Configuration / Modifier les sources

Logiciels de Kubuntu : les 4 premiers
Third Party : cocher jaunty partner (pas source)
Update : la totale

Puis mettre à jour (comme c'est proposé) et dans l'onglet Gestion des logiciels, recherche wicd.

Quand tu l'as, clique sur le + puis sur Appliquer

Cordialement,

Pierre
0
Slt Pierre,

J'ai fait comme tu m'as dit. J'ai installé wicd et j'ai même réussi à faire les mis à jours pour linux. Il semble fonctionner.

Le wifi ne fonctionne toujours pas. Que je débranche le câble éthernet ou que je le laisse branché, le wifi ne fonctionne toujours pas.

De plus, (désolé, j'avais oublié de te le préciser), le petit voyant du wifi ne s'allume pas.

Et puis, ça me dit aussi que 6 mis à jours ont été bloqués. Il faut les débloquer ou linux pense que ce sont des virus?
0
Salut,

Les mises à jour bloquées ne sont pas des virus.

Pour les "débloquer" il faut en général relancer la machine parce que c'est fréquemment des nouvelles versions du noyau ou de modules.

Kpackagekit n'est pas idéal pour ça.

Je te conseille de le faire dans une console (Alt+F2 puis "konsole").

Dans la console, tape
sudo aptitude update
sudo aptitude upgrade

Ensuite, il faudra redémarrer l'ordinateur.

A part ça, quel matériel as-tu ?

Dans la console, tape
lspci

et cherche la ligne où on trouve wireless.

A+

Pierre
0
J'ai tapé les deux sudo et j'ai fait les mis à jour que tu m'as dit de faire. Et j'ai redémarré le PC.

Par contre, la commande "Ispci" ou "ispci" ne fonctionnent pas. Ca me dit: "bash: Ispci : commande introuvable" ou "bash: ispci : commande introuvable".

J'avais dit plus haut que je possède une carte wifi intel corporation PRO/Wireless 4965 AG or AGN.
A moins que tu voulais savoir autre chose...

Et le wifi ne fonctionne toujours pas.
0
Salut,

La commande, c'était lspci (avec un L pour commencer).

Mais tu as donné l'indication recherchée : Intel PRO/Wireless 4965 AG(N).
J'avais oublié...

La carte est connue pour avoir des problèmes qui peuvent (souvent) être résolus en mettant le firmware à jour.

Là ça devient plus délicat à piloter.

Voici les indications d'Intel pour cette mise à jour pour linux :

For Intel Wireless WiFi 4965AGN users:
% wget \
http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-4965-ucode-4.44.17.tgz
% tar xvf iwlwifi-4965-ucode-4.44.17.tgz
% cp iwlwifi-4965-ucode-4.44.17/iwlwifi-4965.ucode /lib/firmware/

ça veut dire que dans une console, il faut taper (ou coller) ce qui est à chaque ligne APRÈS le % !
Donc
wget \ http... (etc)

Il y a donc 3 commandes à taper successivement.

J'ai réglé un problème de ce type avec une carte wifi 3945 de cette façon et ça marche.

Après avoir fait ça, redémarre l'ordinateur.

Cordialement,

Pierre
0
J'ai essayé ce que tu m'as dit... Le wifi ne fonctionne toujours pas.
0
Ok. Je vais essayer d'installer ubuntu. Ou sinon j'attendrai le prochain kubuntu.

Merci beaucoup pour tes réponses rapides, Pierre. Je te dirai après si ça a fonctionné avec ubuntu ou le nouveau kubuntu.
0
Bonjour,

J'ai fait ce que tu m'as dit Pierre, et le wi-fi fonctionne parfaitement sur Ubuntu.
Tu avais sûrement raison pour kubuntu: Peut-être qu'il n'est pas encore assez opérationnel pour l'instant.
Merci pour tes nombreuses réponses rapides, le problème est résolu.
0