Slapd

je n'arrive plus à démarrer slapd d'ou peut venir le problème.

12 réponses

  1. Contributeur
    Salut,
    deja un bonjour ca aurait été plus acceuillant...
    Bon passons,
    quelle est ta distribution?
    0
    1. Salut vous deux,
      J'utilise fedora
      0
      1. Contributeur
        Salut,
        ok,
        tu vas te logguer en root et tu vas essayer:
        /sbin/service slapd status

        Si il y a des message d'erreurs, copie colles...au fait, avant ca tu as quels messages d'erreurs?
        0
        1. C'est au démarrage de l'ordinateur que j'ai vu qu'il ne c'était pas démarrer automatiqemenent, alors j'ai tapez la commande /etc/init.d/ldap start ca ma indiquez: démarrage de slapd: échoué

          et quand je tape ta commande ca m'inscrit: slapd: unrecognized service
          0
          1. Contributeur
            Salut,
            tentes plutot:

            /sbin/service ldap status
            0
            1. Avec ton autre commande sa indique que slapd est arrêté
              0
              1. Contributeur
                Salut,
                ok maintenant,on va lancer slapd à la mano.
                tapes slapd directment mais s'il n'est pas reconnu alors il faut le chercher:
                which slapd

                ou
                whereis slapd


                ensuite si il est par exemple dans /sbin, lances
                /sbin slapd


                Ce genre de mesaventure est du à un changement de ta coinfiguration de ta base ladp qui a mal passé sur tout si l'ancien base existe toujours auquel cas il y a conflit entre ce qui existe et la nouvelle base que tu veux créer.
                0
                1. Je fait comment je supprime l'ancien base ou je doit supprimer les deux
                  0
                  1. Contributeur
                    Salut,
                    en fait la seconde n'est pas créée.La meilleure chose c'est de reconfigurer tes fichiers slapd.conf et ldap.conf avec les parametres de l'ancienne base.La ensuite duex choses sont possibles:
                    -tu supprimes l'ancienne auquel cas tu pourras en créer une nouvelle.?
                    -tu gardes l'ancienne histoire de te faire la main.
                    Mais avant tout
                    1)qu'as tu fais jusqu'à present?
                    2)As tu deja créé une base au prealable ?
                    3)as tu reussi à lancer slapd?
                    0
                    1. J'ai remise l'ancienne configuration maintenant slapd est en cours d'exécution.
                      Qu'est ce que je doit faire pour supprimer l'ancienne, ajouter la nouvelle sans faire la même erreur avec slapd
                      0