Comment démarrer apache

Résolu
svp, je sollicite de l'aide
après avoir installer apache 2.0.47 sur une suse 7.3 je n'arrive à lancer le daemon qui est situé dans /usr/local/apache2/bin en faisant un apachectl start
je voudrais savoir comment activer cette commande.

10 réponses

  1. Salut,

    Normalement pour lancer un daemon :

    /etc/init.d/apache start
    1. selon les version tu risques d'avoir

      http (meme methode) de lancement

      ..../init.d/httpd start
    2. Bonjour,
      il faut lancer le démon en mode root
      #/usr/local/apache2/bin/apachectl start
      a+
      1. merci pour vos réponses.
        la commande de philtrain est la bonne, mais lorsque j'essaie
        de lancer apache je reçois le message d'erreur
        (98) Adress already in use : make sock: could not be to adress
        [::]:80
        no listening sockets avaible, shutting down
        unable to open logs
        euh voila pour le message d'erreur si quelqun sait ce que sa veut
        dire ?, merci d'avance pour vos réponses.
    3. j'ai réglé le problème il y avait un conflit avec une ancienne version
      d'apache que j'ai maintenant désinstallé.
      merci toutes les réponses .
      1. Bonjour,
        je n'arrive pas a lancer apache, quand je fait /etc/init.d/apache2 start
        cela me met rien !!!!
        1. Modérateur
          Salut,

          s'il ne te met rien alors c'est très bien ;-)

          affiche el résultat de
          ps aux | grep apache
          --
          106485010510997108
        2. @lami20jbonjour,
          merci mais voila le code qu'affiche le code ps aux | grep apache
          apache 8565 0.0 2.4 23744 5456 ? S 17:17 0:00 /usr/sbin/httpd
          apache 8566 0.0 2.4 23744 5464 ? S 17:17 0:00 /usr/sbin/httpd
          apache 8567 0.0 2.4 23744 5456 ? S 17:17 0:00 /usr/sbin/httpd
          apache 8568 0.0 2.4 23744 5464 ? S 17:17 0:00 /usr/sbin/httpd
          apache 8569 0.0 2.4 23744 5444 ? S 17:17 0:00 /usr/sbin/httpd
          apache 8570 0.0 2.4 23744 5444 ? S 17:17 0:00 /usr/sbin/httpd
          apache 8571 0.0 2.4 23744 5444 ? S 17:17 0:00 /usr/sbin/httpd
          apache 8572 0.0 2.4 23744 5444 ? S 17:17 0:00 /usr/sbin/httpd
          root 8592 0.0 0.2 3872 504 pts/2 D+ 17:22 0:00 grep apache
          en plus lorsque je tape ps aux |grep httpd
          il me donne une erreur garbage option que je comprend pas ,car je suis debutante en linux et ils m'ont demander au stage d'installer et configurer apach ert dns
      2. As tu essaye httpd service start ?
        1. bonjour,
          j'essaye de demarrer apache mais j'ai une erreur garbage option
          svp aidez moi a la resoudre je suis bloquee
      3. Bonjour,
        svp aidez moi,quand je mets" /etc/init.d# apache2 -k start" on m'affiche:

        apache2: bad user name ${APACHE_RUN_USER}
        svp si quelqu'un peut résoudre ce problème et merci d'avance.
        1. Salut,

          Wubi, j'espère pour lui qu'il a trouvé la solution, depuis le temps ^^