[suse linux] phpMyAdmin

bonjour,
on peut me dire se que cela signifie:

"phpMyAdmin - Erreur

PHP ne peut charger l'extension session,
veuillez vérifier votre configuration de PHP"

Ce message arrive quand je tape:
http://localhost/phpMyAdmin

Merci
Configuration: Linux
Firefox 2.0.0.4

10 réponses

  1. j'ai fait un petit test en recompilant php avec l'option '--disable-session' et j'obtiens ton message d'erreur:
    phpMyAdmin - Error

    Cannot load session extension. Please check your PHP configuration.

    Recompile php avec l'option '--enable-session' lors du ./configure.
    Bon courage!
    0
    1. bonjour,
      merci pour ton aide. Oui le problème doit venir de l'option '--disable-session' qui est dans ma configuration mais comment faire pour changer tout ca?
      Tu peut me dire ou taper la commande pour pouvoir changer cette option en '--enable-session".

      Merci
      0
    2. Il faut que tu recomile php avec les bonnes valeurs lors du configure:
      Pour moi par ex:
      ./configure \
      --prefix=/opt/php5 \
      --with-oracle=$ORACLE_HOME \
      --with-oci8=$ORACLE_HOME \
      --with-mysql \
      --with-apxs2=/opt/apache2/bin/apxs \
      --with-config-file-path=/opt/php5 \
      --with-libdir=lib64 \
      --enable-libxml \
      --enable-filter \
      --enable-session \
      --with-mm \
      --with-pcre-regex=/usr \
      --enable-xml \
      --enable-simplexml \
      --enable-spl \
      --disable-debug \
      --enable-memory-limit \
      --enable-inline-optimization \
      --enable-zend-multibyte \
      --disable-rpath \
      --disable-all \
      --enable-cli

      puis make et make install.
      Le problème est de bien indiquer les binaire d'Apache. Le mieux étant de tout recompiler. C'est la raison pour laquelle je te siuhaitais bon courage!!
      0
  2. autre piste, ton php est-il compilé avec l'option --enable-session (voir valeur de 'Configure Command' au résultat de phpinfo())
    0
    1. Oublie les extensions dll avec Linux
      Est-ce que tu pointes bien sur le bon php.ini
      Vois au résultat de phpinfo(), la valeur de 'Loaded Configuration File'
      0
      1. as-tu initialisé ta valeur short_open_tag à ON dans ton php.ini
        0
        1. oui aussi,
          j'ai meme décommenter toutes les lignes ayant "mysql" ou"sql" dans php.ini.

          Exemple:
          extension=php_mysql.dll

          Mais aparement ca c'est la configuration pour windows (extension .dll) et pour Linux c'est plutot .so ? Non?

          merci
          0
      2. oui mes scripts marchent tous, phpinfo(); également.

        Peux tu m'aider?

        merci
        0
        1. Tes scripts php fonctionnent-ils?
          As-tu testé un phpinfo() ?
          0
          1. S'il vous plait esce qu'il y a quelqu'un qui puisse m'aider?!!!
            J'ai vraiment besoin de vous.

            Merci
            0
            1. bonjour,

              SVP HELP ME!!!!!!

              J'ai vraiment besoin de vous. Ca fait une semaine ke je suis sur cette erreur alors please aidez-moi!!!

              mon erreur est quand je tape:
              -> http://localhost/mysql

              j'obtiens ce message:
              -> phpMyAdmin - Erreur

              PHP ne peut charger l'extension session,
              veuillez vérifier votre configuration de PHP

              Merci pour votre aide
              0
              1. salut,

                est ce que quelqu'un saurait où se trouve le fichier a modifier ou au moins son nom.

                merci.
                0