MyISAM

Bonjour,

J'ai un probleme, je n'arrive pas a importer une table dans ma base de données. Le probleme se trouve au niveau de la requête "TYPE=MyISAM". Lorsque j'insère la table, le message suivant s'affiche :

" #1064 - Erreur de syntaxe près de '(14) NOT NULL )ENGINE=MYISAM' à la ligne 4 "

Après avoir passé en revue tous les sites parlant du sujet je n'arrive toujours pas a trouver ce qui cloche.
J'ai vraiment besoin de comprendre. Merci pour votre aide.

Le code

CREATE TABLE myboard_vl (
idv smallint(11) NOT NULL default '0',
ip varchar(15) NOT NULL default '',
time timestamp(14) NOT NULL
) TYPE=MyISAM;

2 réponses

  1. Merci pour l'aide, tout fonctionne bien. Je tacherai de changer le nom de la colonne "time"
    0
    1. Ca serait pas mal de passer en "Résolu":)
      0
  2. Comme l'indique le message d'erreur, ce n'est pas "TYPE=MyISAM" qui pose problème mais "(14) NOT NULL )", ou plus précisément "timestamp(14) NOT NULL )".

    Le type de champ "timestamp" n'accepte pas de paramètre supplémentaire.
    timestamp NOT NULL

    Au passage, choisir "time" comme nom de colonne risque de poser problème; il s'agit d'un mot clé.
    0