Pbm Clavier, oss/fr et latin9 dans xorg.conf [Résolu/Fermé]

Signaler
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008
-
 scoubidou -
Bonjour,

J'ai un pbm avec le fichier etc/X11/xorg.conf :
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "oss-fr"
Option "XkbVariant" "oss"
Quand je veux changer "oss" en "fr" et "latin9" comme c'est conseillé dans beaucoup de forum, la police de mon clavier devient folle, et j'ai du rebooter en mode recovery pour changer le fichier en mode root car sinon il trouvait mon mot de passe éroné(normal, vu la police prise en compte!!) quand je voulais modifier le fichier à partir du terminal.

Je n'ose plus trop changer le fichier, et d'ailleurs il fonctionne très bien comme ceci au détail près qu'à chaque démarrage de l'ordi, je dois faire un Ctrl+Alt+Backspace pour qu'il prenne en compte les "é","à","@"...

Comment faire en sorte qu'il lance automatiquement et correctement le serveur graphique (c'est ce que fait Ctrl+Alt+Backspace, si j'ai bien compris) ou comment faire pour modifier le fichier xorg.conf ?

Merci d'avance pour vos réponses.

13 réponses

Messages postés
2571
Date d'inscription
vendredi 1 avril 2005
Statut
Contributeur
Dernière intervention
6 septembre 2008
374
Salut,

Voici ce que dois contenir ton xorg.conf :
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "fr"
    Option "XkbVariant"  "oss"
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

Rebonjour,

Merci pour ta réponse mais ça ne marche pas pour moi.... :-(
Mon pc ne supporte pas quand je met Option "XkbLayout" "fr"
La police de mon clavier est toute bizarre avec aucune lettre de l'alphabet classique...

As tu une autre idée ?

Merci d'avance.
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

euh... quand je dis "pc" j'entends ordinateur... je suis sous ubuntu depuis peu...:-s
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

Sinon, j'ai essayé de faire:
sudo aptitude update
sudo aptitude upgrade
(vu sur http://www.commentcamarche.net/forum/affich 3957681 pb avec mon clavier)

Et voilà les messages d'erreur qu'il m'indique pour les deux :

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: Impossible de reconstruire le cache des paquets

Y-a-t-il une erreur à corriger qui pourrait être à l'origine de mon pbm??

Merci d'avance.
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

Bon je continue ma lecture de http://www.commentcamarche.net/forum/affich 3957681 pb avec mon clavier et je donne la réponse aux commandes:
- xprop -root | grep XKB:
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "oss", "oss", ""
_XKB_RULES_NAMES(STRING) = "xorg", "acer_laptop", "us,fr", ",", "grp:alts_toggle"

-gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd :
layouts = [us,fr]
model = acer_laptop
options = [grp grp:alts_toggle]
overrideSettings = true

Je n'ose pas ensuite purger xorg comme le conseille mamiemando...
Messages postés
2571
Date d'inscription
vendredi 1 avril 2005
Statut
Contributeur
Dernière intervention
6 septembre 2008
374
Peux tu afficher ton xorg.conf au complet ?

Tu dois avoir un module pas ou mal chargé qui fait partir en sucette les caractères.
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

Salut,
Voici mon xorg.conf complet:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "oss"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
EndSection


Merci encore pour ton aide.
Remplace :
Option "XkbLayout" "oss"
Option "XkbVariant" "oss"

Par :

Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

Je viens de me rendre compte en essayant de mettre à jour ubuntu que le message suivant s'affiche et m'empêche d'installer les mises à jour:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

Le même que lorsque je tape les commandes :
sudo aptitude update
sudo aptitude upgrade

Je donne des info, au cas où cela t'inspirerait plus qu'à moi... ;-)
Messages postés
2571
Date d'inscription
vendredi 1 avril 2005
Statut
Contributeur
Dernière intervention
6 septembre 2008
374
le plus simple est de te créé un xorg.conf propre, tapes ceci :
sudo dpkg-reconfigure -phigh xserver-xorg

Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

Re,
En fait j'ai deja essaye mais il me met dans le fichier xorg.conf "fr" et "latin9" comme conseille partout et alors ma police est completement tordu jusqu'a ce que je remette "oss" partout...
D'ailleurs la il faut que je reboot mon ordi car il ne veut plus me prendre en compte les accents... sniffffff
Mais merci quand même de l'aide.
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

Re...
Je viens de réaliser quelque chose de ... "suprenant" !!!!
J'ai choisi comme option de ne pas afficher au démarrage la page où l'on choisi l'utilisateur et l'on met le mot de passe : il arrive directement sur le bureau. Et alors il ne prend pas en compte les accents ni @ (et sûrement plein d'autre touche lol).
Quand je fais Ctrl+Alt+Backspace, il affiche cette page de "choix de l'utilisateur" :
- si je clique sur l'utilisateur dans la liste (il n'y en a qu'un) et que je met mon mot de passe root, tout va bien, mon clavier refonctionne normalement.
- si j'attends 10 secondes, il se "log" automatiquement, comme un démarrage normal de l'ordi et alors mon clavier foire...

Là, je suis un peu perdu!!

Au pire je vais enlever l'option d'aller automatiquement sur le bureau pour à chaque fois sélectionner ma session avec le mot de passe root pour que mon clavier fonctionne normalement... mais bon j'aimerais quand même comprendre pourquoi il bug comme ça !!! (question de curiosité intellectuelle)

Je vais continuer de chercher sur Internet si quelqu'un n'a pas déjà eu ce problème en choisissant l'option d'arriver directement sur le bureau au démarrage...

Merci encore.
Messages postés
204
Date d'inscription
vendredi 1 février 2008
Statut
Membre
Dernière intervention
8 octobre 2010
10
deja pour faire propre, fait:

sudo dpkg --configure -a

ensuite

apt-get update
apt-get upgrde

deja t'aura un system OK, ensuite on pourra corriger ton pb de clavier!
a mon avis ca vien de la ton soucis!!!
Messages postés
23
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008

Merci,
je viens de faire les deux commandes.
Maintenant, que dois-je faire ?