[WGET] --http-user non pris en compte

[Résolu/Fermé]
Signaler
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
-
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
-
Bonjour,

il m'arrive un truc pour le moins étrange.
j'ai 2 stations chez moi, une sous Ubuntu une sous gentoo.
je télécharge souvent des fichiers venant de rapidshare.com, des vidéos de concert pour une asso, c'est pas tres volumineux mais ça peut etre par exemple 8 morceaux de vidéos et j'en fais un montage bref...
j'ai donc un compte premium pour pas mettre 2 jours a tout récupérer.
pour faire ça j'utilise wget de la façon suivante:

wget --http-user=monuser --http-password=monpasswd --input-file=list.txt

et dans la liste je met les fichiers dont j'ai besoin, si c'est un seul fichier je met juste l'url.

bon et bien de ubuntu ça fonctionne sans aucun pb, sous gentoo ça ne marche pas.

le user et le mot de passe ne sont pas pris en compte !?

il me telecharge des fichiers de 1ko avec les bons noms mais bon...

ça ne m'avance pas.

j'utilise wget 1.11.3, j'ai bien openssl d'installé, qu'est ce qui pourrait coincer?

3 réponses

Messages postés
29984
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 juillet 2021
7 144
J'imagine que tu tapes exactement la même commande sous gentoo et sous ubuntu ?
Si c'est le cas compare les versions de wget, car visiblement le problème est côté client (wget mal installé ou mal paramétré sous gentoo). En outre je t'invite à faire une mise à jour de ta gentoo en particulier wget. De mémoire c'est un truc du genre :
esync -v
emerge -auD
ldconfig

Vérifie que tu as bien installé wget sous gentoo avec tous les flags qui vont bien (tu peux les configurer avec ufed par exemple), j'imagine en outre qu'il y a un flag pour ssl :
emerge -avD wget

Désolée pour les indications un peu vague mais ça fait des années que je n'ai plus touché une gentoo (et oui debian c'est quand même plus pratique ^^).

Bonne chance
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
111
"Désolée pour les indications un peu vague mais ça fait des années que je n'ai plus touché une gentoo (et oui debian c'est quand même plus pratique ^^)"

Trop gros passera pas ! :)

sinon, ben écoute avant de poser la question j'ai déja fait tout ça, j'ai mis a jour wget en ~x86 et je l'ai compilé avec tout les flags USE de dispo c'est a dire pas grand chose...

coté ssl j'ai installé tout ce qui etait dispo dans portage même les paquets qui me semblaient faire doublon, au cas où...

j'ai testé de telecharger sans mettre --http-user et ça fait la meme chose ça me DL des fichiers d'un Ko, c'st ça qui me fait dire que le --http-user n'est pas pris en compte.

mais je fais peut etre fausse route.

Merci pour le coup de main en tout cas, je continue a chercher.
Messages postés
29984
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 juillet 2021
7 144
Tu es sûr que tu utilises la bonne syntaxe de wget sous gentoo ? Je veux dire elle est peut être un peu différente (même si ça paraît peu probable) ?
man wget

Est-ce que wget fait ce qu'il faut vers une URL publique (sans authentification) par exemple ?

Bonne chance
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
111
alors j'ai avancé de façon significative, le pb de --http-user n'est pas résolu mais malgré tout j'arrive a telecharger en passant par WGET.

et finallement cette methode est peut etre encore mieux.

jusque la je passais par downthemall puisque wget ne marchait plus, pour ce faire je devais me connecter a mon compte premium et laisser la page ouverte pour profiter du cookie encore présent dans Firefox.

donc je me suis inspiré de cette méthode pour utiliser Wget,

j'ai sauvegardé le cookie, et au lieu de d'utiliser http-user je charge le cookie en utilisant --load-cookies.

et la ça passe.