Patages de fichier XP linux via Samba [Résolu/Fermé]

Signaler
-
 Utilisateur anonyme -
Bonjour,

Depuis Linux je vois les fichiers Wxp, mais pas l'inverse.
Avant de poster ce message, j'ai regardé les différents post du forum, j'ai ainsi revu mon fichier smb.conf et le fichier iptable.

Malheureusement la ituation est toujours la même.
je joins mes deux fichiers :

iptables
# Firewall configuration written by lokkit
# Manual customization of this file is not recommended.
# Note: ifup-post will punch the current nameservers through the
# firewall; such entries will *not* be listed here.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:RH-Lokkit-0-50-INPUT - [0:0]
-A INPUT -j RH-Lokkit-0-50-INPUT
-A RH-Lokkit-0-50-INPUT -p udp -m udp -s 0/0 --sport 67:68 -d 0/0 --dport 67:68 -i eth0 -j ACCEPT
-A RH-Lokkit-0-50-INPUT -p udp -m udp -s 0/0 --sport 67:68 -d 0/0 --dport 67:68 -i eth1 -j ACCEPT
-A RH-Lokkit-0-50-INPUT -i lo -j ACCEPT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 0:1023 --syn -j REJECT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 2049 --syn -j REJECT
-A RH-Lokkit-0-50-INPUT -p udp -m udp --dport 0:1023 -j REJECT
-A RH-Lokkit-0-50-INPUT -p udp -m udp --dport 2049 -j REJECT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 6000:6009 --syn -j REJECT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 7100 --syn -j REJECT
#SAMBA
#epmap => définit toutes les RPC
-A INPUT -i eth1 -s 192.168.0.0/24 -d 192.168.0.1 -p tcp -m tcp --dport 135 -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -i eth1 -s 192.168.0.0/24 -d 192.168.0.1 -p udp -m udp --dport 135 -m state --state ESTABLISHED -j ACCEPT
-A OUTPUT -o eth1 -s 192.168.0.1 -d 192.168.0.0/24 -p tcp -m tcp --sport 135 -m state --state ! INVALID -j ACCEPT
-A OUTPUT -o eth1 -s 192.168.0.1 -d 192.168.0.0/24 -p udp -m udp --sport 135 -m state --state NEW -j ACCEPT
#NetBios-NS
-A INPUT -i eth1 -s 192.168.0.0/24 -d 192.168.0.1 -p tcp -m tcp --dport 137 -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -i eth1 -s 192.168.0.0/24 -d 192.168.0.1 -p udp -m udp --dport 137 -m state --state ESTABLISHED -j ACCEPT
-A OUTPUT -o eth1 -s 192.168.0.1 -d 192.168.0.0/24 -p tcp -m tcp --sport 137 -m state --state ! INVALID -j ACCEPT
-A OUTPUT -o eth1 -s 192.168.0.1 -d 192.168.0.0/24 -p udp -m udp --sport 137 -m state --state NEW -j ACCEPT

#NetBios-DGM
-A INPUT -i eth1 -s 192.168.0.0/24 -d 192.168.0.1 -p udp -m udp --dport 138 -m state --state ESTABLISHED -j ACCEPT
-A OUTPUT -o eth1 -s 192.168.0.1 -d 192.168.0.0/24 -p udp -m udp --sport 138 -m state --state NEW -j ACCEPT
#NetBios-SSN
-A INPUT -i eth1 -s 192.168.0.0/24 -d 192.168.0.1 -p tcp -m tcp --dport 139 -m state --state RELATED,ESTABLISHED -j ACCEPT
-A OUTPUT -o eth1 -s 192.168.0.1 -d 192.168.0.0/24 -p udp -m udp --sport 139 -m state --state ! INVALID -j ACCEPT

#SSH
-A INPUT -i eth1 -s 192.168.0.0/24 -d 192.168.0.1 -p tcp -m tcp --dport 22 -m state --state RELATED,ESTABLISHED -j ACCEPT
-A OUTPUT -o eth1 -s 192.168.0.1 -d 192.168.0.0/24 -p tcp -m tcp --dport 22 -m state --state ! INVALID -j ACCEPT
COMMIT


et le smb.conf
#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
server string = Redhat9

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
; hosts allow = 192.168.1. 192.168.2. 127.
hosts allow = 192.168.1. 127.

# this tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/%m.log

# Put a capping on the size of the log files (in Kb).
max log size = 0

# Security mode. Most people will want user level security. See
# security_level.txt for details.
security = share

# See speed.txt and the manual pages for details
# socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The built-in default for versions 1.9.17 is yes,
# this has been changed in version 1.9.18 to no.
dns proxy = no

#============================ Share Definitions ==============================
[homes]
comment = Home Directories
browseable = yes
writable = yes
create mode = 0664
directory mode = 0775
public = yes
path = /home

[tmp]
comment = Temporary file space
path = /tmp
read only = no
public = yes
directory mode = 0777
[Jean-Luc] comment = JL
path = /home/Jean-Luc
public = yes
writeable = yes
printable = no
guest ok = yes

3 réponses

Bonjour,

ajoutez peut etre dans la section [global]
domain master = yes
os level = 99

Ainsi votre samba sera pilote du domaine, c'est plus simple. Par contre il faut que votre utilisateur windows soit declaré sur Linux.

Bonjour,
je vais essayer ce soir. L'utilisateur est bien déclaré.
une question sur iptables :

si plusieurs lignes concernent le même port, laquelle est prise en compte ?
la dernière ou la plus restrictive ?

Merci
Jean-Luc

La solution de Kiki, après diverses modifications ont solutionné mon problème.

ces modifications ont été apportées dans les fichiers :
smbconf
iptables
et des droits sur les répertoires partagés.

le problème de cet synthèse est qu'il est difficle de savoir exactement quelle modification a été salvatrice.

La seule certitude est qu'il faut remercier jipicy,zachrius, kiki et ceux que j'oublie