Résolution d'écran sous Raspian [Résolu]

Signaler
Messages postés
230
Date d'inscription
mercredi 7 mars 2012
Statut
Membre
Dernière intervention
21 janvier 2021
-
Messages postés
230
Date d'inscription
mercredi 7 mars 2012
Statut
Membre
Dernière intervention
21 janvier 2021
-
Bonjour,

J'ai deux soucis d'écran sur mon Raspberry tournant sous la dernière version de Raspbian.
- Résolution non prise en charge (via Raspi-config)
- Extinction de l'écran lorsque je lance une application (pb aléatoires).

J'ai voulu diminuer la résolution pour régler le 2ème pb, et je me ssuis mis en 640x480 mais cette résolution n'est pas prise en compte .
Mon écran est connecté via HDMI sur la TV

Mon fichier config.txt :
# For more options and information see
# https://www.raspberrypi.org/documentation/configuration/config-txt/README.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=4

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d


Merci pour votre aide

Configuration: Raspbian Pi4 - 8Go

3 réponses

Messages postés
36279
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 857
Salut,

Il fut un temps pour le Raspberry 2 ou 3 de problèmes inhérents à la puissance de l'alimentation utilisée qui occasionnait des pertes d'affichage ou de mauvaises résolutions.
Investiguer déjà de ce côté là…

Sinon, j'ai trouvé ce lien qui explique pas mal de choses…

Messages postés
230
Date d'inscription
mercredi 7 mars 2012
Statut
Membre
Dernière intervention
21 janvier 2021
10
Re-bonjour, et encore merci pour ton aide.
Mon alimentation est celle d'origine (neuve) en 5v et 3A, donc je ne pense pas que mon problème vienne de là.

C'est la 3ème fois que je ré-installe l'os complet, car j'avais de soucis de flash d'écran insolvable, mais j'avais réussi à modifier mes paramètre d'affichage après installation de plusieurs paquets mais je ne me rappelle plus lesquels... OUPSSSSS. J'ai été trop con de ne pas les noter car maintenant je n'y arrive plus...

Je précise plusieurs points :

- Je sors du raspberry Pi 4 par le câble micro HDMI / HDMI mais j'ai un adaptateur HDMI -> DVI-D connecté sur mon écran.
-
raspi-config
=> Default Monitor prefered resolution
-
xrandr -s 1024x768 -r 60.00
=> Size 1024x768 not found in available modes
- OS : Raspbian (Raspberry) 2020-12-04-buster -armhf
- Bureau : lightdm-xsession
- Gestionnaire : lightdm-xsession

Dernière précision, si je connecte mon raspberry directement sur la tv sans adaptateur, ma résolution est OK

Décidément je rame comme un fouuuuuuuuuuu mais c'est comme ça qu'on apprends, non ?
Messages postés
36279
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 857
Re-
Dernière précision, si je connecte mon raspberry directement sur la tv sans adaptateur, ma résolution est OK
C'est à dire ?
câble micro HDMI => HDMI
?

Pourquoi passer par un adaptateur
HDMI -> DVI-D
?

Après concernant tes manips passées dont tu ne te rappelles plus, je ne saurais te dire.
Messages postés
230
Date d'inscription
mercredi 7 mars 2012
Statut
Membre
Dernière intervention
21 janvier 2021
10
C'est un câble avec une prise micro HDMI (cpté Raspberry) et HDMI de l'autre.
Je passe par un adaptateur car je n'ai pas de prise HDMI sur mon écran.

Bon, j'ai modifié
hdmi_mode=4
en
hdmi_mode=16
et cela fonctionne bien.

J'ai fait tellement de truc différents sans vraiment comprendre que je m'y suis complètement perdu...
C'était pourtant tout simple mais à force de chercher sur plein de forums, on fini par s'y perdre soi-même.

Mil merci zipe31 :-)