Kompozer sous Xubuntu 18.04 32bits

Résolu/Fermé
Signaler
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
-
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
-
Bonjour, Ubuntu ne veut plus soutenir le 32bits ..Hors nous avons encore un parc d'ordi en 32bits et nous utilisons ubuntu depuis au moins 10 ans ..J'ai donc formaté pour essais un pc acer en 32bits appartenant a une amie avec Xubuntu 18.04 LTS et c'est mauvaises surprises sur mauvaises surprises des logitiels qui jusqu'a maintenant ne posaient aucun problèmes sont devenus maintenant ininstallable ( il a fallut que je retourne a la bonne vieille méthode du tar.gz pour installer Xampp quand a Kompozer qui est nécessaire sur son PC et bien cela fait trois jours que je galère et il n'est toujours pas installé car il semblerait que les paquets trouvés en 32bits ne soient pas bons ou soient bugués ..Je lui ai mis bluegriffon à la place mais ça ne lui convient pas ...
Ma question est Kompozer est il encore installable ( je l'ai sur Ubuntu 16.04 ) et il s'était installé sans problème) ?
Si oui auriez vous des indications pour les télécharger ..
Merci !



5 réponses


je suis désolé de confirmer que les procos en 32 bit ne sont plus maintenus depuis quelque temps , en fait un certain temps déjà et bien qu'il fonctionne encore il n'est plus possible de faire une mise à jour , sur un système 32bit
1
Bonjour,
je suis désolé de confirmer que les procos en 32 bit ne sont plus maintenus depuis quelque temps , en fait un certain temps déjà et bien qu'il fonctionne encore il n'est plus possible de faire une mise à jour , sur un système 32bit

Certes Ubuntu a arrêté le support 32 bit, mais il y a plein d'autres distributions qui le conservent toujours et comportent même la plus récente version, c'est pas ce qui manque : Debian, Linux Mint, xubuntu, kubuntu et lubuntu pour ne citer que celles basées sur Debian.

Il n'y a que quelques logiciels, le plus souvent propriétaires qui ne sont plus disponibles pour le 32 bit (skype par exemple) alors si le logiciel est présent dans les dépôts il devrait s'installer sans problème. J'ignore si kompozer en fait partie, le site officiel étant actuellement indisponible.
D'ailleurs, il arrive parfois que certains logiciels ne sont disponibles qu'en 32 bit (driver de certaines imprimantes)
Inutile de faire une installation sur le disque pour voir si ce logiciel est installable dans la version 32 bit : il suffit de tenter l'installation dans la session live-cd.
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Et bien on va retourner sous windows 7 qui a une version de Kompozer sous 32bits puisque le but non avoué d'ubuntu est de nous faire jeter nos PC 32bits dont le parc Français est encore très important ( quoi que les nouveaux windows 8 et 10 ce sont des cata pour bosser) ..
Enfin nous cela fait plus de 10 ans que nous bossons sous linux principalement Xubuntu et ça nous peinerait d'aller voir ailleurs pour des prises de décisions stupides ..Avec ça le site officiel de Kompozer est suspendu donc pas de solution et disque d'install W7 dans la machine malheureusement car la copine a besoin de sa machine et moi pas le temps de m'amuser a faire de l'informatique bien que ça ne me déplaise pas ...
Il a déjà fallut repasser un CAP pour installer bluegriffon dont gedebi refusait d'installer les paquets deb et reprendre une toute vieille installation de Xampp par la méthode tar.gz , la version run ne s'installant pas et fichant la pagaille dans les fichiers machine et Lamp ne s'installant pas mieux ..
Enfin bref ras le bol de perdre son temps
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Le plus gros problème est qu'a chaque fois que nous mettons des pc sous windows au milieu des Linux et mac nous sommes obligés de modifier le réseau et de pleurer pour ça ..
0
Tu as tenté l'installation décrite dans cette page pour Ubuntu 16.04 ?
https://doc.ubuntu-fr.org/kompozer

Canonical à viré le code source de ses dépôts pour Ubuntu 18.04 alors pas de solution de ce côté. Tu peux installer une 16.04 (mises à jour jusqu'en 2021, ça te laisse de la marge)...

Sinon, il n'y a pas que Ubuntu, tu as linux Mint qui est dérivée d'ubuntu qui propose toujours des versions 32 bit... Une Mint Mate tournerait comme une horloge sur vos vieux pc...

Tu peux aussi essayer de faire tourner la version Windows avec wine sous linux, si ça se trouve elle est parfaitement opérationnelle, faut essayer pour voir.
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Bonjour la version d'installation de Kompozer par la doc ubuntu du lien cité ne fonctionne pas du tout non plus sur les installation fraîches du 16.04 c'est impossible aussi j'ai tenté le coup donc je juge avoir perdu assez de temps comme ça et le temps c'est de l'argent ...Je tenterai mint un Dimanche de mauvais temps la je lui mets un Windows 7 et je préviens ma hiérarchie qu'on ne peut raisonnablement plus bosser avec ubuntu ( la moitié de nos pc sont en 32bits et on ne va pas les mettre a la poubelle ) ..
0
La dernière version Windows téléchargeable de kompozer est la 0.8b3. Cette version date de 2010 ! Ça veut donc dire que le projet est inactif depuis cette date. Ajouté au fait que le site web soit maintenant inaccessible, j'ai bien peur que le projet ne soit définitivement mort. Et même la version windows risque de ne plus fonctionner prochainement. Si tu veux quelque chose de viable il va falloir passer par un logiciel alternatif.
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Je suis de ton avis sur l'avenir de Kompozer mais il fonctionne parfaitement sous Windows et même sur ce PC que j'utilise pour l'instant sous " Ubuntu 16.04 LTS " lui aussi en 32 bits c'est sur les nouveaux Lubuntu , Xubuntu 18.04 en 32bits qui n'acceptent pas les installations autant de Kompozer que de Xampp ( qui heureusement lui a maintenu les anciennes versions ce qui m'a permis d'installer un serveur mais après de longs essais alors que d'habitude ça se fait en 5 minutes ) Même l'installation de bluegriffon a été galère ..C'est donc que tous les ennuis viennent des nouvelles versions en 32bits qui sont mal faites et ou certaines anciennes bibliothèques ne s'installent plus et manquent aux installations de certainement encore plus de logiciels ..Ce qui n'est pas cool pour des gens qui utilisent linux professionnellement ...
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Bonjour après différents essais infructueux entre Xubuntu 16.04 ( qui pourtant ne posait pas problèmes avant ) Lubuntu 18.04 , Xubuntu 18.04 qui pourtant soutient le 32bits j'ai tenté le coup avec "Mint 18 Cimanon" et tout fonctionne les serveurs et sans chipoter des heures ainsi que Kompozer par l'installation préconisée pas la documentation ubuntu ..Avec ça pas besoin de modifier le réseau ..
Reste a savoir jusqu'à quand
0
Ne tente pas Mint 19 : elle est basée sur Ubuntu 18.04. Mint 18 est elle basée sur Ubuntu 16.04.
Tu auras des mises à jour jusqu'en avril 2021. D'ici là, ta boite aura sans doute remplacé son parc de pc.
0
Messages postés
40037
Date d'inscription
mercredi 5 novembre 2003
Statut
Modérateur
Dernière intervention
17 janvier 2022
4 044
Salut

Je lis pourtant ici :

https://fr.wikipedia.org/wiki/Versions_de_Linux_Mint

Que Mint 19 est une LTS soutenu jusqu'en avril 2023.
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Bonjour j'ai parlé trop vite j'ai voulu faire un essai local de php5 mail() et il m'a pris de charger sendmail par le synaptic et ça me désinstalle Kompozer de même pour postfix ..mais bon on ne traite pas souvent des formulaires mails heureusement ...Un des techno de canonical qui s'occupe de notre parc sous linux m'a fait comprendre que même en 64bits Kompozer créera des soucis à l'avenir ...Nous allons rechercher dans les éditeurs de wysiwyg ou alors s'habituer a bluegriffon si c'est par obligation ..
0
@Pierrecastor :

Je lis pourtant ici :

https://fr.wikipedia.org/wiki/Versions_de_Linux_Mint

Que Mint 19 est une LTS soutenu jusqu'en avril 2023.


On est d'accord. C'est Mint 18 qu'il a installé et qui est maintenue jusqu'en 2021
0
@nanarbe :
Tu n'as pas essayé la version portable de Kompozer, c'est un binaire qui peut tourner sur n'importe quelle distribution linux, il contient tout ce qu'il faut, ce qui devrait t'affranchir des bibliothèques incompatibles qui provoquent des désinstallations en cascade et c'est du 32 bit...
Disponible ici :
https://sourceforge.net/projects/portable/files/?source=navbar
Lien direct :
https://sourceforge.net/projects/portable/files/Kompozer%200.8b1/download

Tu télécharges le fichier binaire Kompozer.8b1,
tu le renommes de manière à avoir un nom avec un seul mot : Kompozer par exemple.
Tu le rends exécutable (indispensable).
Ensuite tu le lances depuis le terminal :
cd /home/ton_login/Téléchargements
./Kompozer

(Tu pourras créer un lanceur en .desktop après).
Il va te demander de créer un profil et démarre ensuite.
J'ai pas testé plus loin.

Chez moi, il tourne sur une Debian. Seul problème, il est en anglais.
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Bonjour ..Donc pour en revenir a nos moutons ou plutôt à nos pingouins ; Il n'y a que sous Linux Mint 17 ( le 18 n'ayant pas été essayé ) qu'on peut remettre Kompozer et pour se faire il ne faut surtout pas installer de serveurs mails du type "sendmail" ou "postfix" qui désinstallent kompozer ..Il s'avère que si on met un serveur c'est sans fonction mail() de php qu'il faut l'installer sinon utiliser "bluegriffon " au lieu de Kompozer " Amaya " ne s'installant pas non plus par manque de ce paquet "libdl0" qui ne s'installe plus sous 32bits ..
Donc c'est irrésoluble ...Je mets donc tout de suite un(e) de mes stagiaires ou service civique à étudier le maniement de "bluegriffon" qui m'a l'air moins intuitif a utiliser que Kompozer ...
0
Messages postés
40037
Date d'inscription
mercredi 5 novembre 2003
Statut
Modérateur
Dernière intervention
17 janvier 2022
4 044
Après, perso, je trouve qu'apprendre à développer avec un éditeur WYSIWYG n'est pas une bonne idée du tout, mieux vaut partir d'un bon CMS ou un bon framework et ensuite ajuster. Surtout avec un éditeur pas mis à jour depuis 8 ans et donc pas à la page sur toutes les nouvelles techno et normes du web.

Mais ça n'est que mon humble avis (et celui d'un bon nombre de dev web). ;-)
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Kompozer ne nous sert qu'à gagner du temps surtout sur les remises a jours et non a former des développeurs ..Avec ça kompozer a été choisi comme outil de développement réglementaire ..On ne fait malheureusement pas ce qu'on veut et moi ça m'allait bien car avant j'utilisais NVU et je suis passé a Kompozer dans ses tous débuts et ce wysiwyg était super pratique et le code tout a fait correct ..en tous cas mieux que celui de dreamweaver de windows
0
Messages postés
46
Date d'inscription
mardi 14 juin 2011
Statut
Membre
Dernière intervention
12 décembre 2018
7
Bonjour et bonne nouvelle j'ai réussi au bout de x essais et j'ai compris pourquoi a installer Kompozer sous Mint 18 avec "wine" que j'ai réinstallé par ligne de commande car par la logithèque c'était bugué et ça ne marchait pas ..
Je vais mettre en résolu merci pour vos réponses ...
0