Modification fichier hosts sous vista [Résolu/Fermé]

Signaler
-
 JPDperso -
Bojour,

Je n'arrive pas à modifier le fichier hosts sous windows\system32\dirvers\etc . Je n'arrive également pas à générer un nouveau fichier dans ce repertoire.. j'ai un message qui m'indique qu'il faut être administrateur or je suis connecté sous un profil administrateur . Y a t il un option à decocher ? ou un procèdure à suivre ? Je suis sous vista edition familiale

Merci d'avance de vos réponses

Batator

9 réponses

Pour modifier le fichier HOSTS sous Vista :

aller dans le menu "demarrer" et rechercher "notepad" si c'est l'éditeur de texte que vous utilisez.
Ne faites pas un clic gauche, mais un clic droit de la souris et sélectionner "Executer en tant qu'administrateur"

si vous êtes déjà avec un compte Administrateur, il ne vous demandera rien, sinon il vous demande le mot de passe administrateur.

Dans l'éditeur de texte, aller ouvrir le fichier HOSTS, le modifier et faites "enregistrer"

C'est le seul moyen qui vous permet de modifier des fichiers protégé par le systeme, même avec le compte administrateur.
C'est un genre de "forçage" pour modifier les fichiers protégé par Vista.

@+
Dominique
109
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61496 internautes nous ont dit merci ce mois-ci

Utilisateur anonyme
Avec moi ça fonctionne.

Bon, tu va dans C:\Windows\System32\drivers\etc, puis tu clique-glisse le fichier hosts sur le Bureau.
Tu fais un clic droit dessus Ouvrir, tu choisis le Bloc-note, s'il apparait pas tu va dans C:\Windows\System32\notepad.exe tu le sélectionne.

Puis tu fais ta modification et tu enregistre.

Puis tu clique-glisse du Bureau à C:\Windows\System32\drivers\etc, tu confirme le remplacement.

A+
merci Domi pour l explication...........
Super sympa de ta part ! ;-))
merciiiiiiiiiiii beaucoup !! ca marche !!
Utilisateur anonyme
Enregistre par ce nom précisément "hosts", mets bien les guillemets, ça t'enregistrera ton fichier en hosts sans extension, et tu le glisse dans C:\Windows\System32\drivers\etc.

Voilà. ;)
Vous venez de me sauver la vie !!!
Merci à vous et à Google qui est venu directement ici avec la requete :"modifier le fichier hosts sous vista"
Vous vous embêtez pour rien les gars.

Vous lancez votre editeur "en tant qu'administrateur" par un clic droit sur l'icone et là le programme aura les droits d'écrire dans le fichier. Et c'est le même principe pour n'importe quel programme nécessitant une élévation de droits.
Si ca vous saoule, il suffit d'éditer les stratégies locales de sécurité et de désactiver les contrôles de compte utilisateur dont vous ne souhaitez plus. Après ces réglages, votre Vista se comportera comme un XP sans plus rien vous demander.

++
Bonjour,

pour modifier le fichier HOSTS, il suffit de se rendre dans le répertoire "C:\Windows\System32\drivers\etc", sélectionner le fichier "HOSTS", puis bouton droit de la souris, dans le menu contextuel, choisir ouvrir (associer à notepad --> Bloc note), effectuer les modifications, puis enregistrer sous le bureau par exemple avec le même nom. Une fois réalisé, vous avez sur le bureau un fichier nommé "hosts.txt", il suffit de le renommer (via la touche F2 une fois le fichier sélectionné) "HOSTS", on retire juste l'extension ".TXT" ajoutée par notepad. Ensuite, il ne reste plus qu'à copier ce fichier dans le répertoire "C:\Windows\System32\drivers\etc" et de confirmer l'écrasement et que cette manipulation provient bien de vous (sécurité Vista).

Cordialement, Jérôme.
Top Jérôme ca fonctionne encore merci
Messages postés
1
Date d'inscription
lundi 7 juillet 2008
Statut
Membre
Dernière intervention
7 juillet 2008

La solution est sur le site de Windows:

https://support.microsoft.com/fr-fr/help/923947/you-cannot-modify-the-hosts-file-or-the-lmhosts-file-in-windows-vista

Mais:

1) Il faut au préalable comme expliqué dans les messages précédents désactiver la protection du fichier qui est en"Lecture seule"

2) Si notepad ne "trouve" pas votre fichier Host, cliquez sur Ouvrir puis séléctionnez "tous les fichiers" au lieu de: " Fichiers textes (*.txt) "

3) Réactiver l'attribut "lecture seule" après modification.


Content d'avoir enlevé ces satanées publicités clignotantes dans live Messenger ou MSN en ajoutant ces 3 lignes

# Blocage publicités MSN
127.0.0.1 rad.live.com
127.0.0.1 rad.msn.com
Messages postés
533
Date d'inscription
mercredi 16 janvier 2008
Statut
Membre
Dernière intervention
11 mars 2009
48
Bonjour,

une solution pour indiquer l'extention:
Panneau de configuartion ---> Options des dossiers ---> Affichage
Dans la liste, décochez:"masquer les extensions des fichiers dont le type est connu"
C'est a cause de cela que ".txt" n'apparaît pas. En générale cette option est par défaut dans Vista.

Fox
Salut !

Même si c'est 2 mois après je mets la manip' :
Dans le "panneau de configuration" à partir du "Menu Démarrer", tu vas dans :

1 - 'Comptes d’utilisateurs et protection des utilisateurs'

puis,

2 - 'Comptes d'utilisateurs'

enfin,

3 - 'Activer ou désactiver le contrôle de compte d’utilisateur'

Soit à l'adresse : Panneau de configuration\Comptes d’utilisateurs et protection des utilisateurs\Comptes d'utilisateurs

Tu décoches la case "Activer ou désactiver le contrôle de compte d’utilisateur" pour la désactiver. Ensuite tu peux modifier ton fichier "hosts"
Le fichier host n'est pas censé avoir d'extension, donc il y a un problème.
il se trouve dans le repertoire C:\Windows\System32\drivers\etc

MERCI beaucoup benwoa!!! grâce a vous j'ai reussi!!!merci merci!!!
Bonjour à tous,

Essayé ce matin sous Vista Home : prendre le fichier Hosts, le copier sur le bureau, l'éditer avec Notepad, enregistrer, le déplacer dans son chemin d'origine. Sélectionner "Déplacer et Remplacer" et ça roule !!!

Cdlt,

Bruntho.