[lilo et grub] bloquer sur "loading windows&q

[Résolu/Fermé]
Signaler
Messages postés
1171
Date d'inscription
jeudi 7 septembre 2006
Statut
Membre
Dernière intervention
27 septembre 2010
-
 novocaine -
Hello!!!

Ce poste est juste pour information.

Beaucoup d'entre vous on linux, windows et/ou d'autres syteme d'exploitation sur leur machine. Et LILO et GRUB sont les programmes les plus utilisés pour permètre le démarrage au boot sur le systeme d'exploitation que l'on souhaite.

Ce thème ce base surtout sur LILO. Il est pour moi mon préféré.
Pour ceux qui connaisse bien LILO passer votre chemin. Pour les débutant ce thème peux savérer d'une grande utilité.

1- Récement, j'ai réinstaller ma petit slackware. Comme vous le savez pendant l'installation il est possible d'installer LILO sur le MBR du disque dur. Si l'hors de votre 1er installation vous avez installer lilo sur le MBR. Je vous conseil l'hors de la réinstallation d'un systeme linux plus raissent de le réinstaller. Celà permet d'éviter plusieur problème avec le noyau de votre nouveau linux.

--je ne rentre pas dans les détailles, mais en l'occurence si après une nouvelle installation de linux le noyau que veux charger votre linux est l'ancien noyau. Il est fort probable que le problème vienne de LILO.

2- Suite à cette installation je me suis retrouvé avec une slackware en parfaite état de marche :) (j'en suis encore tout retourner!!!). Mais l'hors de mon reboot pour aller sous windows un problème me tombe dessus!! :(
--LILO ce charge, me propose de sélectionner mon systeme d'exploitation. je choisi windows et là l'écrito "loading windows..." apparaît. Il faut savoir que sur plusieur site il est dis que le problème viend de windows. Ce qui n'est pas faut. Mais si vous arriver a démarrer windows le problème doue peux bien provenir ce problème?? Perso, je n'en sais rien. La seule chose que je peux vous dire c'est que LILO peux palier (résoudre) ce problème.

voici la configuration de base d'un lilo.conf pour windows :

other=/dev/hdb1
label="Windows"
table=/dev/hdb

la "table" n'est pas obligatoire.
hdb1 est le disque dur conserné (1 étant la partition ou ce trouve windows)

Maintenant pour résoudre ce problème de "loading windows" il faut ajouter ces commandes à la suite :

map-drive=0x80
to=0x81
map-drive=0x81
to=0x80

Ce qui nous donne :

other=/dev/hdb1
label="Windows"
table=/dev/hdb
map-drive=0x80
to=0x81
map-drive=0x81
to=0x80

Enregistrer et lancer la commande : "lilo"!

Et voilà le problème est résolut!!

pour GRUB.

là je me base sur les informations trouvé à droite et à gauche sur le net.
d'après ce que j'ai trouver il faut rajouter la commande : "chainloader +1"

ce qui donne quelque chose comme cela (dans le fichier : grub.conf):

title Windows XP
rootnoverify (hd0,0)
chainloader +1

Puisse ces informations être d'une grande utilité!

Bon, si je me suis tromper merci de complèter. Sur le net il y a peux d'information consernant ce genre de problème. (sauf sur les sites américain et étrangé).

voilà, @++

6 réponses

Messages postés
2
Date d'inscription
mercredi 14 février 2007
Statut
Membre
Dernière intervention
14 février 2007

Bonjour,
Je voudrais juste préciser que la partie où tu parles de GRUB est incomplète (je cherche quand même la réponse...).
Par défaut, voici la configuration avec Windows installé sur un disque (le premier je crois, c'est à dire le 0), et Ubuntu sur un autre disque :

timeout		10

title		Ubuntu, kernel 2.6.17-11-generic
root		(hd1,1)
kernel		/boot/vmlinuz-2.6.17-11-generic root=/dev/sdb2 ro quiet splash locale=fr_FR
initrd		/boot/initrd.img-2.6.17-11-generic
quiet
savedefault
boot

title		Ubuntu, kernel 2.6.17-11-generic (recovery mode)
root		(hd1,1)
kernel		/boot/vmlinuz-2.6.17-11-generic root=/dev/sdb2 ro single
initrd		/boot/initrd.img-2.6.17-11-generic
boot

title		Ubuntu, kernel 2.6.17-10-generic
root		(hd1,1)
kernel		/boot/vmlinuz-2.6.17-10-generic root=/dev/sdb2 ro quiet splash locale=fr_FR
initrd		/boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

title		Ubuntu, kernel 2.6.17-10-generic (recovery mode)
root		(hd1,1)
kernel		/boot/vmlinuz-2.6.17-10-generic root=/dev/sdb2 ro single
initrd		/boot/initrd.img-2.6.17-10-generic
boot

title		Ubuntu, memtest86+
root		(hd1,1)
kernel		/boot/memtest86+.bin
quiet
boot

title		Microsoft Windows XP dition familiale
root		(hd0,0)
savedefault
makeactive
chainloader	+1


Voilà donc j'aimerais bien savoir, puisque personne n'a complété depuis le 17 janvier ^^, comment modifier le fichier de boot pour démarer par défaut avec Windows, si quelqu'un a une idée.
Merci d'avance.
Messages postés
2213
Date d'inscription
dimanche 29 octobre 2006
Statut
Contributeur
Dernière intervention
15 novembre 2014
400
Messages postés
2
Date d'inscription
mercredi 14 février 2007
Statut
Membre
Dernière intervention
14 février 2007

Arf merci désolé pour la question stupide.
La réponse plus explicite est là pour ceux que ça intéresse : bootloader dual boot systeme par defaut
Messages postés
1171
Date d'inscription
jeudi 7 septembre 2006
Statut
Membre
Dernière intervention
27 septembre 2010
190
Re,

Merci pour les complément les mec ;)
Je te remercie depuis un moment je restais bloqué fasse à se probleme au final je changer l'ordre des priorité de mes dd pour booter soit sous linux soit sous bt. J'ai pas le temps de tester se soir (un peut tard) mais je ferais le test demain et si sa marche.

Merci encore, cela me donne espoir je vais bien dormir ^^
Voila les nouvelles

J'ai testé merci et cela marche à merveille, merci encore "pakistador"