Net view affiche nom vide [Résolu/Fermé]

Signaler
Messages postés
924
Date d'inscription
mercredi 11 août 2004
Statut
Membre
Dernière intervention
17 janvier 2019
-
Messages postés
924
Date d'inscription
mercredi 11 août 2004
Statut
Membre
Dernière intervention
17 janvier 2019
-
Bonjour,
Chez un client, j'ai constaté quelque chose de plutôt bizarre.

Il a un réseau de machines M$ (XP, Windows 7, etc...), toutes les machines sont dans le même Workgroup. (Pas de domaine).

Lorsque l'on passe la commande "Net view", on affiche la liste des machines, et là, ô surprise... la première machine a un nom invisible...

C:\> Net view    
Nom de serveur         Remarque   

-------------------------------------------------   
\\   
\\PC1   
\\PC2   
\\PAO   
[...]   

La commande s'est terminée correctement.   


Evidemment, même si je vais dans l'explorateur réseau, je vois cette machine sans nom.

Pour voir si quelqu'un ne s'était pas amusé avec le caractère ASCII 255, j'ai fait une boucle for après envoyé le résultat de la commande net view vers un fichier texte et supprimé les lignes "Nom de server Remarque" et "---------------"

for /f %i in (listemachine.txt) do echo %i && ping %i
Et là, la surprise fut totale, il n'y a même pas un caractère 255. Ce qui signifie que le nom de cette machine est vide.

Par un moyen détourné nous avons récupéré son IP et nous savons maintenant de quelle machine il s'agit, mais c'est plutôt étrange comme comportement.

J'ai pensé à un problème de dns car il me semble qu'ils en ont un sur leur réseau.
J'ai demandé au client faire certaines manipulations concernant cette machine
Maintenant qu'on sait de quelle machine il s'agit, je lui ai fait "pinguer" le nom afin de savoir si on a une réponse, puis
Je lui ai demandé de taper la commande
"ping -a <adresse IP>" (le -a permet d'avoir une résolution du nom).
Afin de voir si le retour est bien le nom de la machine ou un blanc...
J'attends la réponse, mais si quelqu'un a une autre idée...


Merci par avance et par Toutatis.



Une idée reçue est souvent une idée morte.

1 réponse

Messages postés
924
Date d'inscription
mercredi 11 août 2004
Statut
Membre
Dernière intervention
17 janvier 2019
290
Pas plus de nouvelle que ça.
J'ai envoyé à mon client des infos pour purger son cache.
Je pense qu'il a du s'en tirer...

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci