Tous les jeux Linux rament à mort [Résolu/Fermé]

Signaler
-
 Utilisateur anonyme -
Bonjour,
Je suis sous Linux depuis quelques temps, et chaque fois que j'essaye de jouer à un jeu téléchargé du genre Openarena ou Warsow, le jeu tourne à une image seconde, ce qui est injouable...
Ma config me permettait pourtant de faire tourner Black Ops sous Windows, donc je ne pense pas que le problème vienne de là.
Mes pilotes de carte graphiques sont à jour.
Quelqu'un pourrait-il m'aider svp ?
Merci d'avance...


7 réponses

Messages postés
29505
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 janvier 2021
7 012
Je pense que ce sont bien tes pilotes graphiques qui posent problème. Tu utilises quoi comme carte vidéo et comme distribution ?

Reporte -moi le résultat de :

lspci
cat /etc/X11/xorg.conf
glxinfo | grep -i render


Bonne chance
lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192SE Wireless LAN Controller (rev 10)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)


cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: Aucun fichier ou dossier de ce type


glxinfo | grep -i render
direct rendering: Yes
OpenGL renderer string: Software Rasterizer
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fragment_program,



Le programme glxinfo n'était pas installé, j'ai donc du l'installer avec sudo.

Stp aide moi !

Edit : Je possède une carte graphique Nvidia G320, et je suis sous Ubuntu 10.10.
Messages postés
29505
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 janvier 2021
7 012
Ok ben le problème c'est que tu n'as pas de fichier /etc/X11/xorg.conf et c'est donc probablement le pilote libre (nv) qui est utilisé au lieu du pilote propriétaire (nvidia), requis pour avoir une bonne accélération 3D.

Tu peux générer ce fichier avec nvidia-xconfig. Vérifie au préalable que le pilote propriétaire est installé :
http://doc.ubuntu-fr.org/nvidia

sudo apt-get update
sudo apt-get install nvidia-xconfig
sudo nvidia-xconfig
sudo service kdm restart


La troisième commande (re)génère le fichier /etc/X11/xorg.conf qui va permettre de lancer le mode graphique en chargeant le pilote propriétaire.

Normalement tu devrais voir le logo nvidia.

Si ton mode graphique ne se lance plus c'est probablement que le pilote propriétaire n'est pas installé. Tu peux le temps de la réparation rebasculer sur le pilote libre en supprimant le fichier /etc/X11/xorg.conf. Pour ce faire bascule en mode texte (ctrl alt f1), loggue toi (rien n'apparaîtra au moment de taper le mot de passe), puis tape :

sudo rm /etc/X11/xorg.conf
sudo service kdm restart


Bonne chance

J'ai installé le pilote propriétaire grace à ton lien, puis j'ai tapé la première commande, qui a apparemment réussie. Seulement, quand je tape la seconde commande, voila ce qui s'affiche :

sudo apt-get install nvidia-xconfig
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet nvidia-xconfig

Mais je ne sais pas comment faire pour trouver le paquet nvidia-xconfig...
Pourrais-tu m'aider une nouvelle fois stp ?
Messages postés
29505
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 janvier 2021
7 012
Ah tiens c'est bizarre, ce paquet existe sous debian mais pas ubuntu. As-tu essayé de déinstaller puis réinstaller ton driver propriétaire ?

Sinon tu peux toujours essayer de récupérer le paquet debian mais ce n'est pas dit que ça s'installe...
https://packages.debian.org/sid/nvidia-xconfig

À titre indicatif voici mon fichier mais la configuration de l'écran serait à adapter dans ton cas :

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 260.19.44  (buildmeister@swio-display-x86-rhel47-04.nvidia.com)  Sun Feb 27 21:50:39 PST 2011


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	BusID          "PCI:3:0:0"
	Option         "NvAGP" "3"
    VideoRAM       131072
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Bonne chance

Bonne nouvelle, je n'ai pas réussi à obtenir le paquet nvidia-xconfig, mais apparemment il suffisait d'installer le pilote propriétaire, car maintenant les jeux fonctionnent sans problème...
Un grand merci à toi ! :D
Messages postés
29505
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 janvier 2021
7 012
Oui je pense que le pilote propriétaire génère pour toi le fichier /etc/X11/xorg.conf (tu peux regarder si tu es curieux) et qu'il doit plus ou moins ressembler au mien. En tout cas si tout marche, c'est parfait !

Bonne continuation et bon jeu !
Oui je viens de vérifier, et le fichier a bien été créé...
Encore merci à toi !