Installation webacula 5.5.0

Résolu
Bonjour,
Alor, j'essai d'installer webacula, sur une Debian 6 squeeze mais la doc n'étant pas très parfaite je viens poser mon problème.

voilà, j'ai quand meme bien suivis la doc et lorsque j'essai d'ouvrir mon interface web, j'ai une page blanche.

et voici l'erreur que g dans le log error d'apache.

[Fri Feb 25 09:56:19 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7 with Suhosin-Patch configured -- resuming normal operations
[Fri Feb 25 09:56:24 2011] [error] [client 127.0.0.1] PHP Fatal error:  Uncaught exception 'Zend_Exception' with message 'Fatal error: Can't connect to SQL server' in /var/www/webacula/html/index.php:177\nStack trace:\n#0 {main}\n  thrown in /var/www/webacula/html/index.php on line 177
root@debian:~#


Merci.

6 réponses

  1. Modérateur
    Est-ce que tu as installé un serveur sql et est ce que celui-ci est lancé ?

    Reporte-moi le résultat de :

    dpkg -l | grep mysql-server
    netstat -ntlp | grep 3306


    Pour installer mysql en roor :

    aptitude update
    aptitude safe-upgrade
    aptitude install mysql-server


    Bonne chance
    0
    1. Merci mais j'ai resolu le probleme c t un probleme de droit sur le dossier /data
      0
      1. Modérateur
        Ok bonne continuation.
        0
        1. Bonjour,

          J'apporte juste une précision supplémentaire, car le message d'erreur persistait malgré toutes les astuces et vérifications proposées dans les forums du net :

          Le mot de passe de la base MySQL dans le fichier ../webacula/application/config.ini doit être entre guillemets :

          db.config.password = "lemotdepasse"

          En effet, en commentant la ligne 177 du fichier ../webacula/html/index.php (cf.message d'erreur), le message d'erreur suivant était :

          Access denied for user 'root'@'localhost' (using password: YES)' in /usr/share/php/Zend/Db/Adapter

          en fait, le même message d'erreur que lors d'un passage de la commande :

          mysql -u root -plemotdepasse

          au lieu de :

          mysql -u root -p"lemotdepasse"

          PI, mon environnement : Debian 6.0.1, PHP 5..3.3-7, Apache 2.2.16, Zendframework 1.10.6-10, Bacula 5.0.2-2, Mysql-server5.0
          0
          1. Modérateur
            En fait ce qui est intéressant, c'est de voir que webacula est basé sur Zend, un framework php. Ainsi on peut imaginer que si tu rencontres d'autres soucis et si tu as des bases en php/zend, tu puisses t'en sortir avec ce qui se dit sur zend.

            Bonne continuation
            0