Permission dossier partagé [Résolu/Fermé]

Signaler
-
Messages postés
397
Date d'inscription
samedi 25 septembre 2010
Statut
Membre
Dernière intervention
20 février 2021
-
Bonjour,

J'ai un petit problème: j'aimerai transférer des fichiers dans le dossier partagé et plus précisément dans un dossier nommé 'Musique' ou il y a encore des sous-dossiers en fonction des artistes mais le petit problème, c'est que quand je veux ajouter 1 ou deux fichiers dans un sous-dossier artiste il me dit que je ne peux pas car je n'ai pas les permissions (c'est un autre utilisateur qui a mis le dossier musique dans partagé et c'est donc lui seulement qui a les droits d'écritures, nous c'est juste de lecture), Bref ! pas de problème je vais dans les info, je déverouille le petit cadenas et je me met ma session pour les droits d'ecriture et de lecture dans l'onglet permission --> jusque la OK .... J'ai beaucoup, beaucoup de sous-dossiers d'artistes et si je dois faire ca pour chaque dossier ca va me prendre des jours... je me suis donc dit : ok je me met la permission d'ecriture sur le dossier source 'Musique' comme ca je pourrai faire tout ce que je veux, eh bien non, je ne sais pas pourquoi mais ca ne change pas les permission pour les sous-dossiers.

Donc, je voudrais savoir comment faire pour que je mette pour ma session toutes les permissions d'ecriture (et de lecture naturellement) pour tout un dossier ( et donc ses sous-dossiers et ses sous-sous dossier ...), y'a pas une option TOUT AUTORISER ???

6 réponses

Messages postés
20136
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 416
Bonjour,
Il y a un utilitaire pour changer les droits d'accès à toute une arborescence, mais il faut le manipuler après avoir bien réfléchi à ce que l'on veut obtenir au niveau des droits, car une fois modifiés, ils est difficile de revenir à l'état initial.
Ces précautions étant données, voici l'outil: BatChmod

Ritchi
Merci, mais n'y a-t-il pas moyen de faire ca simplement sans logiciel ou d'activer une préférence, c'est pas possible qu'une telle option soit pas intégré dans Mac ... ?
Ah voila, c'est bon, j'ai trouvé, en fait quand je change les permissions, il faut aller sur la petite roue dentée pour choisir ce qu'on veut autoriser puis faire "appliquer aux éléments inclus". Voila, voila merci quand même ^^

Autrement tu as la commande chmod dans le terminal.
Si je me trompe pas, le truc suivant :
chmod -r 777 ton_dossier

donne à tout le monde les droits en lecture/ecriture/exécution sur l'intégralité du dossier et de ses sous-dossiers.
Messages postés
20136
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 416
Bonjour,
L'avantage de BatChmod est de le faire sans connaître le Terminal.
De plus, il permet de déverrouiller des fichiers/dossiers ce qui peut être pratique quand on veut vider la corbeille et que cela est refusé car un(des) fichier(s) est(sont) verrouillé(s).

Ritchi
Messages postés
397
Date d'inscription
samedi 25 septembre 2010
Statut
Membre
Dernière intervention
20 février 2021
31
Bonjour,

J'ai un problème peu différent ; je souhaite attribuer une permission de partage de données avec un DD multimedia.
Dans Préferences système, Partage, Partage de fichiers, je clique sur + et je sélectionne les fichiers à partager (musique, photos et videos);
Quand je veux attribuer une autorisation je clique sur utliisateurs et la zone d'attribution "utilisateurs" reste déséspérement vide ; aucune information ne vient me proposer un choix en regard du fichier choisi.

Dans la rubriques Comptes, j'ai bien ouvert un nom d'utilisateurs avec ses droits ; ce nom n'apparait pas non plus.

Alors au secours et merci pour vos conseils
PS le réseau interne fonctionne bien ; lecture des fichiers dans les deux sens ; seul le transfert de données du Mac vers le DD est refusé.
je suis sous MAC OSX 10.6