Impossible de créer un volume logique [Résolu/Fermé]

Signaler
Messages postés
6
Date d'inscription
vendredi 5 février 2010
Statut
Membre
Dernière intervention
17 février 2010
-
Messages postés
153
Date d'inscription
jeudi 5 novembre 2009
Statut
Membre
Dernière intervention
19 février 2012
-
Bonjour,


J'ai un petit exercice à faire il s'agit de Déplacer les données (d'une base de données oracle en termes de fichiers physique) d'un système de fichier actuellement sur une partition d'un disque physique (/dev/hdb1) vers un espace de stockage en LVM.

Pour cela j'ai d'abord crée un volume physique /dev/hdb1, ensuite un groupe de volume vg_group, cependant j'arrive pas à créer un volume logique en fait quand je tape la commande lvcreate -L 3,5G -n lv_nom vg_groupe j'ai l'erreur suivante :

device-mapper ioctl cmd 9 failed: Argument invalid
couldn't load device 'vg_groupe-lv_nom'
failed to activate new lv


j'ai activé mon groupe de volume en utilisant vgchange -a y vg_groupe

mais ça ne fonctionne toujours pas

Je suis vraiment bloquée là dessus, merci pour votre aide

voici la version de lvm : 2.00.31

autre remarques:
quand je tape /etc/init.d/lvm ça ne marche pas il me dit aucun répértoire ou fichier

quand je tape également mkfs .ext3 /dev/vg et j fais tabulation il ne me propose pas le groupe que je veins de créer

c'est vraiement urgent.
Merci

6 réponses

Messages postés
153
Date d'inscription
jeudi 5 novembre 2009
Statut
Membre
Dernière intervention
19 février 2012
33
salut,

ton module device-mapper est bien chargé...?

fais un : cat /proc/misc |more

et regarde que tu as bien device-mapper dedans...
sinon installe ou upgrade ta version souvent ça corrige pas mal de bug...
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
6
Date d'inscription
vendredi 5 février 2010
Statut
Membre
Dernière intervention
17 février 2010

Bonjour,

Merci pour ta réponse rapide, en effet g réinitialisé la partition /dev/hdb et après plusieurs coup ça a marché!! youpi

mnt j'ai un autre petit problème
en fait il faut que je transforme la partition /dev/hdb1 de linux 83 en linux 8e!!!

est ce que tu peux m'aider??
Merci bcp
Messages postés
153
Date d'inscription
jeudi 5 novembre 2009
Statut
Membre
Dernière intervention
19 février 2012
33
??? je comprends pas trop ce que tu veux changer...
Messages postés
6
Date d'inscription
vendredi 5 février 2010
Statut
Membre
Dernière intervention
17 février 2010

il faut que je transforme le type de la partition /dev/hdb1 de linux 83 en linux lvm 8e

Merci
Messages postés
6
Date d'inscription
vendredi 5 février 2010
Statut
Membre
Dernière intervention
17 février 2010

En fait la question est comment modifier le type d'une partition???

Merc
Messages postés
153
Date d'inscription
jeudi 5 novembre 2009
Statut
Membre
Dernière intervention
19 février 2012
33
ah escuse...ben dans ce cas c'est mkfs non ?