Application réduite ds le bureau2 au démarage

Résolu/Fermé
Signaler
Messages postés
183
Date d'inscription
dimanche 17 avril 2005
Statut
Membre
Dernière intervention
22 février 2011
-
Messages postés
183
Date d'inscription
dimanche 17 avril 2005
Statut
Membre
Dernière intervention
22 février 2011
-
Salut,

Bon, j'arrive à ouvrir Thunderbird au démarrage grâce au dossier ~/.kde/autostart.

Mais si je veux qu'à chaque démarrage Thunderbird s'ouvre réduit, dans le tableau de bord du bureau2 (pour qu'il vérifie mes mails mais que je ne le vois pas).

Comment je peux faire SVP ?

3 réponses

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 899
Salut,

Il faut utiliser la commande "kstart" et ses options. Par exemple pour que "thunderbird" s'ouvre sur le bureau 2 et icônifié, il suffit de taper la commande suivante :
kstart --desktop 2 --iconify thunderbird
man kstart pour toutes les options ;-))
0
Messages postés
183
Date d'inscription
dimanche 17 avril 2005
Statut
Membre
Dernière intervention
22 février 2011
13
Merci,

Ca marche, mais à chaque fois il me met le message:
kstart: WARNING: Omitting both --window and --windowclass arguments is not recommended


Quand je regarde l'aide ("kstart --help" et non "man kstart" ;-) ), il me dit:
Options :
  --window <regexp>         Une expression rationnelle correspondant au titre de la fenêtre
  --windowclass <class>     Une chaîne correspondant à la classe de la fenêtre (propriété WM_CLASS).
                            La classe d'une fenêtre peut être trouvée en exécutant la commande « xprop | grep WM_CLASS » et en cliquant sur la fenêtre.
                            Note : si vous ne spécifiez ni titre ni classe de fenêtre, la première fenêtre qui apparaîtra sera prise, ce qui n'est PAS recommandé.


Quand je fais ce qu'il me dit pour obtenir la classe de la fenêtre ("xprop | grep WM_CLASS"), j'obtiens:
WM_CLASS(STRING) = "Gecko", "Thunderbird-bin"


J'ai donc essayé:
kstart --desktop 2 --iconify mozilla-thunderbird --window "Mozilla Thunderbird" --windowclass "Gecko"

mais il n'aime pas du tout (au lieu de me lancer thunderbird, il me met:
Usage: /usr/lib/mozilla-thunderbird-1.0.2/thunderbird-bin [ options ... ] [URL] where options include: 
...


Help please :-/
0
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 899
Place tes options avant la commande et non pas après !

kstart --window "Mozilla Thunderbird" --windowclass "Gecko" --desktop 2 --iconify mozilla-thunderbird
0
Messages postés
183
Date d'inscription
dimanche 17 avril 2005
Statut
Membre
Dernière intervention
22 février 2011
13
Merci, ça m'a mis sur la voie (oublier de mettre "mozilla-thunderbird", c'était pas malin).

J'ai repris la commande telle quelle, mais ça ne amrchait pas (thunderbird se lançait, mais en grand et dans le bureau 1).

C'était les -window et -windowclass qui n'allaient pas.

La commande qui marche sans retourner d'erreur est:
kstart -desktop 2 -iconify -windowclass "Thunderbird-bin" mozilla-thunderbird


Merci encore pour ton coup de main !

PS: Un autre petite question: c'est quoi la différence entre - et -- stp (s'il y en a une) ? Parceque ça réagit pareil avec l'un où l'autre...
0