Iptables

Résolu
Bonjour à tous,

J'ai un problème avec mon pare feu, j'arrive pas à me connecter sur mon serveur Web local.

Je m'explique:
J'ai une machine virtuelle dans laquelle j'ai installé un serveur tomcat.
Sur mon par feu, j'ai fait une redirection de port qui marche bien.

Si j'essaie de me connecter sur mon site web, en désactivant le pare feu, sa marche.
Mais une fois que le pare feu activé, la connexion est impossible.

J'ai repéré la ligne qui bloque:

REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited


J'ai ajouté la règle suivante mais sa marche pas:

iptables -I FORWARD -p tcp -i eth0 --dport 8080 -j ACCEPT


Qu'est ce que j'ai loupé?

Merci d'avance.

3 réponses

  1. Modérateur
    Mmmh je ne suis pas spécialiste d'iptables, mais d'après ce qui est expliqué ici :
    http://doc.ubuntu-fr.org/iptables

    ... j'aurais plutôt dit :

    iptables -A INPUT -p tcp -i eth0 --dport 8080 -j ACCEPT


    Bonne chance
    0
    1. Bonjour,

      Oui j'ai testé aussi mais sa marche pas.
      0
      1. Modérateur
        Tu as supprimé la règle FORWARD ?
        0