Sqlplus
Bonjour,
quand je tape la commande ./sqlplus voila ce que ca me donne :
Error 6 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory
que faut-il faire pour y remedier
please i need your help
quand je tape la commande ./sqlplus voila ce que ca me donne :
Error 6 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory
que faut-il faire pour y remedier
please i need your help
Configuration: Linux Firefox 1.5.0.9
23 réponses
-
bonjour,
verifie que tu es sous le bon repertoir a savoir bin et non pas sqlplus car j'avé la meme erreur que toi -
Je t'en prie :) si t'as encore besoin d'aide je serai là ;)
-
t'a raison je vais reinstaller dans tous les cas je te remercie pour ton aide simo
-
Tu as trouvé au moins le répertoire sqlplus?!!
si c pas le cas, à mon avis tu ferai mieux de réinstaller oracle correctement pour éviter tt problème future! -
ils n'y sont pas suis je obliger de tout reinstaller ou je peux les installer autrement
-
Il faudrait que tu trouves ces deux fichiers "sp1us.msb" et "sp1f.msb" dans le réperoire Oracle_HOME/sqlplus/mesg/
?!!!
ds le set, fais réference à ce réperoire! -
comment je fais pour le desinstaller
je sais qu'il faut aller dans application ajout/enlever des logiciel mais apres je ne sais pas lesquels il faut enlever -
Eh bein je crois que qu'il faudrait réinstaller oracle!
-
ca ne donne rien
-
Je pars assister à une présentation, j'éspère que tu aura résolu le pbm à mon retour :)
-
t'es sûre que c'est le home d'oracle que tu lui donne??
essaies de faire une recherche sur ce fichier "sp1<lang>.msb" comme suit :
[root@Ntsivoa ~]#find / -name "sp1*.msb" -print >$HOME/res.txt
et regardes le contenu du fichier résultant res.txt pour savoir où il est. -
ca me donne tjs la meme erreur a savoir:
Error 6 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory -
Essaies ça :
[root@Ntsivoa ~]#ORACLE_HOME=/home/SIVOA/app/SIVOA/product/11.1.0/db_1/bin
[root@Ntsivoa ~]#export ORACLE_HOME
et relance sqlplus :) -
[root@Ntsivoa ~]# set ORACLE_HOME=/home/SIVOA/app/SIVOA/product/11.1.0/db_1/bin[root@Ntsivoa ~]# export $ORACLE_HOME
declare -x COLORTERM="gnome-terminal"
declare -x CVS_RSH="ssh"
declare -x DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-O8FmQI2fcj,guid=836bc647ad3939ad1f10f2563fe76900"
declare -x DESKTOP_SESSION="default"
declare -x DESKTOP_STARTUP_ID=""
declare -x DISPLAY=":0.0"
declare -x GDMSESSION="default"
declare -x GDM_XSERVER_LOCATION="local"
declare -x GNOME_DESKTOP_SESSION_ID="Default"
declare -x GNOME_KEYRING_SOCKET="/tmp/keyring-IiCL8B/socket"
declare -x GTK_RC_FILES="/etc/gtk/gtkrc:/root/.gtkrc-1.2-gnome2"
declare -x G_BROKEN_FILENAMES="1"
declare -x HISTSIZE="1000"
declare -x HOME="/root"
declare -x HOSTNAME="Ntsivoa"
declare -x INPUTRC="/etc/inputrc"
declare -x LANG="fr_FR.UTF-8"
declare -x LESSOPEN="|/usr/bin/lesspipe.sh %s"
declare -x LOGNAME="root"
declare -x LS_COLORS="no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:"
declare -x MAIL="/var/spool/mail/root"
declare -x OLDPWD
declare -x PATH="/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin"
declare -x PWD="/root"
declare -x SESSION_MANAGER="local/Ntsivoa:/tmp/.ICE-unix/3191"
declare -x SHELL="/bin/bash"
declare -x SHLVL="2"
declare -x SSH_AGENT_PID="3250"
declare -x SSH_ASKPASS="/usr/libexec/openssh/gnome-ssh-askpass"
declare -x SSH_AUTH_SOCK="/tmp/ssh-mesGfr3191/agent.3191"
declare -x TERM="xterm"
declare -x USER="root"
declare -x WINDOWID="48234577"
declare -x XAUTHORITY="/tmp/.gdm84786T"
declare -x XMODIFIERS="@im=none"
declare -x http_proxy="http://10.0.10.9:80"
PS : merci de ton aide -
J epense qu'oracle est mal installé sur ton poste/serveur linux. Essaies de le réinstaller.
Normalement, il ne devrait rien te dire lors du set.
Fais moi un copier coller des lignes de commandes genre :
root#set ORACLE_HOME=..
root#etc -
quand j'ai entré les commandes cela ma donné toute une liste de : declare -x ............ cela veut dire quoi???
-
ok merci je vais essayer et je te tiens au courant
-
dans ce cas essaies de faire un :
set ORACLE_HOME="chemin de l'installl d'oracle" exemple : set ORACLE_HOME=/opt/oracle/bin
suivi de :
export $ORACLE_HOME
et essaies de lancer mnt sqlplus -
quand j'entre la commande ca me donne rien
-
fais un echo $ORACLE_HOME
ça va te donner le home d'oracle là où il est installé :)
- 1
- 2
Suivant