Centreon error
Solved
Hello,
I’m new to computing and I’m experimenting a bit with monitoring, particularly in the Centreon environment. I’ve been struggling for a few days with this error:
SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost'
I want to point out that I am still in the installation phase and that I haven’t created a database yet.
Thank you in advance for the various help you will provide me.
I’m new to computing and I’m experimenting a bit with monitoring, particularly in the Centreon environment. I’ve been struggling for a few days with this error:
SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost'
I want to point out that I am still in the installation phase and that I haven’t created a database yet.
Thank you in advance for the various help you will provide me.
3 answers
-
ModeratorHello,
Indeed, the MySQL user you connect with must have the right to access the database (see this link).
That said, you need to be careful about two things if you want a secure installation:- The MySQL user used by your application should have minimal rights on the database it interacts with: if only read access is necessary, there is no reason for it to have the right to modify the content of the tables or create new ones.
- The MySQL user used by your application should be specific, and certainly not root. If your application is compromised, it becomes possible to hack the entire database.
In summary, I advise you to create a user specific to your application (which typically bears the name of your application) and that has the necessary and sufficient rights for its proper functioning.
After... it's up to you :-)