Partage Windows2003/Linux

Résolu
Bonjour à tous,

J'ai 2 serveurs sur un même LAN (un Debian/Lenny et un Win2003). J'arrive sans problème via Samba à partager un dossier situé sur le Linux, là où je m'arrache les cheveux c'est dans l'autre sens: j'ai un dossier partagé sur Windows 2003 accessible à tous et là quand j'essaye de le monter depuis mon serveur Linux:

mount -t nfs 172.18.2.28:/shared /var/www/partage

Je prends un message:

mount.nfs: mount to NFS server '172.18.2.28' failed: System Error: Connection refused

Si quelqu'un peut m'aider car j'ai pas mal cherché les forums et GG et je sèche :(

Marco
Configuration: Windows XP
Linux Debian

4 réponses

  1. en gardant mount

    mount -t cifs -o user=TONUSER,workgroup=TONDOMAINE //172.18.2.28/shared /mnt/samba/

    tiens nous au courant
    0
    1. Bon et bien un grand MERCI car maintenant ça marche (avec le workgroup de renseigné) !!!

      mount -t cifs -o username=XXX,password=YYY,workgroup=ZZZ //172.18.2.28/shared /var/www/shared

      Merci à tous et à x11r6 :)
      0
  2. humm

    mount.cifs //172.18.2.28/shared /mnt/samba/ -o user=TONUSER pass=PASSWORD domain=TONDOMAINE

    et ça sa donne quoi ?
    0
    1. regarde tes log...pour identifier le sushi
      0
      1. Bon j'ai regardé /var/log/syslog et je trouve:

        Aug 25 14:20:00 VM-SRV-IPV6 kernel: [795366.967902] CIFS: UNC Path does not begin with // or \\
        Aug 25 14:20:00 VM-SRV-IPV6 kernel: [795366.967927] CIFS VFS: cifs_mount failed w/return code = -22

        alors que j'ai essayé avec:

        mount -t cifs //172.18.2.28/shared /var/www/shared
        mount -t cifs \\\\172.18.2.28\\shared /var/www/shared
        mount -t cifs 172.18.2.28:/shared /var/www/shared

        Quels autres logs seraient utiles?
        0
    2. Modérateur
      Ben c'est normal windows utilise lors d'un partage .. samba. Nfs est une alternative bien plus pratique que samba, mais je ne crois pas qu'il existe de client nfs sous windows. En tout cas ce n'est pas nfs qui résoudra ton problème dans le cas présent :-)

      Il faut donc que tu montes le partage sous linux en cifs (qui remplace smbfs). En root :
      mount -t cifs //172.18.2.28/shared /mnt/samba/ -o username=login,password=psswd 

      ... en remplaçant login par ton profil windows et psswd par ton mot de passe windows.

      Tu peux ensuite automatiser ça avec /etc/fstab.

      Il est également possible de mettre ton mot de passe samba dans un fichier séparé et sans droit en lecture afin d'éviter d'avoir le mot de passe samba en clair dans /etc/fstab (lisible par tous les utilisateurs de ta debian).
      https://forums.fedoraforum.org/showthread.php?2696-etc-fstab-cifs-smbfs-passwords-in-cleartext

      Pour plus d'informations :
      man fstab
      man mount

      Bonne chance
      1
      1. Merci mamimando

        mais en cifs je prends:

        mount: wrong fs type, bad option, bad superblock on 172.18.2.28:/shared,
        missing codepage or helper program, or other error
        (for several filesystems (e.g. nfs, cifs) you might
        need a /sbin/mount.<type> helper program)
        In some cases useful info is found in syslog - try
        dmesg | tail or so

        Et pour info c'est la même erreur même si j'essaye de monter un partage qui n'existe pas
        0